summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--libraries/RxCpp/README11
-rw-r--r--libraries/RxCpp/RxCpp.SlackBuild107
-rw-r--r--libraries/RxCpp/RxCpp.info10
-rw-r--r--libraries/RxCpp/RxCpp.patch40
-rw-r--r--libraries/RxCpp/slack-desc19
5 files changed, 187 insertions, 0 deletions
diff --git a/libraries/RxCpp/README b/libraries/RxCpp/README
new file mode 100644
index 0000000000..1e30aae43f
--- /dev/null
+++ b/libraries/RxCpp/README
@@ -0,0 +1,11 @@
+Reactive Extensions for C++.
+
+The ReactiveX Observable model allows you to treat streams of
+asynchronous events with the same sort of simple, composable
+operations that you use for collections of data items like arrays.
+It frees you from tangled webs of callbacks, and thereby makes
+your code more readable and less prone to bugs.
+
+The Reactive Extensions for C++ (RxCpp) is a library of algorithms
+for values-distributed-in-time. The Range-v3 library does the same
+for values-distributed-in-space.
diff --git a/libraries/RxCpp/RxCpp.SlackBuild b/libraries/RxCpp/RxCpp.SlackBuild
new file mode 100644
index 0000000000..ece313157f
--- /dev/null
+++ b/libraries/RxCpp/RxCpp.SlackBuild
@@ -0,0 +1,107 @@
+#!/bin/sh
+
+# Slackware build script for Reactive Extensions for C++
+
+# Copyright 2017 Andre Barboza, Belo Horizonte - Brazil
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=RxCpp
+VERSION=${VERSION:-3.0.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+patch -p1 < $CWD/RxCpp.patch
+mkdir -p build
+cd build
+ cmake \
+ -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DLIB_SUFFIX=${LIBDIRSUFFIX} \
+ -DCMAKE_BUILD_TYPE=Release ..
+ make
+ make install DESTDIR=$PKG
+cd ..
+
+if [ "${BUILD_DOCS}" == "yes" ]; then
+ ( cd projects/doxygen/
+ doxygen doxygen.conf
+ )
+fi
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a AUTHORS.txt DeveloperManual.md README.md Readme.html license.md \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+if [ "${BUILD_DOCS}" == "yes" ]; then
+ cp -ra projects/doxygen/html Rx/v2/examples/ $PKG/usr/doc/$PRGNAM-$VERSION
+fi
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/libraries/RxCpp/RxCpp.info b/libraries/RxCpp/RxCpp.info
new file mode 100644
index 0000000000..2614d0daea
--- /dev/null
+++ b/libraries/RxCpp/RxCpp.info
@@ -0,0 +1,10 @@
+PRGNAM="RxCpp"
+VERSION="3.0.0"
+HOMEPAGE="https://github.com/Reactive-Extensions/RxCpp"
+DOWNLOAD="https://github.com/Reactive-Extensions/RxCpp/archive/v3.0.0/RxCpp-3.0.0.tar.gz"
+MD5SUM="fe37d9e730ab98d5e7c1fb9edb6625cf"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Andre Barboza"
+EMAIL="bmg.andre@gmail.com"
diff --git a/libraries/RxCpp/RxCpp.patch b/libraries/RxCpp/RxCpp.patch
new file mode 100644
index 0000000000..239f607b24
--- /dev/null
+++ b/libraries/RxCpp/RxCpp.patch
@@ -0,0 +1,40 @@
+diff -ur RxCpp-3.0.0.old/projects/CMake/CMakeLists.txt RxCpp-3.0.0/projects/CMake/CMakeLists.txt
+--- RxCpp-3.0.0.old/projects/CMake/CMakeLists.txt 2016-11-25 17:51:43.000000000 -0200
++++ RxCpp-3.0.0/projects/CMake/CMakeLists.txt 2017-01-06 14:25:44.185727167 -0200
+@@ -11,18 +11,18 @@
+
+ MESSAGE( STATUS "RXCPP_DIR: " ${RXCPP_DIR} )
+
+-add_subdirectory(${RXCPP_DIR}/Rx/v2/test ${CMAKE_CURRENT_BINARY_DIR}/test)
++#add_subdirectory(${RXCPP_DIR}/Rx/v2/test ${CMAKE_CURRENT_BINARY_DIR}/test)
+
+ add_subdirectory(${RXCPP_DIR}/projects/doxygen ${CMAKE_CURRENT_BINARY_DIR}/projects/doxygen)
+
+-set(EXAMPLES_DIR ${RXCPP_DIR}/Rx/v2/examples)
++#set(EXAMPLES_DIR ${RXCPP_DIR}/Rx/v2/examples)
+
+-add_subdirectory(${EXAMPLES_DIR}/cep ${CMAKE_CURRENT_BINARY_DIR}/examples/cep)
+-add_subdirectory(${EXAMPLES_DIR}/stop ${CMAKE_CURRENT_BINARY_DIR}/examples/stop)
+-add_subdirectory(${EXAMPLES_DIR}/linesfrombytes ${CMAKE_CURRENT_BINARY_DIR}/examples/linesfrombytes)
+-add_subdirectory(${EXAMPLES_DIR}/println ${CMAKE_CURRENT_BINARY_DIR}/examples/println)
+-add_subdirectory(${EXAMPLES_DIR}/pythagorian ${CMAKE_CURRENT_BINARY_DIR}/examples/pythagorian)
+-add_subdirectory(${EXAMPLES_DIR}/tests ${CMAKE_CURRENT_BINARY_DIR}/examples/tests)
++#add_subdirectory(${EXAMPLES_DIR}/cep ${CMAKE_CURRENT_BINARY_DIR}/examples/cep)
++#add_subdirectory(${EXAMPLES_DIR}/stop ${CMAKE_CURRENT_BINARY_DIR}/examples/stop)
++#add_subdirectory(${EXAMPLES_DIR}/linesfrombytes ${CMAKE_CURRENT_BINARY_DIR}/examples/linesfrombytes)
++#add_subdirectory(${EXAMPLES_DIR}/println ${CMAKE_CURRENT_BINARY_DIR}/examples/println)
++#add_subdirectory(${EXAMPLES_DIR}/pythagorian ${CMAKE_CURRENT_BINARY_DIR}/examples/pythagorian)
++#add_subdirectory(${EXAMPLES_DIR}/tests ${CMAKE_CURRENT_BINARY_DIR}/examples/tests)
+
+ # The list of RxCpp source files. Please add every new file to this list
+ set(RX_SOURCES
+@@ -131,5 +131,6 @@
+
+ set(CMAKE_SKIP_INSTALL_ALL_DEPENDENCY TRUE CACHE BOOL "Don't require all projects to be built in order to install" FORCE)
+
+-install(DIRECTORY ${RXCPP_DIR}/Rx/v2/src/rxcpp/ DESTINATION rxcpp
+- FILES_MATCHING PATTERN "*.hpp")
+\ No newline at end of file
++install(DIRECTORY ${RXCPP_DIR}/Rx/v2/src/rxcpp/ DESTINATION include/rxcpp
++ FILES_MATCHING PATTERN "*.hpp")
++install(TARGETS RxCpp DESTINATION lib${LIB_SUFFIX})
diff --git a/libraries/RxCpp/slack-desc b/libraries/RxCpp/slack-desc
new file mode 100644
index 0000000000..91d3a04d98
--- /dev/null
+++ b/libraries/RxCpp/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+RxCpp: RxCpp (The Reactive Extensions for C++)
+RxCpp:
+RxCpp: The Reactive Extensions for C++ (RxCpp) is a library of algorithms
+RxCpp: for values-distributed-in-time.
+RxCpp:
+RxCpp:
+RxCpp:
+RxCpp:
+RxCpp:
+RxCpp: https://github.com/Reactive-Extensions/RxCpp
+RxCpp: