summaryrefslogtreecommitdiffstats
path: root/academic/PhyML/PhyML.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'academic/PhyML/PhyML.SlackBuild')
-rw-r--r--academic/PhyML/PhyML.SlackBuild12
1 files changed, 7 insertions, 5 deletions
diff --git a/academic/PhyML/PhyML.SlackBuild b/academic/PhyML/PhyML.SlackBuild
index bddb063c00..893454e123 100644
--- a/academic/PhyML/PhyML.SlackBuild
+++ b/academic/PhyML/PhyML.SlackBuild
@@ -25,7 +25,7 @@
# Thanks to Niels Horn for some handy modifications and corrections.
PRGNAM=PhyML
-VERSION=${VERSION:-3.3.20190909}
+VERSION=${VERSION:-3.3.20200621}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -89,7 +89,9 @@ find -L . \
# Use our CFLAGS
sed -i "/^CFLAGS/s/=/+=/" Makefile src/Makefile
-CFLAGS="$SLKCFLAGS" CXXFLAGS="$SLKCFLAGS" make
+# The -mfma flag is needed for building on 14.2. Help is from here:
+# https://github.com/horovod/horovod/issues/1832
+CFLAGS="$SLKCFLAGS -mfma" CXXFLAGS="$SLKCFLAGS -mfma" make
make install DESTDIR=$PKG
# This is PhyML MPI. If you do not want it, comment the lines below. Then you do
@@ -108,7 +110,7 @@ make install DESTDIR=$PKG
# Use our CFLAGS
sed -i "/^CFLAGS/s/=/+=/" Makefile src/Makefile
-CFLAGS="$SLKCFLAGS" CXXFLAGS="$SLKCFLAGS" make
+CFLAGS="$SLKCFLAGS -mfma" CXXFLAGS="$SLKCFLAGS -mfma" make
make install DESTDIR=$PKG
# This is Phyrex
@@ -126,7 +128,7 @@ make install DESTDIR=$PKG
# Use our CFLAGS
sed -i "/^CFLAGS/s/=/+=/" Makefile src/Makefile
-CFLAGS="$SLKCFLAGS" CXXFLAGS="$SLKCFLAGS" make
+CFLAGS="$SLKCFLAGS -mfma" CXXFLAGS="$SLKCFLAGS -mfma" make
make install DESTDIR=$PKG
# This is PhyTime
@@ -144,7 +146,7 @@ make install DESTDIR=$PKG
# Use our CFLAGS
sed -i "/^CFLAGS/s/=/+=/" Makefile src/Makefile
-CFLAGS="$SLKCFLAGS" CXXFLAGS="$SLKCFLAGS" make
+CFLAGS="$SLKCFLAGS -mfma" CXXFLAGS="$SLKCFLAGS -mfma" make
make install DESTDIR=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \