summaryrefslogtreecommitdiffstats
path: root/accessibility/espeak
diff options
context:
space:
mode:
Diffstat (limited to 'accessibility/espeak')
-rw-r--r--accessibility/espeak/README19
-rw-r--r--accessibility/espeak/espeak.187
-rw-r--r--accessibility/espeak/espeak.SlackBuild102
-rw-r--r--accessibility/espeak/espeak.info10
-rw-r--r--accessibility/espeak/makefile.patch17
-rw-r--r--accessibility/espeak/slack-desc19
6 files changed, 0 insertions, 254 deletions
diff --git a/accessibility/espeak/README b/accessibility/espeak/README
deleted file mode 100644
index 19f50b44bc..0000000000
--- a/accessibility/espeak/README
+++ /dev/null
@@ -1,19 +0,0 @@
-eSpeak (a compact open source software speech synthesizer)
-
-eSpeak produces good quality English speech. It uses a different synthesis
-method from other open source text to speech (TTS) engines, and sounds
-quite different. It's perhaps not as natural or "smooth", but some find
-the articulation clearer and easier to listen to for long periods. It
-can run as a command line program to speak text from a file or from stdin.
-
-To build without portaudio support, set WAVONLY=yes in the script's
-environment.
-
-If you get errors like this:
-
-bt_audio_service_open: connect() failed: Connection refused (111)
-
-...either ignore them (if espeak produces audio anyway), or comment out
-the 'pcm.headset' and 'ctl.headset' stanzas in /etc/asound.conf. This
-should only happen if your Slackware system was upgraded from an older
-version.
diff --git a/accessibility/espeak/espeak.1 b/accessibility/espeak/espeak.1
deleted file mode 100644
index c4bb0ea2f1..0000000000
--- a/accessibility/espeak/espeak.1
+++ /dev/null
@@ -1,87 +0,0 @@
-.\" Hey, EMACS: -*- nroff -*-
-.\" First parameter, NAME, should be all caps
-.\" Second parameter, SECTION, should be 1-8, maybe w/ subsection
-.\" other parameters are allowed: see man(7), man(1)
-.TH ESPEAK 1 "June 23, 2006"
-.\" Please adjust this date whenever revising the manpage.
-.\"
-.\" Some roff macros, for reference:
-.\" .nh disable hyphenation
-.\" .hy enable hyphenation
-.\" .ad l left justify
-.\" .ad b justify to both left and right margins
-.\" .nf disable filling
-.\" .fi enable filling
-.\" .br insert line break
-.\" .sp <n> insert n+1 empty lines
-.\" for manpage-specific macros, see man(7)
-.SH NAME
-espeak \- A multi-lingual software speech synthesizer.
-.SH SYNOPSIS
-.B espeak
-.RI [ options ]\ [ "<words>" ]
-.SH DESCRIPTION
-.B espeak
-is a software speech synthesizer for English, and some other languages.
-.SH OPTIONS
-.TP
-.B \-h
-Show summary of options.
-.TP
-.B \-f <text file>
-Text file to speak
-.TP
-.B \-\-stdin
-Read text input from stdin instead of a file
-.TP
-If neither -f nor --stdin, <words> are spoken, or if none then text is spoken from stdin, each line separately.
-.TP
-.B \-q
-Quiet, don't produce any speech (may be useful with -x)
-.TP
-.B \-a <integer>
-Amplitude, 0 to 20, default is 10
-.TP
-.B \-l <integer>
-Line length. If not zero (which is the default), consider
-lines less than this length as and-of-clause
-.TP
-.B \-p <integer>
-Pitch adjustment, 0 to 99, default is 50
-.TP
-.B -s <integer>
-peed in words per minute, default is 160
-.TP
-.B \-v <voice name>
-Use voice file of this name from espeak-data/voices
-.TP
-.B -m
-Indicates that the text contains SSML (Speech Synthesis Markup Language) tags or other XML tags. Those SSML tags which are supported are interpreted. Other tags, including HTML, are ignored, except that some HTML tags such as <hr> <h2> and <li> ensure a break in the speech.
-.TP
-.B \-w <wave file name>
-Write output to this WAV file, rather than speaking it directly
-.TP
-.B \-x
-Write phoneme mnemonics to stdout
-.TP
-.B \-X
-Write phonemes mnemonics and translation trace to stdout
-.TP
-.B \-\-stdout
-Write speech output to stdout
-.TP
-.B \-\-compile=<voice name>
-Compile the pronunciation rules and dictionary in the current directory. =<voice name> is optional and specifies which language
-.TP
-.B \-\-punct="<characters>"
-Speak the names of punctuation characters during speaking. If =<characters> is omitted, all punctuation is spoken.
-.TP
-.B \-k <integer>
-Indicate capital letters with: 1=sound, 2=the word "capitals", higher values = a pitch increase (try -k20).
-.TP
-.B \-\-voices[=<language code>]
-Lists the available voices. If =<language code> is present then only those voices which are suitable for that language are listed.
-.SH AUTHOR
-eSpeak was written by Jonathan Duddington <jonsd@jsd.clara.co.uk>. The webpage for this package can be found at http://espeak.sourceforge.net/.
-.PP
-This manual page was written by Luke Yelavich <themuso@ubuntu.com>, for the Ubuntu project (but may be used by others).
diff --git a/accessibility/espeak/espeak.SlackBuild b/accessibility/espeak/espeak.SlackBuild
deleted file mode 100644
index fb2d960c0c..0000000000
--- a/accessibility/espeak/espeak.SlackBuild
+++ /dev/null
@@ -1,102 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for espeak
-
-# Written by B. Watson (yalhcru@gmail.com)
-
-# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
-
-PRGNAM=espeak
-VERSION=${VERSION:-1.48.04}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION-source
-unzip $CWD/$PRGNAM-$VERSION-source.zip
-cd $PRGNAM-$VERSION-source
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
-
-# Cruft...
-find . -type d -a -name .svn -print0 | xargs -0 rm -rf
-
-# Make the Makefile install everything stripped
-patch -p1 < $CWD/makefile.patch
-
-# Note: there are two executables (speak and espeak). They seem to do the same
-# thing, except "speak" doesn't use libespeak.so at runtime. This package only
-# installs "espeak" (which is how other distros do it, too).
-
-cd src
- if [ "${WAVONLY:-no}" = "yes" ]; then
- EXTRAMAKEFLAGS="AUDIO=none"
- else
- # Let this script die due to "set -e" if no portaudio installed...
- pkg-config --modversion portaudio-2.0
- # portaudio version *should* be 19, but support 18 just in case...
- rm -f portaudio.h
- ln -s portaudio$( pkg-config --modversion portaudio-2.0 ).h portaudio.h
- fi
-
- SLKCFLAGS="$SLKCFLAGS -Wno-narrowing"
- make LIBDIR=/usr/lib$LIBDIRSUFFIX CXXFLAGS="$SLKCFLAGS" $EXTRAMAKEFLAGS
- make install LIBDIR=/usr/lib$LIBDIRSUFFIX DESTDIR=$PKG $EXTRAMAKEFLAGS
- rm -f $PKG/usr/lib$LIBDIRSUFFIX/*.a # guidelines say no static libs
- find $PKG/usr/share -type f -print0 | xargs -0 chmod 644
-cd ..
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -r ReadMe *.txt docs/* $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-find $PKG/usr/doc/$PRGNAM-$VERSION -type f -exec chmod 0644 {} \;
-
-# Man page from Debian
-mkdir -p $PKG/usr/man/man1
-gzip -9c $CWD/$PRGNAM.1 > $PKG/usr/man/man1/$PRGNAM.1.gz
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-if [ "${WAVONLY:-no}" = "yes" ]; then
- sed -i \
- '19s/:/: This package lacks audio support (wav file output only)/' \
- $PKG/install/slack-desc
-fi
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/accessibility/espeak/espeak.info b/accessibility/espeak/espeak.info
deleted file mode 100644
index 380f4b6368..0000000000
--- a/accessibility/espeak/espeak.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="espeak"
-VERSION="1.48.04"
-HOMEPAGE="http://espeak.sourceforge.net/"
-DOWNLOAD="http://downloads.sourceforge.net/espeak/espeak-1.48.04-source.zip"
-MD5SUM="cadd7482eaafe9239546bdc09fa244c3"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="portaudio"
-MAINTAINER="B. Watson"
-EMAIL="yalhcru@gmail.com"
diff --git a/accessibility/espeak/makefile.patch b/accessibility/espeak/makefile.patch
deleted file mode 100644
index ce3f2e7679..0000000000
--- a/accessibility/espeak/makefile.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-diff -Naur espeak-1.44.05-source/src/Makefile espeak-1.44.05-source.patched/src/Makefile
---- espeak-1.44.05-source/src/Makefile 2010-08-13 17:35:09.000000000 -0400
-+++ espeak-1.44.05-source.patched/src/Makefile 2010-12-26 19:31:55.000000000 -0500
-@@ -113,11 +113,9 @@
- $(MKDIR) $(DESTDIR)$(INCDIR)
- $(MKDIR) $(DESTDIR)$(DATADIR)
- # Install espeak executable
-- $(INSTALL) -m 755 $(BIN2_NAME) $(DESTDIR)$(BINDIR)
-+ $(INSTALL) -s -m 755 $(BIN2_NAME) $(DESTDIR)$(BINDIR)
- # Install shared library
-- $(INSTALL) -m 755 $(LIB_NAME).$(LIBTAG) $(DESTDIR)$(LIBDIR)
-- # Install static library
-- $(INSTALL) -m 755 $(STATIC_LIB_NAME) $(DESTDIR)$(LIBDIR)
-+ $(INSTALL) -s -m 755 $(LIB_NAME).$(LIBTAG) $(DESTDIR)$(LIBDIR)
- $(LN_SF) $(LIB_NAME).$(LIBTAG) $(DESTDIR)$(LIBDIR)/$(LIB_NAME).$(LIB_VERSION)
- $(LN_SF) $(LIB_NAME).$(LIB_VERSION) $(DESTDIR)$(LIBDIR)/$(LIB_NAME)
- # Install development headers
diff --git a/accessibility/espeak/slack-desc b/accessibility/espeak/slack-desc
deleted file mode 100644
index 18cc43f6cd..0000000000
--- a/accessibility/espeak/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-espeak: espeak (a compact open source software speech synthesizer)
-espeak:
-espeak: eSpeak produces good quality English speech. It uses a different
-espeak: synthesis method from other open source text to speech (TTS) engines,
-espeak: and sounds quite different. It's perhaps not as natural or "smooth",
-espeak: but some find the articulation clearer and easier to listen to for
-espeak: long periods. It can run as a command line program to speak text from
-espeak: a file or from stdin.
-espeak:
-espeak:
-espeak: