summaryrefslogtreecommitdiffstats
path: root/audio/TiMidity++/patches
diff options
context:
space:
mode:
Diffstat (limited to 'audio/TiMidity++/patches')
-rw-r--r--audio/TiMidity++/patches/autoconf.diff6
-rw-r--r--audio/TiMidity++/patches/patch-tclbitmaps135
-rw-r--r--audio/TiMidity++/patches/patch-tclsh139
-rw-r--r--audio/TiMidity++/patches/timidity++-2.14.0-tcltk86.patch13
4 files changed, 3 insertions, 290 deletions
diff --git a/audio/TiMidity++/patches/autoconf.diff b/audio/TiMidity++/patches/autoconf.diff
index 587df035da..df1398b5b2 100644
--- a/audio/TiMidity++/patches/autoconf.diff
+++ b/audio/TiMidity++/patches/autoconf.diff
@@ -133,7 +133,7 @@ diff -Nur a/autoconf/Makefile.am b/autoconf/Makefile.am
diff -Nur a/configure.in b/configure.in
--- a/configure.in 2012-06-28 17:14:25.000000000 +0300
+++ b/configure.in 2012-10-13 18:19:14.806923746 +0200
-@@ -889,7 +889,7 @@
+@@ -905,7 +905,7 @@
jack: JACK
ao: Libao
vorbis: Ogg Vorbis
@@ -142,7 +142,7 @@ diff -Nur a/configure.in b/configure.in
speex: Ogg Speex
gogo: MP3 GOGO (Only Windows is supported)
],
-@@ -1393,23 +1393,10 @@
+@@ -1409,23 +1409,10 @@
AC_MSG_CHECKING(enable_audio=flac)
if test "x$au_enable_flac" = xyes; then
AC_MSG_RESULT([yes, configuring flac])
@@ -167,7 +167,7 @@ diff -Nur a/configure.in b/configure.in
else
AC_MSG_RESULT(no)
fi
-@@ -1423,11 +1410,6 @@
+@@ -1439,11 +1426,6 @@
EXTRACT_CPPFLAGS(CPPFLAGS,CFLAGS,$LIBFLAC_CFLAGS)
LIBS="$LIBS $LIBFLAC_LIBS"
])
diff --git a/audio/TiMidity++/patches/patch-tclbitmaps b/audio/TiMidity++/patches/patch-tclbitmaps
deleted file mode 100644
index f2e64e59d7..0000000000
--- a/audio/TiMidity++/patches/patch-tclbitmaps
+++ /dev/null
@@ -1,135 +0,0 @@
-commit 009dd7494916089ca8a4a3c15c37bab4bc6fc7c7
-Author: Yair K <cesium2@gmail.com>
-Date: Mon Aug 20 09:32:05 2012 +0200
-
- Include xbm bitmaps in the tcl interface itself
-
- Include xbm bitmaps in the tcl interface itself rather than as files in the
- system.
-
- Also, include tcl.h a bit later to avoid a redefine warning on reverb.h.
-
- Signed-off-by: Hans de Goede <hdegoede@redhat.com>
-
-diff --git a/interface/Makefile.am b/interface/Makefile.am
-index e45ce43..6ce4795 100644
---- a/interface/Makefile.am
-+++ b/interface/Makefile.am
-@@ -275,7 +275,7 @@ if ENABLE_DYNAMIC_XAW
- install_xaw = install.xaw
- endif
-
--install.tk: $(ALLTCLF) install.bitmaps
-+install.tk: $(ALLTCLF)
- test -d $(DESTDIR)$(TCL_DIR) || mkdir -p $(DESTDIR)$(TCL_DIR)
- for f in $(ALLTCLF) ''; do case ".$$f" in .);; *) $(INSTALL_DATA) $$f $(DESTDIR)$(TCL_DIR);; esac; done
-
-diff --git a/interface/tk_c.c b/interface/tk_c.c
-index c5c9074..ff49568 100644
---- a/interface/tk_c.c
-+++ b/interface/tk_c.c
-@@ -46,8 +46,6 @@
- #include <sys/ipc.h>
- #include <sys/shm.h>
- #include <sys/sem.h>
--#include <tcl.h>
--#include <tk.h>
- #include <sys/wait.h>
-
- #include "timidity.h"
-@@ -60,6 +58,9 @@
- #include "miditrace.h"
- #include "aq.h"
-
-+#include <tcl.h>
-+#include <tk.h>
-+
- #ifndef TKPROGPATH
- #define TKPROGPATH PKGLIBDIR "/tkmidity.tcl"
- #endif /* TKPROGPATH */
-@@ -871,6 +872,21 @@ static Tcl_Interp *my_interp;
-
- static int AppInit(Tcl_Interp *interp)
- {
-+#include "bitmaps/back.xbm"
-+#include "bitmaps/fwrd.xbm"
-+#include "bitmaps/next.xbm"
-+#include "bitmaps/pause.xbm"
-+#include "bitmaps/play.xbm"
-+#include "bitmaps/prev.xbm"
-+#include "bitmaps/quit.xbm"
-+#include "bitmaps/stop.xbm"
-+#include "bitmaps/timidity.xbm"
-+
-+#define DefineBitmap(Bitmap) do { \
-+ Tk_DefineBitmap (interp, Tk_GetUid(#Bitmap), Bitmap##_bits, \
-+ Bitmap##_width, Bitmap##_height); \
-+ } while(0)
-+
- my_interp = interp;
-
- if (Tcl_Init(interp) == TCL_ERROR) {
-@@ -890,7 +906,19 @@ static int AppInit(Tcl_Interp *interp)
- (ClientData)NULL, (Tcl_CmdDeleteProc*)NULL);
- Tcl_CreateCommand(interp, "TraceUpdate", (Tcl_CmdProc*) TraceUpdate,
- (ClientData)NULL, (Tcl_CmdDeleteProc*)NULL);
-+
-+ DefineBitmap(back);
-+ DefineBitmap(fwrd);
-+ DefineBitmap(next);
-+ DefineBitmap(pause);
-+ DefineBitmap(play);
-+ DefineBitmap(prev);
-+ DefineBitmap(quit);
-+ DefineBitmap(stop);
-+ DefineBitmap(timidity);
-+
- return TCL_OK;
-+#undef DefineBitmap
- }
-
- /*ARGSUSED*/
-diff --git a/interface/tkpanel.tcl b/interface/tkpanel.tcl
-index e826c54..e64f509 100755
---- a/interface/tkpanel.tcl
-+++ b/interface/tkpanel.tcl
-@@ -87,7 +87,7 @@ proc InitGlobal {} {
- wm title . "TkMidity"
- wm iconname . "TkMidity"
- global bitmap_path
-- wm iconbitmap . @$bitmap_path/timidity.xbm
-+ wm iconbitmap . "timidity"
- }
-
-
-@@ -825,22 +825,14 @@ proc CreateWindow {} {
- global bitmap_path
- frame .body.button -relief raised -bd 1
- pack .body.button -side top -expand 1 -fill x
-- button .body.button.play -bitmap @$bitmap_path/play.xbm\
-- -command "PlayCmd"
-- button .body.button.stop -bitmap @$bitmap_path/stop.xbm\
-- -command "StopCmd"
-- button .body.button.prev -bitmap @$bitmap_path/prev.xbm\
-- -command "PrevCmd"
-- button .body.button.back -bitmap @$bitmap_path/back.xbm\
-- -command "BackwardCmd"
-- button .body.button.fwrd -bitmap @$bitmap_path/fwrd.xbm\
-- -command "ForwardCmd"
-- button .body.button.next -bitmap @$bitmap_path/next.xbm\
-- -command "NextCmd"
-- button .body.button.pause -bitmap @$bitmap_path/pause.xbm\
-- -command "PauseCmd"
-- button .body.button.quit -bitmap @$bitmap_path/quit.xbm\
-- -command "QuitCmd"
-+ button .body.button.play -bitmap "play" -command "PlayCmd"
-+ button .body.button.stop -bitmap "stop" -command "StopCmd"
-+ button .body.button.prev -bitmap "prev" -command "PrevCmd"
-+ button .body.button.back -bitmap "back" -command "BackwardCmd"
-+ button .body.button.fwrd -bitmap "fwrd" -command "ForwardCmd"
-+ button .body.button.next -bitmap "next" -command "NextCmd"
-+ button .body.button.pause -bitmap "pause" -command "PauseCmd"
-+ button .body.button.quit -bitmap "quit" -command "QuitCmd"
- pack .body.button.play .body.button.pause\
- .body.button.prev .body.button.back\
- .body.button.stop\
diff --git a/audio/TiMidity++/patches/patch-tclsh b/audio/TiMidity++/patches/patch-tclsh
deleted file mode 100644
index 6467765360..0000000000
--- a/audio/TiMidity++/patches/patch-tclsh
+++ /dev/null
@@ -1,139 +0,0 @@
-commit 7cbdab2041e378486a74cd9d0ae0b39fb4d1af16
-Author: TAMUKI Shoichi <tamuki@linet.gr.jp>
-Date: Wed Sep 5 12:26:22 2012 +0900
-
- Remove tclIndex due to autogenerated file
-
- auto_mkindex will now run with tclsh instead of wish.
-
-diff --git a/configure.in b/configure.in
-index 286e459..dcc8442 100644
---- a/configure.in
-+++ b/configure.in
-@@ -36,7 +36,7 @@ dnl - add to -L LDFLAGS
- dnl C_INCLUDE_PATH
- dnl - add to -I CPPFLAGS
- dnl MSYS - `yes' if cygnus or Mingw windows environment.
--dnl WISH - wish
-+dnl TCLSH - tclsh
- dnl LN_S - ln -s
- dnl tcltk_dep - make dependencies for tcl/tk interface
- dnl
-@@ -59,7 +59,7 @@ AC_CONFIG_HEADERS([config.h interface.h])
- AM_MAINTAINER_MODE
-
- SHELL=${CONFIG_SHELL-"/bin/sh"}
--WISH=${WISH-"wish"}
-+TCLSH=${TCLSH-"tclsh"}
-
- dnl to use contains() macro (see autoconf/acinclude.m4)
- CONTAINS_INIT
-@@ -2287,7 +2287,7 @@ AC_SUBST(SHCFLAGS)
- AC_SUBST(dynamic_targets)
- AC_SUBST(so)
- AC_SUBST(LN_S)
--AC_SUBST(WISH)
-+AC_SUBST(TCLSH)
- AC_SUBST(tcltk_dep)
- AC_SUBST(program_transform_name)
- AC_SUBST(INTERFACE_SRCS)
-diff --git a/interface/Makefile.am b/interface/Makefile.am
-index 6ce4795..6921a83 100644
---- a/interface/Makefile.am
-+++ b/interface/Makefile.am
-@@ -240,8 +240,7 @@ EXTRA_DIST = \
- tkpanel.tcl \
- browser.tcl \
- misc.tcl \
-- timidity.pel \
-- tclIndex
-+ timidity.pel
-
- .ptcl.tcl:
- sed -e 's@%TCL_DIR%@$(TCL_DIR)@g' $< > $@
-@@ -249,6 +248,8 @@ EXTRA_DIST = \
- sed -e 's@%BIN_DIR%@$(bindir)@g' $< > $@
- clean:
- rm -f tkmidity.tcl
-+ rm -f tclIndex
-+ rm -f timidity.el
- rm -f *.$(OBJEXT)
- rm -f *.$(so)
- rm -f *.res
-@@ -259,7 +260,7 @@ clean:
-
- tclIndex: $(TCLSRCS)
- rm -f tclIndex
-- echo 'auto_mkindex . *.tcl; exit' | $(WISH)
-+ echo 'auto_mkindex $(srcdir) *.tcl; exit' | $(TCLSH)
-
- if ENABLE_TCLTK
- install_tk = install.tk
-diff --git a/interface/tclIndex b/interface/tclIndex
-deleted file mode 100644
-index e62cfcf..0000000
---- a/interface/tclIndex
-+++ /dev/null
-@@ -1,62 +0,0 @@
--# Tcl autoload index file, version 2.0
--# This file is generated by the "auto_mkindex" command
--# and sourced to set up indexing information for one or
--# more commands. Typically each line is a command that
--# sets an element in the auto_index array, where the
--# element name is the name of a command and the value is
--# a script that loads the command.
--
--set auto_index(InitGlobal) [list source [file join $dir tkpanel.tcl]]
--set auto_index(HandleInput) [list source [file join $dir tkpanel.tcl]]
--set auto_index(MakeShuffleList) [list source [file join $dir tkpanel.tcl]]
--set auto_index(AppendMsg) [list source [file join $dir tkpanel.tcl]]
--set auto_index(ClearMsg) [list source [file join $dir tkpanel.tcl]]
--set auto_index(SelectNumber) [list source [file join $dir tkpanel.tcl]]
--set auto_index(SetTime) [list source [file join $dir tkpanel.tcl]]
--set auto_index(DispButtonPlay) [list source [file join $dir tkpanel.tcl]]
--set auto_index(SetVolume) [list source [file join $dir tkpanel.tcl]]
--set auto_index(WriteMsg) [list source [file join $dir tkpanel.tcl]]
--set auto_index(JumpCmd) [list source [file join $dir tkpanel.tcl]]
--set auto_index(VolumeCmd) [list source [file join $dir tkpanel.tcl]]
--set auto_index(LoadCmd) [list source [file join $dir tkpanel.tcl]]
--set auto_index(PlayCmd) [list source [file join $dir tkpanel.tcl]]
--set auto_index(PauseCheck) [list source [file join $dir tkpanel.tcl]]
--set auto_index(PauseCmd) [list source [file join $dir tkpanel.tcl]]
--set auto_index(StopCmd) [list source [file join $dir tkpanel.tcl]]
--set auto_index(QuitCmd) [list source [file join $dir tkpanel.tcl]]
--set auto_index(PrevCmd) [list source [file join $dir tkpanel.tcl]]
--set auto_index(NextCmd) [list source [file join $dir tkpanel.tcl]]
--set auto_index(ForwardCmd) [list source [file join $dir tkpanel.tcl]]
--set auto_index(BackwardCmd) [list source [file join $dir tkpanel.tcl]]
--set auto_index(VolUpCmd) [list source [file join $dir tkpanel.tcl]]
--set auto_index(VolDownCmd) [list source [file join $dir tkpanel.tcl]]
--set auto_index(DispTables) [list source [file join $dir tkpanel.tcl]]
--set auto_index(SaveConfig) [list source [file join $dir tkpanel.tcl]]
--set auto_index(LoadConfig) [list source [file join $dir tkpanel.tcl]]
--set auto_index(InitCmdLine) [list source [file join $dir tkpanel.tcl]]
--set auto_index(SelectList) [list source [file join $dir tkpanel.tcl]]
--set auto_index(OpenFiles) [list source [file join $dir tkpanel.tcl]]
--set auto_index(CloseFiles) [list source [file join $dir tkpanel.tcl]]
--set auto_index(ToggleCurFileMode) [list source [file join $dir tkpanel.tcl]]
--set auto_index(CreateWindow) [list source [file join $dir tkpanel.tcl]]
--set auto_index(filebrowser) [list source [file join $dir browser.tcl]]
--set auto_index(fs:init) [list source [file join $dir browser.tcl]]
--set auto_index(fs:init-lbox) [list source [file join $dir browser.tcl]]
--set auto_index(fs:get-cur-lbox) [list source [file join $dir browser.tcl]]
--set auto_index(fs:select) [list source [file join $dir browser.tcl]]
--set auto_index(fs:selall) [list source [file join $dir browser.tcl]]
--set auto_index(fs:updir) [list source [file join $dir browser.tcl]]
--set auto_index(fs:changedir) [list source [file join $dir browser.tcl]]
--set auto_index(fs:update) [list source [file join $dir browser.tcl]]
--set auto_index(retrieve-filename) [list source [file join $dir misc.tcl]]
--set auto_index(sec2time) [list source [file join $dir misc.tcl]]
--set auto_index(numeric-bind) [list source [file join $dir misc.tcl]]
--set auto_index(my-listbox) [list source [file join $dir misc.tcl]]
--set auto_index(my-dialog) [list source [file join $dir misc.tcl]]
--set auto_index(warning) [list source [file join $dir misc.tcl]]
--set auto_index(error) [list source [file join $dir misc.tcl]]
--set auto_index(information) [list source [file join $dir misc.tcl]]
--set auto_index(question) [list source [file join $dir misc.tcl]]
--set auto_index(rootname) [list source [file join $dir misc.tcl]]
--set auto_index(my-random) [list source [file join $dir misc.tcl]]
--set auto_index(init-random) [list source [file join $dir misc.tcl]]
diff --git a/audio/TiMidity++/patches/timidity++-2.14.0-tcltk86.patch b/audio/TiMidity++/patches/timidity++-2.14.0-tcltk86.patch
deleted file mode 100644
index 23ef62aa03..0000000000
--- a/audio/TiMidity++/patches/timidity++-2.14.0-tcltk86.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-http://bugs.gentoo.org/451296
-
---- a/interface/tk_c.c
-+++ b/interface/tk_c.c
-@@ -913,7 +913,7 @@
- vsnprintf(buf, sizeof(buf), fmt, ap);
- Tcl_Eval(my_interp, buf);
- va_end(ap);
-- return my_interp->result;
-+ return Tcl_GetStringResult(my_interp);
- }
-
- static const char *v_get2(const char *v1, const char *v2)