summaryrefslogtreecommitdiffstats
path: root/audio/eyeD3/eyeD3.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'audio/eyeD3/eyeD3.SlackBuild')
-rw-r--r--audio/eyeD3/eyeD3.SlackBuild22
1 files changed, 16 insertions, 6 deletions
diff --git a/audio/eyeD3/eyeD3.SlackBuild b/audio/eyeD3/eyeD3.SlackBuild
index 2cd673662c..10a2b214ef 100644
--- a/audio/eyeD3/eyeD3.SlackBuild
+++ b/audio/eyeD3/eyeD3.SlackBuild
@@ -1,4 +1,4 @@
-#!/bin/sh
+#!/bin/bash
# Slackware build script for eyeD3
@@ -28,20 +28,30 @@
# No additional license terms added
# Modified by new maintainer: Andrew Strong
+cd $(dirname $0) ; CWD=$(pwd)
+
PRGNAM=eyeD3
-VERSION=${VERSION:-0.8.10}
+VERSION=${VERSION:-0.9.6}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
fi
-CWD=$(pwd)
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
@@ -61,7 +71,7 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python2 setup.py install --root=$PKG
+python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
@@ -74,4 +84,4 @@ mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE