summaryrefslogtreecommitdiffstats
path: root/audio/mktoc
diff options
context:
space:
mode:
Diffstat (limited to 'audio/mktoc')
-rw-r--r--audio/mktoc/README4
-rw-r--r--audio/mktoc/mktoc.SlackBuild18
-rw-r--r--audio/mktoc/mktoc.info4
3 files changed, 19 insertions, 7 deletions
diff --git a/audio/mktoc/README b/audio/mktoc/README
index c0075b4bc7..25dd6f818f 100644
--- a/audio/mktoc/README
+++ b/audio/mktoc/README
@@ -16,3 +16,7 @@ Features:
* Fuzzy file name logic can correct common file name spelling
variations.
* Workaround known TOC file parsing bugs in cdrdao.
+
+Note: mktoc can't handle .wav files that use floating point samples.
+You can convert such wav files to 16-bit integer samples:
+ $ sox input.wav -b16 output.wav
diff --git a/audio/mktoc/mktoc.SlackBuild b/audio/mktoc/mktoc.SlackBuild
index d6694b7362..11f028d8eb 100644
--- a/audio/mktoc/mktoc.SlackBuild
+++ b/audio/mktoc/mktoc.SlackBuild
@@ -1,12 +1,13 @@
-#!/bin/sh
+#!/bin/bash
# Slackware build script for mktoc
# Written by Luis Henrique <email removed>
-# Now maintained by B. Watson <yalhcru@gmail.com>
+# Now maintained by B. Watson <urchlay@slackware.uk>
# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
+# 20211126 bkw: add README note about floating point samples.
# 20180111 bkw:
# - take over maintenance
# - BUILD=2
@@ -17,10 +18,13 @@
# (sorry, this is a pet peeve, I can't not fix it)
# - add man page, basically upstream's README
+cd $(dirname $0) ; CWD=$(pwd)
+
PRGNAM=mktoc
VERSION=${VERSION:-1.3}
BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -30,7 +34,11 @@ if [ -z "$ARCH" ]; then
esac
fi
-CWD=$(pwd)
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
@@ -54,7 +62,7 @@ find . -type f -print0 | xargs -0 chmod 644
# age. Does that mean computers make people illiterate?
patch -p1 < $CWD/lose_not_loose.diff
-python setup.py install --root=$PKG
+python2 setup.py install --root=$PKG
mkdir -p $PKG/usr/man/man1
gzip -9c $CWD/$PRGNAM.1 > $PKG/usr/man/man1/$PRGNAM.1.gz
@@ -67,4 +75,4 @@ mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/audio/mktoc/mktoc.info b/audio/mktoc/mktoc.info
index 0d6b9ed822..15eff4a8f0 100644
--- a/audio/mktoc/mktoc.info
+++ b/audio/mktoc/mktoc.info
@@ -5,6 +5,6 @@ DOWNLOAD="https://github.com/cmcginty/mktoc/raw/master/dist/mktoc-1.3.tar.gz"
MD5SUM="2eabcdc8c9433d1a398e113b8a8299b4"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="python-chardet"
+REQUIRES=""
MAINTAINER="B. Watson"
-EMAIL="yalhcru@gmail.com"
+EMAIL="urchlay@slackware.uk"