summaryrefslogtreecommitdiffstats
path: root/audio/muse
diff options
context:
space:
mode:
Diffstat (limited to 'audio/muse')
-rw-r--r--audio/muse/README2
-rw-r--r--audio/muse/muse.SlackBuild23
-rw-r--r--audio/muse/muse.info12
-rw-r--r--audio/muse/qt512.patch22
4 files changed, 24 insertions, 35 deletions
diff --git a/audio/muse/README b/audio/muse/README
index 83befba3bd..50295f5b64 100644
--- a/audio/muse/README
+++ b/audio/muse/README
@@ -4,7 +4,7 @@ the MusE development team. MusE aims to be a complete multitrack
virtual studio for Linux, it is published under the GNU General Public
License.
-Optional dependencies are fluidsynth, dssi and lash.
+Optional dependencies are dssi and lash.
To start MusE, the user has to be in the "audio" group.
diff --git a/audio/muse/muse.SlackBuild b/audio/muse/muse.SlackBuild
index 76f3dedc57..2644f7dc5f 100644
--- a/audio/muse/muse.SlackBuild
+++ b/audio/muse/muse.SlackBuild
@@ -1,4 +1,4 @@
-#!/bin/sh
+#!/bin/bash
# Slackware build script for muse
@@ -9,10 +9,13 @@
# - don't install docs in /usr/share/doc
# - add realtime capability support
+cd $(dirname $0) ; CWD=$(pwd)
+
PRGNAM=muse
-VERSION=${VERSION:-3.1}
+VERSION=${VERSION:-3.1.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -22,7 +25,14 @@ if [ -z "$ARCH" ]; then
esac
fi
-CWD=$(pwd)
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
@@ -56,7 +66,8 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
-patch -p1 < $CWD/qt512.patch
+# Change the INSTALL_NAME or every path in the package is versioned
+sed -e "s/muse-3.1/muse/" -i CMakeLists.txt
mkdir -p build
cd build
@@ -79,7 +90,7 @@ find $PKG/usr/man -type f -exec gzip -9 {} \;
for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
mkdir -p $PKG/usr/doc
-mv $PKG/usr/share/doc/$PRGNAM-$VERSION $PKG/usr/doc/$PRGNAM-$VERSION
+mv $PKG/usr/share/doc/$PRGNAM $PKG/usr/doc/$PRGNAM-$VERSION
rmdir $PKG/usr/share/doc
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
@@ -96,4 +107,4 @@ if [ "${SETCAP:-yes}" = "yes" ]; then
fi
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/audio/muse/muse.info b/audio/muse/muse.info
index b66465f167..47c0420533 100644
--- a/audio/muse/muse.info
+++ b/audio/muse/muse.info
@@ -1,10 +1,10 @@
PRGNAM="muse"
-VERSION="3.1"
+VERSION="3.1.1"
HOMEPAGE="http://muse-sequencer.org/"
-DOWNLOAD="https://sourceforge.net/projects/lmuse/files/muse-3.1/muse-3.1.tar.gz"
-MD5SUM="45557bf2f0932daedd057678b3faf913"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="jack ladspa_sdk liblo qt5"
+DOWNLOAD="UNSUPPORTED"
+MD5SUM=""
+DOWNLOAD_x86_64="https://downloads.sourceforge.net/lmuse/muse-3.1.1.tar.gz"
+MD5SUM_x86_64="ac9da5c16b670fd6a3139e86845a3d4d"
+REQUIRES="jack ladspa_sdk liblo"
MAINTAINER="Felix Pfeifer"
EMAIL="pfeifer[dot]felix[at]googlemail[dot]com"
diff --git a/audio/muse/qt512.patch b/audio/muse/qt512.patch
deleted file mode 100644
index 4c5e1c2278..0000000000
--- a/audio/muse/qt512.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-diff -Naur muse-3.0.2/muse/mplugins/mitplugin.cpp muse-3.0.2.patched/muse/mplugins/mitplugin.cpp
---- muse-3.0.2/muse/mplugins/mitplugin.cpp 2017-12-04 22:01:18.000000000 +0100
-+++ muse-3.0.2.patched/muse/mplugins/mitplugin.cpp 2020-02-26 23:27:20.013277911 +0100
-@@ -21,6 +21,7 @@
- //
- //=========================================================
-
-+#include <QtWidgets>
- #include "mitplugin.h"
- #include "app.h"
- #include "event.h"
-diff -Naur muse-3.0.2/muse/widgets/genset.cpp muse-3.0.2.patched/muse/widgets/genset.cpp
---- muse-3.0.2/muse/widgets/genset.cpp 2018-01-22 17:43:28.000000000 +0100
-+++ muse-3.0.2.patched/muse/widgets/genset.cpp 2020-02-26 21:47:19.446707723 +0100
-@@ -24,6 +24,7 @@
-
- #include <stdio.h>
-
-+#include <QButtonGroup>
- #include <QFileDialog>
- #include <QFileInfo>
- #include <QRect>