summaryrefslogtreecommitdiffstats
path: root/development/gcclegacy494
diff options
context:
space:
mode:
Diffstat (limited to 'development/gcclegacy494')
-rw-r--r--development/gcclegacy494/942-asan-fix-missing-include-signal-h.patch36
-rw-r--r--development/gcclegacy494/943-Use-ucontext_t-not-struct-ucontext-in-linux-unwind.h.patch190
-rw-r--r--development/gcclegacy494/944-sanitizer-linux.patch88
-rw-r--r--development/gcclegacy494/README8
-rw-r--r--development/gcclegacy494/gcclegacy494.SlackBuild197
-rw-r--r--development/gcclegacy494/gcclegacy494.info20
-rw-r--r--development/gcclegacy494/slack-desc19
-rw-r--r--development/gcclegacy494/ustat.h.patch47
-rw-r--r--development/gcclegacy494/wrapper.sh3
9 files changed, 0 insertions, 608 deletions
diff --git a/development/gcclegacy494/942-asan-fix-missing-include-signal-h.patch b/development/gcclegacy494/942-asan-fix-missing-include-signal-h.patch
deleted file mode 100644
index 5f00c04d2b..0000000000
--- a/development/gcclegacy494/942-asan-fix-missing-include-signal-h.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-From 205aa8e97bab553e5e6fe45896325e97962de704 Mon Sep 17 00:00:00 2001
-From: Rolf Eike Beer <eb@emlix.com>
-Date: Wed, 8 Feb 2017 11:42:52 +0100
-Subject: [PATCH] asan: fix missing include of signal.h
-
-This breaks when building gcc 4.9.4 / 5.4.0 with
-target_platform=powerpc-unknown-linux-gnu with glibc 2.25:
-
-../../../../gcc-host/libsanitizer/asan/asan_linux.cc: In function 'bool __asan::AsanInterceptsSignal(int)':
-../../../../gcc-host/libsanitizer/asan/asan_linux.cc:222:20: error: 'SIGSEGV' was not declared in this scope
- return signum == SIGSEGV && common_flags()->handle_segv;
-
-This has been verified to apply to at least 4.9.4 and up to 5.4,
-the code has been reworked for gcc 6.
-
-Resolves (Buildroot) Bug: https://bugs.busybox.net/show_bug.cgi?id=10061
-
-Upstream: https://patchwork.ozlabs.org/patch/725596/
-
-Signed-off-by: Matthew Weber <matthew.weber@rockwellcollins.com>
----
- libsanitizer/asan/asan_linux.cc | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/libsanitizer/asan/asan_linux.cc b/libsanitizer/asan/asan_linux.cc
-index c504168..59087b9 100644
---- a/libsanitizer/asan/asan_linux.cc
-+++ b/libsanitizer/asan/asan_linux.cc
-@@ -29,6 +29,7 @@
- #include <dlfcn.h>
- #include <fcntl.h>
- #include <pthread.h>
-+#include <signal.h>
- #include <stdio.h>
- #include <unistd.h>
- #include <unwind.h>
diff --git a/development/gcclegacy494/943-Use-ucontext_t-not-struct-ucontext-in-linux-unwind.h.patch b/development/gcclegacy494/943-Use-ucontext_t-not-struct-ucontext-in-linux-unwind.h.patch
deleted file mode 100644
index 526346c6f8..0000000000
--- a/development/gcclegacy494/943-Use-ucontext_t-not-struct-ucontext-in-linux-unwind.h.patch
+++ /dev/null
@@ -1,190 +0,0 @@
-From b7e85069238c40eae54d0ca03ab6d5470d1815f9 Mon Sep 17 00:00:00 2001
-From: jsm28 <jsm28@138bc75d-0d04-0410-961f-82ee72b054a4>
-Date: Tue, 4 Jul 2017 10:25:10 +0000
-Subject: [PATCH] Use ucontext_t not struct ucontext in linux-unwind.h files.
-
-Current glibc no longer gives the ucontext_t type the tag struct
-ucontext, to conform with POSIX namespace rules. This requires
-various linux-unwind.h files in libgcc, that were previously using
-struct ucontext, to be fixed to use ucontext_t instead. This is
-similar to the removal of the struct siginfo tag from siginfo_t some
-years ago.
-
-This patch changes those files to use ucontext_t instead. As the
-standard name that should be unconditionally safe, so this is not
-restricted to architectures supported by glibc, or conditioned on the
-glibc version.
-
-Tested compilation together with current glibc with glibc's
-build-many-glibcs.py.
-
- * config/aarch64/linux-unwind.h (aarch64_fallback_frame_state),
- config/alpha/linux-unwind.h (alpha_fallback_frame_state),
- config/bfin/linux-unwind.h (bfin_fallback_frame_state),
- config/i386/linux-unwind.h (x86_64_fallback_frame_state,
- x86_fallback_frame_state), config/m68k/linux-unwind.h (struct
- uw_ucontext), config/nios2/linux-unwind.h (struct nios2_ucontext),
- config/pa/linux-unwind.h (pa32_fallback_frame_state),
- config/sh/linux-unwind.h (sh_fallback_frame_state),
- config/tilepro/linux-unwind.h (tile_fallback_frame_state),
- config/xtensa/linux-unwind.h (xtensa_fallback_frame_state): Use
- ucontext_t instead of struct ucontext.
-
-git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/branches/gcc-5-branch@249958 138bc75d-0d04-0410-961f-82ee72b054a4
-[Romain backport from gcc-5-branch]
-Signed-off-by: Romain Naour <romain.naour@gmail.com>
----
- libgcc/config/aarch64/linux-unwind.h | 2 +-
- libgcc/config/alpha/linux-unwind.h | 2 +-
- libgcc/config/bfin/linux-unwind.h | 2 +-
- libgcc/config/i386/linux-unwind.h | 4 ++--
- libgcc/config/m68k/linux-unwind.h | 2 +-
- libgcc/config/nios2/linux-unwind.h | 2 +-
- libgcc/config/pa/linux-unwind.h | 2 +-
- libgcc/config/sh/linux-unwind.h | 2 +-
- libgcc/config/tilepro/linux-unwind.h | 2 +-
- libgcc/config/xtensa/linux-unwind.h | 2 +-
- 10 files changed, 11 insertions(+), 11 deletions(-)
-
-diff --git a/libgcc/config/aarch64/linux-unwind.h b/libgcc/config/aarch64/linux-unwind.h
-index 6b5b3cd..d13dc34 100644
---- a/libgcc/config/aarch64/linux-unwind.h
-+++ b/libgcc/config/aarch64/linux-unwind.h
-@@ -52,7 +52,7 @@ aarch64_fallback_frame_state (struct _Unwind_Context *context,
- struct rt_sigframe
- {
- siginfo_t info;
-- struct ucontext uc;
-+ ucontext_t uc;
- };
-
- struct rt_sigframe *rt_;
-diff --git a/libgcc/config/alpha/linux-unwind.h b/libgcc/config/alpha/linux-unwind.h
-index b5bfd1c..166d3d2 100644
---- a/libgcc/config/alpha/linux-unwind.h
-+++ b/libgcc/config/alpha/linux-unwind.h
-@@ -51,7 +51,7 @@ alpha_fallback_frame_state (struct _Unwind_Context *context,
- {
- struct rt_sigframe {
- siginfo_t info;
-- struct ucontext uc;
-+ ucontext_t uc;
- } *rt_ = context->cfa;
- sc = &rt_->uc.uc_mcontext;
- }
-diff --git a/libgcc/config/bfin/linux-unwind.h b/libgcc/config/bfin/linux-unwind.h
-index dc58f0a..8b94568 100644
---- a/libgcc/config/bfin/linux-unwind.h
-+++ b/libgcc/config/bfin/linux-unwind.h
-@@ -52,7 +52,7 @@ bfin_fallback_frame_state (struct _Unwind_Context *context,
- void *puc;
- char retcode[8];
- siginfo_t info;
-- struct ucontext uc;
-+ ucontext_t uc;
- } *rt_ = context->cfa;
-
- /* The void * cast is necessary to avoid an aliasing warning.
-diff --git a/libgcc/config/i386/linux-unwind.h b/libgcc/config/i386/linux-unwind.h
-index 7986928..a9d621c 100644
---- a/libgcc/config/i386/linux-unwind.h
-+++ b/libgcc/config/i386/linux-unwind.h
-@@ -58,7 +58,7 @@ x86_64_fallback_frame_state (struct _Unwind_Context *context,
- if (*(unsigned char *)(pc+0) == 0x48
- && *(unsigned long long *)(pc+1) == RT_SIGRETURN_SYSCALL)
- {
-- struct ucontext *uc_ = context->cfa;
-+ ucontext_t *uc_ = context->cfa;
- /* The void * cast is necessary to avoid an aliasing warning.
- The aliasing warning is correct, but should not be a problem
- because it does not alias anything. */
-@@ -138,7 +138,7 @@ x86_fallback_frame_state (struct _Unwind_Context *context,
- siginfo_t *pinfo;
- void *puc;
- siginfo_t info;
-- struct ucontext uc;
-+ ucontext_t uc;
- } *rt_ = context->cfa;
- /* The void * cast is necessary to avoid an aliasing warning.
- The aliasing warning is correct, but should not be a problem
-diff --git a/libgcc/config/m68k/linux-unwind.h b/libgcc/config/m68k/linux-unwind.h
-index 1ba2a0c4..d67767e 100644
---- a/libgcc/config/m68k/linux-unwind.h
-+++ b/libgcc/config/m68k/linux-unwind.h
-@@ -33,7 +33,7 @@ see the files COPYING3 and COPYING.RUNTIME respectively. If not, see
- /* <sys/ucontext.h> is unfortunately broken right now. */
- struct uw_ucontext {
- unsigned long uc_flags;
-- struct ucontext *uc_link;
-+ ucontext_t *uc_link;
- stack_t uc_stack;
- mcontext_t uc_mcontext;
- unsigned long uc_filler[80];
-diff --git a/libgcc/config/nios2/linux-unwind.h b/libgcc/config/nios2/linux-unwind.h
-index ba4bd80..8978868 100644
---- a/libgcc/config/nios2/linux-unwind.h
-+++ b/libgcc/config/nios2/linux-unwind.h
-@@ -38,7 +38,7 @@ struct nios2_mcontext {
-
- struct nios2_ucontext {
- unsigned long uc_flags;
-- struct ucontext *uc_link;
-+ ucontext_t *uc_link;
- stack_t uc_stack;
- struct nios2_mcontext uc_mcontext;
- sigset_t uc_sigmask; /* mask last for extensibility */
-diff --git a/libgcc/config/pa/linux-unwind.h b/libgcc/config/pa/linux-unwind.h
-index 4a3cfff..d2ac437 100644
---- a/libgcc/config/pa/linux-unwind.h
-+++ b/libgcc/config/pa/linux-unwind.h
-@@ -80,7 +80,7 @@ pa32_fallback_frame_state (struct _Unwind_Context *context,
- struct sigcontext *sc;
- struct rt_sigframe {
- siginfo_t info;
-- struct ucontext uc;
-+ ucontext_t uc;
- } *frame;
-
- /* rt_sigreturn trampoline:
-diff --git a/libgcc/config/sh/linux-unwind.h b/libgcc/config/sh/linux-unwind.h
-index 4875706..671bde7 100644
---- a/libgcc/config/sh/linux-unwind.h
-+++ b/libgcc/config/sh/linux-unwind.h
-@@ -180,7 +180,7 @@ sh_fallback_frame_state (struct _Unwind_Context *context,
- {
- struct rt_sigframe {
- siginfo_t info;
-- struct ucontext uc;
-+ ucontext_t uc;
- } *rt_ = context->cfa;
- /* The void * cast is necessary to avoid an aliasing warning.
- The aliasing warning is correct, but should not be a problem
-diff --git a/libgcc/config/tilepro/linux-unwind.h b/libgcc/config/tilepro/linux-unwind.h
-index 27481cf..c24d58c 100644
---- a/libgcc/config/tilepro/linux-unwind.h
-+++ b/libgcc/config/tilepro/linux-unwind.h
-@@ -61,7 +61,7 @@ tile_fallback_frame_state (struct _Unwind_Context *context,
- struct rt_sigframe {
- unsigned char save_area[C_ABI_SAVE_AREA_SIZE];
- siginfo_t info;
-- struct ucontext uc;
-+ ucontext_t uc;
- } *rt_;
-
- /* Return if this is not a signal handler. */
-diff --git a/libgcc/config/xtensa/linux-unwind.h b/libgcc/config/xtensa/linux-unwind.h
-index 6832d0b..cb15b4c 100644
---- a/libgcc/config/xtensa/linux-unwind.h
-+++ b/libgcc/config/xtensa/linux-unwind.h
-@@ -63,7 +63,7 @@ xtensa_fallback_frame_state (struct _Unwind_Context *context,
-
- struct rt_sigframe {
- siginfo_t info;
-- struct ucontext uc;
-+ ucontext_t uc;
- } *rt_;
-
- /* movi a2, __NR_rt_sigreturn; syscall */
---
-2.9.5
-
diff --git a/development/gcclegacy494/944-sanitizer-linux.patch b/development/gcclegacy494/944-sanitizer-linux.patch
deleted file mode 100644
index caadf2de7b..0000000000
--- a/development/gcclegacy494/944-sanitizer-linux.patch
+++ /dev/null
@@ -1,88 +0,0 @@
-From f9a35ba5c150da2e381c4cab01f8f12bcd6af5d2 Mon Sep 17 00:00:00 2001
-From: jakub <jakub@138bc75d-0d04-0410-961f-82ee72b054a4>
-Date: Mon, 17 Jul 2017 19:41:08 +0000
-Subject: [PATCH] Backported from mainline 2017-07-14 Jakub
- Jelinek <jakub@redhat.com>
-
- PR sanitizer/81066
- * sanitizer_common/sanitizer_linux.h: Cherry-pick upstream r307969.
- * sanitizer_common/sanitizer_linux.cc: Likewise.
- * sanitizer_common/sanitizer_stoptheworld_linux_libcdep.cc: Likewise.
- * tsan/tsan_platform_linux.cc: Likewise.
-
-git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/branches/gcc-7-branch@250287 138bc75d-0d04-0410-961f-82ee72b054a4
-(cherry picked from commit 72edc2c02f8b4768ad660f46a1c7e2400c0a8e06)
-[Romain backport to 4.9.4]
-Signed-off-by: Romain Naour <romain.naour@gmail.com>
----
- libsanitizer/sanitizer_common/sanitizer_linux.cc | 3 +--
- libsanitizer/sanitizer_common/sanitizer_linux.h | 4 +---
- libsanitizer/sanitizer_common/sanitizer_stoptheworld_linux_libcdep.cc | 2 +-
- libsanitizer/tsan/tsan_platform_linux.cc | 2 +-
- 4 files changed, 4 insertions(+), 7 deletions(-)
-
-diff --git a/libsanitizer/sanitizer_common/sanitizer_linux.cc b/libsanitizer/sanitizer_common/sanitizer_linux.cc
-index 69c9c10..8e53673 100644
---- a/libsanitizer/sanitizer_common/sanitizer_linux.cc
-+++ b/libsanitizer/sanitizer_common/sanitizer_linux.cc
-@@ -599,8 +599,7 @@ uptr internal_prctl(int option, uptr arg2, uptr arg3, uptr arg4, uptr arg5) {
- return internal_syscall(__NR_prctl, option, arg2, arg3, arg4, arg5);
- }
-
--uptr internal_sigaltstack(const struct sigaltstack *ss,
-- struct sigaltstack *oss) {
-+uptr internal_sigaltstack(const void *ss, void *oss) {
- return internal_syscall(__NR_sigaltstack, (uptr)ss, (uptr)oss);
- }
-
-diff --git a/libsanitizer/sanitizer_common/sanitizer_linux.h b/libsanitizer/sanitizer_common/sanitizer_linux.h
-index 6422df1..8e111d1 100644
---- a/libsanitizer/sanitizer_common/sanitizer_linux.h
-+++ b/libsanitizer/sanitizer_common/sanitizer_linux.h
-@@ -18,7 +18,6 @@
- #include "sanitizer_platform_limits_posix.h"
-
- struct link_map; // Opaque type returned by dlopen().
--struct sigaltstack;
-
- namespace __sanitizer {
- // Dirent structure for getdents(). Note that this structure is different from
-@@ -28,8 +27,7 @@ struct linux_dirent;
- // Syscall wrappers.
- uptr internal_getdents(fd_t fd, struct linux_dirent *dirp, unsigned int count);
- uptr internal_prctl(int option, uptr arg2, uptr arg3, uptr arg4, uptr arg5);
--uptr internal_sigaltstack(const struct sigaltstack* ss,
-- struct sigaltstack* oss);
-+uptr internal_sigaltstack(const void* ss, void* oss);
- uptr internal_sigaction(int signum, const __sanitizer_kernel_sigaction_t *act,
- __sanitizer_kernel_sigaction_t *oldact);
- uptr internal_sigprocmask(int how, __sanitizer_kernel_sigset_t *set,
-diff --git a/libsanitizer/sanitizer_common/sanitizer_stoptheworld_linux_libcdep.cc b/libsanitizer/sanitizer_common/sanitizer_stoptheworld_linux_libcdep.cc
-index 6ee63ec..50c21a3 100644
---- a/libsanitizer/sanitizer_common/sanitizer_stoptheworld_linux_libcdep.cc
-+++ b/libsanitizer/sanitizer_common/sanitizer_stoptheworld_linux_libcdep.cc
-@@ -238,7 +238,7 @@ static int TracerThread(void* argument) {
-
- // Alternate stack for signal handling.
- InternalScopedBuffer<char> handler_stack_memory(kHandlerStackSize);
-- struct sigaltstack handler_stack;
-+ stack_t handler_stack;
- internal_memset(&handler_stack, 0, sizeof(handler_stack));
- handler_stack.ss_sp = handler_stack_memory.data();
- handler_stack.ss_size = kHandlerStackSize;
-diff --git a/libsanitizer/tsan/tsan_platform_linux.cc b/libsanitizer/tsan/tsan_platform_linux.cc
-index fe69430..49f5270 100644
---- a/libsanitizer/tsan/tsan_platform_linux.cc
-+++ b/libsanitizer/tsan/tsan_platform_linux.cc
-@@ -351,7 +351,7 @@ bool IsGlobalVar(uptr addr) {
- // closes within glibc. The code is a pure hack.
- int ExtractResolvFDs(void *state, int *fds, int nfd) {
- int cnt = 0;
-- __res_state *statp = (__res_state*)state;
-+ struct __res_state *statp = (struct __res_state*)state;
- for (int i = 0; i < MAXNS && cnt < nfd; i++) {
- if (statp->_u._ext.nsaddrs[i] && statp->_u._ext.nssocks[i] != -1)
- fds[cnt++] = statp->_u._ext.nssocks[i];
---
-2.9.5
-
diff --git a/development/gcclegacy494/README b/development/gcclegacy494/README
deleted file mode 100644
index df52926ff9..0000000000
--- a/development/gcclegacy494/README
+++ /dev/null
@@ -1,8 +0,0 @@
-The GNU Compiler Collection includes front ends for C, C++,
-Objective-C, Fortran, Ada, and Go, as well as libraries for these
-languages (libstdc++,...). GCC was originally written as the compiler
-for the GNU operating system. The GNU system was developed to be 100%
-free software, free in the sense that it respects the user's freedom.
-
-This script only compiles the GNU C, and C++ front ends. This script
-was written with the intention to compile a better PaleMoon.
diff --git a/development/gcclegacy494/gcclegacy494.SlackBuild b/development/gcclegacy494/gcclegacy494.SlackBuild
deleted file mode 100644
index 1c1fb412a8..0000000000
--- a/development/gcclegacy494/gcclegacy494.SlackBuild
+++ /dev/null
@@ -1,197 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for gcc-4.9.4
-
-# Copyright 2017 Vasily Sora USA
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM=gcclegacy494
-VERSION=${VERSION:-4.9.4}
-BUILD=${BUILD:-5}
-TAG=${TAG:-_SBo}
-
-INSTLOC=${INSTLOC:-/opt/$PRGNAM}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i386" ]; then
- SLKCFLAGS="-O2 -march=i386 -mcpu=i686"
- LIBDIRSUFFIX=""
- LIB_ARCH=i386
-elif [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
- LIBDIRSUFFIX=""
- LIB_ARCH=i386
-elif [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
- LIB_ARCH=i386
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686"
- LIBDIRSUFFIX=""
- LIB_ARCH=i386
-elif [ "$ARCH" = "s390" ]; then
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
- LIB_ARCH=s390
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
- LIB_ARCH=amd64
-elif [ "$ARCH" = "armv7hl" ]; then
- SLKCFLAGS="-O3 -march=armv7-a -mfpu=vfpv3-d16"
- LIBDIRSUFFIX=""
- LIB_ARCH=armv7hl
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
- LIB_ARCH=$ARCH
-fi
-
-case "$ARCH" in
- arm*) TARGET=$ARCH-slackware-linux-gnueabi ;;
- *) TARGET=$ARCH-slackware-linux ;;
-esac
-
-if [ "$ARCH" = "x86_64" ]; then
- GCC_ARCHOPTS="--disable-multilib"
-else
- GCC_ARCHOPTS="--with-arch=$ARCH"
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf gcc-$VERSION
-tar xvf $CWD/gcc-$VERSION.tar.gz
-cd gcc-$VERSION
-
-tar xjf $CWD/mpfr-2.4.2.tar.bz2
-ln -sf mpfr-2.4.2 mpfr
-tar xjf $CWD/gmp-4.3.2.tar.bz2
-ln -sf gmp-4.3.2 gmp
-tar xzf $CWD/mpc-0.8.1.tar.gz
-ln -sf mpc-0.8.1 mpc
-tar xjf $CWD/isl-0.12.2.tar.bz2
-ln -sf isl-0.12.2 isl
-tar xzf $CWD/cloog-0.18.1.tar.gz
-ln -sf cloog-0.18.1 cloog
-
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-# Do not run fixincludes
-cp -v gcc/Makefile.in{,.orig}
-sed 's@\./fixinc\.sh@-c true@' gcc/Makefile.in.orig > gcc/Makefile.in
-
-# Apply patches if we are compiling against glibc version greater than 2.23
-minor="$(ldd --version | head -1 | sed -e 's/.*2\.//')"
-if [ "$minor" -gt "23" ]; then
- patch -p1 -i "$CWD/942-asan-fix-missing-include-signal-h.patch"
- patch -p1 -i "$CWD/943-Use-ucontext_t-not-struct-ucontext-in-linux-unwind.h.patch"
- patch -p1 -i "$CWD/944-sanitizer-linux.patch"
- patch -p1 -i "$CWD/ustat.h.patch"
- if [ "$minor" = "26" ]; then
- export glibcxx_cv_c99_math=yes
- fi
-fi
-
-rm -rf $TMP/objdir
-mkdir $TMP/objdir
-cd $TMP/objdir
-
-CFLAGS="$SLKCFLAGS" \
-CXXFLAGS="$SLKCFLAGS" \
-../gcc-$VERSION/configure --prefix=$INSTLOC \
- --program-suffix=-$VERSION \
- --enable-languages=c,c++ \
- --with-system-zlib \
- --libdir=$INSTLOC/lib$LIBDIRSUFFIX \
- --enable-threads=posix \
- --disable-gtktest \
- --target=${TARGET} \
- --build=${TARGET} \
- --host=${TARGET} \
- $GCC_ARCHOPTS \
- --with-arch-directory=$LIB_ARCH \
- --enable-clocale=gnu \
- --with-gnu-ld \
- --enable-shared \
- --enable-__cxa_atexit
-make
-make DESTDIR=$PKG install-strip
-
-# Thank you to 'idlemoor'
-mkdir -p $PKG/usr/bin
-cd $PKG/usr/bin
-for COMPILER in gcc g++ ; do
- sed \
- -e "s~%LIBDIRSUFFIX%~$LIBDIRSUFFIX~" \
- -e "s~%COMPILER%~$COMPILER~" \
- -e "s~%INSTLOC%~$INSTLOC~" \
- < $CWD/wrapper.sh \
- > $PKG/usr/bin/$ARCH-slackware-linux-$COMPILER-$VERSION
- chmod ugo+x $PKG/usr/bin/$ARCH-slackware-linux-$COMPILER-$VERSION
-done
-ln -s $ARCH-slackware-linux-gcc-$VERSION $PKG/usr/bin/gcc-$VERSION
-ln -s $ARCH-slackware-linux-g++-$VERSION $PKG/usr/bin/g++-gcc-$VERSION
-
-mv -f $PKG$INSTLOC/share/man $PKG/usr/man
-cd $PKG/usr/man/man7
-# we do not need these; according to "diff" there is no difference between these files
-# and the ones Slackware ships with; except this man page named "gfdl.7"; which shall be
-# saved; and renamed so that it does not conflict with Slackware's.
-find . ! -name 'gfdl.7' -exec rm -rf {} \;
-mv gfdl.7 gfdl494.7
-find $PKG/usr/man -type f -exec gzip -9 {} \;
-for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
-
-mv -f $PKG$INSTLOC/share/info $PKG/usr/info
-rm -f $PKG/usr/info/dir
-cd $PKG/usr/info
-#rename the .info files so they do not conflict with Slackware's own .info files.
-for info in *.info; do mv "$info" "${info%.*}-$VERSION.info"; done
-gzip -9 $PKG/usr/info/*.info*
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/development/gcclegacy494/gcclegacy494.info b/development/gcclegacy494/gcclegacy494.info
deleted file mode 100644
index 64786e47f2..0000000000
--- a/development/gcclegacy494/gcclegacy494.info
+++ /dev/null
@@ -1,20 +0,0 @@
-PRGNAM="gcclegacy494"
-VERSION="4.9.4"
-HOMEPAGE="https://gcc.gnu.org/"
-DOWNLOAD="http://ponce.cc/slackware/sources/repo/gcclegacy494/gcc-4.9.4.tar.gz \
- http://ponce.cc/slackware/sources/repo/gcclegacy494/cloog-0.18.1.tar.gz \
- http://ponce.cc/slackware/sources/repo/gcclegacy494/isl-0.12.2.tar.bz2 \
- http://ponce.cc/slackware/sources/repo/gcclegacy494/mpc-0.8.1.tar.gz \
- http://ponce.cc/slackware/sources/repo/gcclegacy494/gmp-4.3.2.tar.bz2 \
- http://ponce.cc/slackware/sources/repo/gcclegacy494/mpfr-2.4.2.tar.bz2"
-MD5SUM="b92b423b2f8f517c909fda2621ff2d7c \
- e34fca0540d840e5d0f6427e98c92252 \
- e039bfcfb6c2ab039b8ee69bf883e824 \
- 5b34aa804d514cc295414a963aedb6bf \
- dd60683d7057917e34630b4a787932e8 \
- 89e59fe665e2b3ad44a6789f40b059a0"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="khronosschoty"
-EMAIL="khronosschoty@posteo.org"
diff --git a/development/gcclegacy494/slack-desc b/development/gcclegacy494/slack-desc
deleted file mode 100644
index 8648e399dd..0000000000
--- a/development/gcclegacy494/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-gcclegacy494: gcclegacy494 (GNU gcc-4.9.4 and GNU g++-4.9.4 compilers)
-gcclegacy494:
-gcclegacy494: The GNU Compiler Collection includes front ends for C, C++,
-gcclegacy494: Objective-C, Fortran, Ada and Go, as well as libraries for these
-gcclegacy494: (libstdc++,...)
-gcclegacy494:
-gcclegacy494:
-gcclegacy494:
-gcclegacy494: https://gcc.gnu.org/
-gcclegacy494:
-gcclegacy494:
diff --git a/development/gcclegacy494/ustat.h.patch b/development/gcclegacy494/ustat.h.patch
deleted file mode 100644
index e22c33ef9f..0000000000
--- a/development/gcclegacy494/ustat.h.patch
+++ /dev/null
@@ -1,47 +0,0 @@
-*** a/libsanitizer/sanitizer_common/sanitizer_platform_limits_posix.cc 2018-10-31 11:20:33.419203838 -0700
---- b/libsanitizer/sanitizer_common/sanitizer_platform_limits_posix.cc 2018-10-31 12:18:50.202725160 -0700
-***************
-*** 81,87 ****
- #include <sys/statvfs.h>
- #include <sys/timex.h>
- #include <sys/user.h>
-- #include <sys/ustat.h>
- #include <linux/cyclades.h>
- #include <linux/if_eql.h>
- #include <linux/if_plip.h>
---- 81,86 ----
-***************
-*** 163,172 ****
- unsigned struct_old_utsname_sz = sizeof(struct old_utsname);
- unsigned struct_oldold_utsname_sz = sizeof(struct oldold_utsname);
- unsigned struct_itimerspec_sz = sizeof(struct itimerspec);
-- unsigned struct_ustat_sz = sizeof(struct ustat);
- #endif // SANITIZER_LINUX
-
- #if SANITIZER_LINUX && !SANITIZER_ANDROID
- unsigned struct_rlimit64_sz = sizeof(struct rlimit64);
- unsigned struct_timex_sz = sizeof(struct timex);
- unsigned struct_msqid_ds_sz = sizeof(struct msqid_ds);
---- 162,183 ----
- unsigned struct_old_utsname_sz = sizeof(struct old_utsname);
- unsigned struct_oldold_utsname_sz = sizeof(struct oldold_utsname);
- unsigned struct_itimerspec_sz = sizeof(struct itimerspec);
- #endif // SANITIZER_LINUX
-
- #if SANITIZER_LINUX && !SANITIZER_ANDROID
-+ // Use pre-computed size of struct ustat to avoid <sys/ustat.h> which
-+ // has been removed from glibc 2.28.
-+ #if defined(__aarch64__) || defined(__s390x__) || defined (__mips64) \
-+ || defined(__powerpc64__) || defined(__arch64__) || defined(__sparcv9) \
-+ || defined(__x86_64__)
-+ #define SIZEOF_STRUCT_USTAT 32
-+ #elif defined(__arm__) || defined(__i386__) || defined(__mips__) \
-+ || defined(__powerpc__) || defined(__s390__)
-+ #define SIZEOF_STRUCT_USTAT 20
-+ #else
-+ #error Unknown size of struct ustat
-+ #endif
-+ unsigned struct_ustat_sz = SIZEOF_STRUCT_USTAT;
- unsigned struct_rlimit64_sz = sizeof(struct rlimit64);
- unsigned struct_timex_sz = sizeof(struct timex);
- unsigned struct_msqid_ds_sz = sizeof(struct msqid_ds);
diff --git a/development/gcclegacy494/wrapper.sh b/development/gcclegacy494/wrapper.sh
deleted file mode 100644
index d664f74edf..0000000000
--- a/development/gcclegacy494/wrapper.sh
+++ /dev/null
@@ -1,3 +0,0 @@
-#!/bin/sh
-export LD_LIBRARY_PATH=%INSTLOC%/lib%LIBDIRSUFFIX%
-exec %INSTLOC%/bin/%COMPILER%-4.9.4 "$@"