summaryrefslogtreecommitdiffstats
path: root/development/neovim-remote
diff options
context:
space:
mode:
Diffstat (limited to 'development/neovim-remote')
-rw-r--r--development/neovim-remote/README2
-rw-r--r--development/neovim-remote/neovim-remote.SlackBuild23
-rw-r--r--development/neovim-remote/neovim-remote.info8
3 files changed, 19 insertions, 14 deletions
diff --git a/development/neovim-remote/README b/development/neovim-remote/README
index b2d9c28ded..dff9a31920 100644
--- a/development/neovim-remote/README
+++ b/development/neovim-remote/README
@@ -1,3 +1 @@
Control nvim processes using "nvr" commandline tool.
-
-Dependencies should be built with python3 support.
diff --git a/development/neovim-remote/neovim-remote.SlackBuild b/development/neovim-remote/neovim-remote.SlackBuild
index ff6e203f8f..490fba47ed 100644
--- a/development/neovim-remote/neovim-remote.SlackBuild
+++ b/development/neovim-remote/neovim-remote.SlackBuild
@@ -1,8 +1,8 @@
-#!/bin/sh
+#!/bin/bash
# Slackware build script for neovim-remote
-# Copyright 2020, Alexander Verbovetsky, Moscow, Russia
+# Copyright 2020-2022, Alexander Verbovetsky, Moscow, Russia
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -22,10 +22,13 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+cd $(dirname $0) ; CWD=$(pwd)
+
PRGNAM=neovim-remote
-VERSION=${VERSION:-2.4.0}
-BUILD=${BUILD:-1}
+VERSION=${VERSION:-2.5.1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -35,7 +38,11 @@ if [ -z "$ARCH" ]; then
esac
fi
-CWD=$(pwd)
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
@@ -74,8 +81,8 @@ python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-mkdir -p $PKG/etc/bash_completion.d
-cp contrib/completion.bash $PKG/etc/bash_completion.d/neovim-remote.new
+mkdir -p $PKG/usr/share/bash-completion/completions
+cp contrib/completion.bash $PKG/usr/share/bash-completion/completions/neovim-remote
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a README.md $PKG/usr/doc/$PRGNAM-$VERSION
@@ -86,4 +93,4 @@ cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/development/neovim-remote/neovim-remote.info b/development/neovim-remote/neovim-remote.info
index 2e84053d0d..4e2e9022a9 100644
--- a/development/neovim-remote/neovim-remote.info
+++ b/development/neovim-remote/neovim-remote.info
@@ -1,10 +1,10 @@
PRGNAM="neovim-remote"
-VERSION="2.4.0"
+VERSION="2.5.1"
HOMEPAGE="https://github.com/mhinz/neovim-remote"
-DOWNLOAD="https://github.com/mhinz/neovim-remote/archive/v2.4.0/neovim-remote-2.4.0.tar.gz"
-MD5SUM="c49c70b8f4725bf69aed152db62d593c"
+DOWNLOAD="https://github.com/mhinz/neovim-remote/archive/v2.5.1/neovim-remote-2.5.1.tar.gz"
+MD5SUM="a30ea48264ca459df2c488009d1cffd0"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="python3 python-neovim psutil"
+REQUIRES="python3-neovim python3-psutil"
MAINTAINER="Alexander Verbovetsky"
EMAIL="alik@ejik.org"