summaryrefslogtreecommitdiffstats
path: root/games/openclonk/openclonk.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'games/openclonk/openclonk.SlackBuild')
-rw-r--r--games/openclonk/openclonk.SlackBuild11
1 files changed, 5 insertions, 6 deletions
diff --git a/games/openclonk/openclonk.SlackBuild b/games/openclonk/openclonk.SlackBuild
index bcf3324139..4d76efcd17 100644
--- a/games/openclonk/openclonk.SlackBuild
+++ b/games/openclonk/openclonk.SlackBuild
@@ -23,8 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=openclonk
-VERSION=${VERSION:-5.4.1}
-SRCVER=$VERSION-src
+VERSION=${VERSION:-5.5.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -60,9 +59,9 @@ set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $PRGNAM-$SRCVER
-tar xvf $CWD/$PRGNAM-$SRCVER.tar.bz2
-cd $PRGNAM-$SRCVER
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz || tar xvf $CWD/v$VERSION.tar.gz
+cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
@@ -70,7 +69,7 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-patch -p1 < $CWD/CMakeLists_boost.patch
+patch -p1 < $CWD/boost.patch
mkdir -p build
cd build