summaryrefslogtreecommitdiffstats
path: root/games/openmsx/openmsx.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'games/openmsx/openmsx.SlackBuild')
-rw-r--r--games/openmsx/openmsx.SlackBuild14
1 files changed, 12 insertions, 2 deletions
diff --git a/games/openmsx/openmsx.SlackBuild b/games/openmsx/openmsx.SlackBuild
index 4c8c6da7e1..fa13ee95e8 100644
--- a/games/openmsx/openmsx.SlackBuild
+++ b/games/openmsx/openmsx.SlackBuild
@@ -3,7 +3,7 @@
# Slackware build script for OpenMSX
# Copyright 2013-2014 Erwin van Zanten, Dordrecht, The Netherlands
-# Copyright 2016-2017 Philip van der Hoeven, Almere, The Netherlands
+# Copyright 2016-2018 Philip van der Hoeven, Almere, The Netherlands
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,7 +25,7 @@
PRGNAM=openmsx
VERSION=${VERSION:-0.14.0}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -81,6 +81,16 @@ echo "INSTALL_BINARY_DIR:=/usr/bin" >> build/custom.mk
make
make install DESTDIR=$PKG
+# Build DMK tools
+cd Contrib/dmk
+for DMKTOOL in analyze-dmk combine-dmk der2dmk dsk2dmk empty-dmk svi2dmk; do
+ echo "Building $DMKTOOL"
+ g++ -std=c++11 $SLKCFLAGS -o $DMKTOOL $DMKTOOL.cc
+ cp $DMKTOOL $PKG/usr/bin
+ chmod 755 $PKG/usr/bin/$DMKTOOL
+done
+cd ../..
+
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true