summaryrefslogtreecommitdiffstats
path: root/games/qtsixa/qtsixa-dbus.patch
diff options
context:
space:
mode:
Diffstat (limited to 'games/qtsixa/qtsixa-dbus.patch')
-rw-r--r--games/qtsixa/qtsixa-dbus.patch43
1 files changed, 0 insertions, 43 deletions
diff --git a/games/qtsixa/qtsixa-dbus.patch b/games/qtsixa/qtsixa-dbus.patch
deleted file mode 100644
index deab7c3677..0000000000
--- a/games/qtsixa/qtsixa-dbus.patch
+++ /dev/null
@@ -1,43 +0,0 @@
-diff -urp qtsixa/gui/qtsixa_main.py qtsixa/gui/qtsixa_main.py
---- qtsixa/gui/qtsixa_main.py 2012-12-06 22:59:03.103868725 -0800
-+++ qtsixa/gui/qtsixa_main.py 2012-12-06 22:59:55.033596582 -0800
-@@ -307,6 +307,8 @@ class MainW(QMainWindow, ui_qtsixa_mainw
- def func_DBusDisconnect(self, mode, name, mac):
- bus = dbus.SystemBus()
- try:
-+ if (getoutput("qtsixa "+"--check-bluetoothd") == "0"):
-+ raise
- bluez_bus = bus.get_object('org.bluez', '/')
- bluez_id = bluez_bus.DefaultAdapter(dbus_interface='org.bluez.Manager')
- adapter_bus = bus.get_object('org.bluez', bluez_id)
-diff -urp qtsixa/qtsixa qtsixa/qtsixa
---- qtsixa/qtsixa 2012-12-06 22:59:03.107202042 -0800
-+++ qtsixa/qtsixa 2012-12-06 22:59:17.417127047 -0800
-@@ -68,6 +68,10 @@ fi
- echo "$ROOT"
- ;;
-
-+ check-bluetoothd|-check-bluetoothd|--check-bluetoothd)
-+ps -e | grep bluetoothd > /dev/null && echo "1" || echo "0"
-+ ;;
-+
- *)
- if [ -f ./gui/main.py ]; then
- exec python2 ./gui/main.py "$@"
-diff -urp sixad/Makefile sixad/Makefile
---- sixad/Makefile 2012-12-06 22:59:03.100535408 -0800
-+++ sixad/Makefile 2012-12-06 22:59:17.417127047 -0800
-@@ -34,7 +34,6 @@ install:
- install -m 755 bins/sixad-remote $(DESTDIR)/usr/sbin/
- install -m 755 bins/sixad-3in1 $(DESTDIR)/usr/sbin/
- install -m 755 bins/sixad-raw $(DESTDIR)/usr/sbin/
-- install -m 755 sixad-dbus-blocker $(DESTDIR)/usr/sbin/
- @chmod 777 -R $(DESTDIR)/var/lib/sixad/
- @echo "Installation is Complete!"
-
-@@ -47,5 +46,4 @@ uninstall:
- rm -f $(DESTDIR)/usr/sbin/sixad-sixaxis
- rm -f $(DESTDIR)/usr/sbin/sixad-remote
- rm -f $(DESTDIR)/usr/sbin/sixad-raw
-- rm -f $(DESTDIR)/usr/sbin/sixad-dbus-blocker
- rm -rf $(DESTDIR)/var/lib/sixad/