summaryrefslogtreecommitdiffstats
path: root/libraries/LucenePlusPlus/LucenePlusPlus.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'libraries/LucenePlusPlus/LucenePlusPlus.SlackBuild')
-rw-r--r--libraries/LucenePlusPlus/LucenePlusPlus.SlackBuild11
1 files changed, 5 insertions, 6 deletions
diff --git a/libraries/LucenePlusPlus/LucenePlusPlus.SlackBuild b/libraries/LucenePlusPlus/LucenePlusPlus.SlackBuild
index adc205acf4..4466204933 100644
--- a/libraries/LucenePlusPlus/LucenePlusPlus.SlackBuild
+++ b/libraries/LucenePlusPlus/LucenePlusPlus.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for LucenePlusPlus
-# Copyright 2014-2016 Willy Sudiarto Raharjo <willysr@slackbuilds.org>
+# Copyright 2014-2021 Willy Sudiarto Raharjo <willysr@slackbuilds.org>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,8 +23,8 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=LucenePlusPlus
-VERSION=${VERSION:-3.0.7}
-BUILD=${BUILD:-2}
+VERSION=${VERSION:-3.0.8}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -69,12 +69,11 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-# Disable building internal gtest
-sed -i "s/include(CMakeExternal.txt)/#include(CMakeExternal.txt)/" CMakeLists.txt
-sed -i "s/enable_testing()/#enable_testing()/" CMakeLists.txt
+patch -p1 < $CWD/soname.patch
mkdir -p build
cd build
+ export "PATH=/opt/cmake-202x/bin:$PATH"
cmake \
-DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
-DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \