summaryrefslogtreecommitdiffstats
path: root/libraries/cffi
diff options
context:
space:
mode:
Diffstat (limited to 'libraries/cffi')
-rw-r--r--libraries/cffi/README7
-rw-r--r--libraries/cffi/cffi.SlackBuild25
-rw-r--r--libraries/cffi/cffi.info6
3 files changed, 21 insertions, 17 deletions
diff --git a/libraries/cffi/README b/libraries/cffi/README
index 95a3dd927b..c3a88637f7 100644
--- a/libraries/cffi/README
+++ b/libraries/cffi/README
@@ -1,4 +1,3 @@
-Foreign Function Interface for Python calling C code. The aim of this project
-is to provide a convenient and reliable way of calling C code from Python.
-
-Optional dependency: python3
+Foreign Function Interface for Python calling C code. The aim of this
+project is to provide a convenient and reliable way of calling C code
+from Python.
diff --git a/libraries/cffi/cffi.SlackBuild b/libraries/cffi/cffi.SlackBuild
index fff9a062b1..25ab251f4c 100644
--- a/libraries/cffi/cffi.SlackBuild
+++ b/libraries/cffi/cffi.SlackBuild
@@ -1,4 +1,4 @@
-#!/bin/sh
+#!/bin/bash
# Slackware build script for cffi
@@ -22,10 +22,13 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+cd $(dirname $0) ; CWD=$(pwd)
+
PRGNAM=cffi
-VERSION=${VERSION:-1.11.5}
+VERSION=${VERSION:-1.13.2}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -35,7 +38,14 @@ if [ -z "$ARCH" ]; then
esac
fi
-CWD=$(pwd)
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
@@ -70,12 +80,7 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
-
-# Python 3 support.
-if $(python3 -c 'import sys' 2>/dev/null); then
- python3 setup.py install --root=$PKG
-fi
+python2 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
@@ -88,4 +93,4 @@ mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/libraries/cffi/cffi.info b/libraries/cffi/cffi.info
index bea16058d3..f64849ab41 100644
--- a/libraries/cffi/cffi.info
+++ b/libraries/cffi/cffi.info
@@ -1,8 +1,8 @@
PRGNAM="cffi"
-VERSION="1.11.5"
+VERSION="1.13.2"
HOMEPAGE="http://cffi.readthedocs.org"
-DOWNLOAD="https://files.pythonhosted.org/packages/e7/a7/4cd50e57cc6f436f1cc3a7e8fa700ff9b8b4d471620629074913e3735fb2/cffi-1.11.5.tar.gz"
-MD5SUM="ac8492f4ad952360737413e82d661908"
+DOWNLOAD="https://files.pythonhosted.org/packages/2d/bf/960e5a422db3ac1a5e612cb35ca436c3fc985ed4b7ed13a1b4879006f450/cffi-1.13.2.tar.gz"
+MD5SUM="652203cf99faa254efff7fab23c2f3a2"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="pycparser"