summaryrefslogtreecommitdiffstats
path: root/libraries/dav1d
diff options
context:
space:
mode:
Diffstat (limited to 'libraries/dav1d')
-rw-r--r--libraries/dav1d/README12
-rw-r--r--libraries/dav1d/dav1d.SlackBuild38
-rw-r--r--libraries/dav1d/dav1d.info8
-rw-r--r--libraries/dav1d/slack-desc2
4 files changed, 35 insertions, 25 deletions
diff --git a/libraries/dav1d/README b/libraries/dav1d/README
index 8a55430643..cf7b07d41c 100644
--- a/libraries/dav1d/README
+++ b/libraries/dav1d/README
@@ -1,7 +1,7 @@
-dav1d is an AV1 Decoder being developed by the VideoLAN,
-VLC and FFmpeg communities for use with AV1,the new video
-codec created by the Alliance for Open Media.
+dav1d is an AV1 decoder being developed by the VideoLAN,
+with the aim of creating a fast and correct decoder to
+overcome the present lack of hardware AV1 decoders.
-This SlackBuild builds the binary decoder dav1d, a basic
-playback application dav1dplay, as well as libraries suitable
-for use by other applications such as FFmpeg.
+This SlackBuild builds the binary decoder dav1d as well
+as libraries suitable for use by other applications such
+as FFmpeg and VLC.
diff --git a/libraries/dav1d/dav1d.SlackBuild b/libraries/dav1d/dav1d.SlackBuild
index 4c00aee62e..70cced3037 100644
--- a/libraries/dav1d/dav1d.SlackBuild
+++ b/libraries/dav1d/dav1d.SlackBuild
@@ -1,8 +1,8 @@
-#!/bin/sh
+#!/bin/bash
# ----------------------------------------------------------------------
# Slackware build script for dav1d
#
-# Copyright (c) 2019 Andrew Strong, Blue Mountains, Australia.
+# Copyright (c) 2019-2024 Andrew Strong, Blue Mountains, Australia.
#
# Permission to use, copy, modify, and distribute this software for
# any purpose with or without fee is hereby granted, provided that
@@ -23,10 +23,13 @@
# SUCH DAMAGE.
# ----------------------------------------------------------------------
+cd $(dirname $0) ; CWD=$(pwd)
+
PRGNAM=dav1d
-VERSION=${VERSION:-0.4.0}
+VERSION=${VERSION:-1.4.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -36,7 +39,11 @@ if [ -z "$ARCH" ]; then
esac
fi
-CWD=$(pwd)
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
@@ -61,7 +68,7 @@ rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
rm -rf $TMP/$PRGNAM-$VERSION
cd $TMP
-tar xvf $CWD/$PRGNAM-$VERSION.tar.xz
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
@@ -70,14 +77,17 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-# 14.2 has a version of nasm that is .01 away from the required nasm version
-# so this is adjusted here with no issues that I can see. Courtesy of Alien Bob:
-sed -i meson.build -e 's/2.13.02/2.13.01/'
-
-CFLAGS="$SLKCFLAGS" \
-CXXFLAGS="$SLKCFLAGS" \
-meson --prefix /usr --libdir lib${LIBDIRSUFFIX} build
-DESTDIR=$PKG ninja -C build all install
+mkdir build
+cd build
+ CFLAGS="$SLKCFLAGS" \
+ CXXFLAGS="$SLKCFLAGS" \
+ meson setup .. \
+ --buildtype=release \
+ --libdir=/usr/lib${LIBDIRSUFFIX} \
+ --prefix=/usr
+ "${NINJA:=ninja}"
+ DESTDIR=$PKG $NINJA install
+cd ..
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
@@ -90,4 +100,4 @@ mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/libraries/dav1d/dav1d.info b/libraries/dav1d/dav1d.info
index 36a6871d53..53196f5a6e 100644
--- a/libraries/dav1d/dav1d.info
+++ b/libraries/dav1d/dav1d.info
@@ -1,10 +1,10 @@
PRGNAM="dav1d"
-VERSION="0.4.0"
+VERSION="1.4.0"
HOMEPAGE="https://code.videolan.org/videolan/dav1d"
-DOWNLOAD="http://downloads.videolan.org/pub/videolan/dav1d/0.4.0/dav1d-0.4.0.tar.xz"
-MD5SUM="0864760964d65bf2d9d4c6c15ecffca6"
+DOWNLOAD="https://code.videolan.org/videolan/dav1d/-/archive/1.4.0/dav1d-1.4.0.tar.gz"
+MD5SUM="827aff30accb3de733df9482e19935d4"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="meson"
+REQUIRES=""
MAINTAINER="Andrew Strong"
EMAIL="andrew.david.strong@gmail.com"
diff --git a/libraries/dav1d/slack-desc b/libraries/dav1d/slack-desc
index 2dd2042ef0..b9ef7d3079 100644
--- a/libraries/dav1d/slack-desc
+++ b/libraries/dav1d/slack-desc
@@ -10,10 +10,10 @@ dav1d: dav1d (AV1 decoder)
dav1d:
dav1d: dav1d is an AV1 decoder focused on speed and correctness.
dav1d:
+dav1d: Homepage: https://code.videolan.org/videolan/dav1d
dav1d:
dav1d:
dav1d:
dav1d:
-dav1d: Homepage: https://code.videolan.org/videolan/dav1d
dav1d:
dav1d: