summaryrefslogtreecommitdiffstats
path: root/libraries/msgpack-c
diff options
context:
space:
mode:
Diffstat (limited to 'libraries/msgpack-c')
-rw-r--r--libraries/msgpack-c/README17
-rw-r--r--libraries/msgpack-c/msgpack-c.SlackBuild45
-rw-r--r--libraries/msgpack-c/msgpack-c.info10
3 files changed, 48 insertions, 24 deletions
diff --git a/libraries/msgpack-c/README b/libraries/msgpack-c/README
index a773af1661..ecad9972cf 100644
--- a/libraries/msgpack-c/README
+++ b/libraries/msgpack-c/README
@@ -1,3 +1,14 @@
-MessagePack is an efficient binary serialisation format that lets you exchange
-data among multiple languages like JSON. msgpack-c is a C and C++
-implementation of MessagePack.
+MessagePack is an efficient binary serialisation format that lets you
+exchange data among multiple languages like JSON. msgpack-c is a C and
+C++ implementation of MessagePack.
+
+Note: this is the lastest version of msgpack including both C and C++
+implementations. Later versions have separate implementations for these
+languages. This slackbuild is maintained for compatibility with
+some slackbuilds which require msgpack-c.
+
+If you want install a newer version (>=6.0.0) please refer to following
+packages:
+- msgpack-c-cpp for only C++ implementation
+- msgpack-c-c for only C implementation
+(both packages can coexist)
diff --git a/libraries/msgpack-c/msgpack-c.SlackBuild b/libraries/msgpack-c/msgpack-c.SlackBuild
index 92e33947ce..92d7d21e4b 100644
--- a/libraries/msgpack-c/msgpack-c.SlackBuild
+++ b/libraries/msgpack-c/msgpack-c.SlackBuild
@@ -1,8 +1,10 @@
-#!/bin/sh
+#!/bin/bash
# SlackBuild script for msgpack-c
-# Copyright 2014-2019 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
+# Copyright 2024 Giancarlo Dessi, Cagliari, IT
+# Copyright 2021 Ruben Schuller <sb@rbn.im>
+# Copyright 2014-2020 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -22,11 +24,18 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-SRCNAM=msgpack
-PRGNAM=$SRCNAM-c
-VERSION=${VERSION:-3.2.0}
-BUILD=${BUILD:-1}
+# 20220419 bkw: Modified by SlackBuilds.org, BUILD=2:
+# - remove empty AUTHORS from doc dir.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=msgpack-c
+VERSION=${VERSION:-3.3.0}
+BUILD=${BUILD:-3}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+SRCNAM=msgpack
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -36,7 +45,11 @@ if [ -z "$ARCH" ]; then
esac
fi
-CWD=$(pwd)
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
@@ -66,28 +79,28 @@ cd $SRCNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
+sed -i ./CMakeLists.txt -e "s/(VERSION 2.8.12)/(VERSION 3.5)/g"
mkdir -p build
cd build
cmake \
-DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
- -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS -std=c++11" \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=/usr/lib${LIBDIRSUFFIX} \
+ -DMSGPACK_BUILD_TESTS=OFF \
+ -DMSGPACK_BUILD_EXAMPLES=OFF \
..
- make install DESTDIR=$PKG
+ make install/strip DESTDIR=$PKG
cd ..
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a \
- AUTHORS COPYING LICENSE_1_0.txt NOTICE README \
+ COPYING LICENSE_1_0.txt NOTICE README \
$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
@@ -95,4 +108,4 @@ mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/libraries/msgpack-c/msgpack-c.info b/libraries/msgpack-c/msgpack-c.info
index 1227286bcf..e746c6b2e4 100644
--- a/libraries/msgpack-c/msgpack-c.info
+++ b/libraries/msgpack-c/msgpack-c.info
@@ -1,10 +1,10 @@
PRGNAM="msgpack-c"
-VERSION="3.2.0"
+VERSION="3.3.0"
HOMEPAGE="https://github.com/msgpack/msgpack-c"
-DOWNLOAD="https://github.com/msgpack/msgpack-c/releases/download/cpp-3.2.0/msgpack-3.2.0.tar.gz"
-MD5SUM="53ae37b760690562a1e1cc03d5e1baa4"
+DOWNLOAD="https://github.com/msgpack/msgpack-c/releases/download/cpp-3.3.0/msgpack-3.3.0.tar.gz"
+MD5SUM="e676575d52caae974e579c3d5f0ba6a2"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""
-MAINTAINER="Benjamin Trigona-Harany"
-EMAIL="slackbuilds@jaxartes.net"
+MAINTAINER="Giancarlo Dessi"
+EMAIL="slack@giand.it"