summaryrefslogtreecommitdiffstats
path: root/libraries
diff options
context:
space:
mode:
Diffstat (limited to 'libraries')
-rw-r--r--libraries/pyusb/pyusb.SlackBuild8
1 files changed, 2 insertions, 6 deletions
diff --git a/libraries/pyusb/pyusb.SlackBuild b/libraries/pyusb/pyusb.SlackBuild
index 2a3f897308..a228dd632f 100644
--- a/libraries/pyusb/pyusb.SlackBuild
+++ b/libraries/pyusb/pyusb.SlackBuild
@@ -46,12 +46,8 @@ CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
python ./setup.py install --root=$PKG
-( cd $PKG
- find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : \
- | xargs strip --strip-unneeded 2> /dev/null || true
- find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : \
- | xargs strip --strip-unneeded 2> /dev/null || true
-)
+find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
# Normalize line endings
sed -i "s/\xd$//g" README