summaryrefslogtreecommitdiffstats
path: root/misc/grc/grc.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'misc/grc/grc.SlackBuild')
-rw-r--r--misc/grc/grc.SlackBuild29
1 files changed, 13 insertions, 16 deletions
diff --git a/misc/grc/grc.SlackBuild b/misc/grc/grc.SlackBuild
index 9285f69709..02733b06b8 100644
--- a/misc/grc/grc.SlackBuild
+++ b/misc/grc/grc.SlackBuild
@@ -24,7 +24,7 @@
PRGNAM="grc"
VERSION=${VERSION:-1.10}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -63,28 +63,25 @@ rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-install -d $PKG/etc/profile.d
-install -D -m644 grc.conf $PKG/etc/grc.conf.new
-install -D -m644 grc.bashrc $PKG/etc/profile.d/grc.bashrc.new
-install -D -m644 grc.zsh $PKG/etc/profile.d/grc.zsh.new
-install -D -m644 grc.fish $PKG/etc/profile.d/grc.fish.new
+./install.sh $PKG/usr $PKG
-install -d $PKG/usr/bin
-install -D -m755 {grc,grcat} $PKG/usr/bin
+mv $PKG/etc/grc.conf $PKG/etc/grc.conf.new
-install -d $PKG/usr/share/grc
-install -D -m644 conf.* $PKG/usr/share/grc
-
-install -d $PKG/usr/man/man1
-install -D -m644 {grc.1,grcat.1} $PKG/usr/man/man1
+# for Bash, Fish and Zsh.
+mv $PKG/etc/profile.d/grc.bashrc $PKG/etc/profile.d/grc.bashrc.new
+cp -a grc.zsh $PKG/etc/profile.d/grc.zsh.new
+cp -a grc.fish $PKG/etc/profile.d/grc.fish.new
+mv $PKG/usr/share/man $PKG/usr/man
find $PKG/usr/man -type f -exec gzip -9 {} \;
for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
-install -d $PKG/usr/share/$PRGNAM
-install -D -m644 conf.* $PKG/usr/share/$PRGNAM
-
DOCS="contrib debian/changelog debian/copyright CREDITS INSTALL \
README.markdown Regexp.txt TODO"