summaryrefslogtreecommitdiffstats
path: root/network/airpwn
diff options
context:
space:
mode:
Diffstat (limited to 'network/airpwn')
-rw-r--r--network/airpwn/README7
-rw-r--r--network/airpwn/airpwn.SlackBuild132
-rw-r--r--network/airpwn/airpwn.info10
-rw-r--r--network/airpwn/slack-desc19
4 files changed, 0 insertions, 168 deletions
diff --git a/network/airpwn/README b/network/airpwn/README
deleted file mode 100644
index 613361cd54..0000000000
--- a/network/airpwn/README
+++ /dev/null
@@ -1,7 +0,0 @@
-Airpwn is a framework for 802.11 (wireless) packet injection.
-Airpwn listens to incoming wireless packets, and if the data
-matches a pattern specified in the config files, custom content
-is injected "spoofed" from the wireless access point. From the
-perspective of the wireless client, airpwn becomes the server.
-
-This package also installs lorcon (Loss Of Radio CONnectivity).
diff --git a/network/airpwn/airpwn.SlackBuild b/network/airpwn/airpwn.SlackBuild
deleted file mode 100644
index b09a5958d5..0000000000
--- a/network/airpwn/airpwn.SlackBuild
+++ /dev/null
@@ -1,132 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for airpwn
-# Written by Larry Hajali <larryhaja[at]gmail[dot]com>
-# and Klaatu <klaatu@member.fsf.no.psam.org>
-
-PRGNAM=airpwn
-VERSION=${VERSION:-1.4}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i486 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tgz
-cd $PRGNAM-$VERSION
-tar xvf lorcon-current.tgz
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
-
-# Remove unneeded directories and change a file to Unix
-find . -type d -name "CVS" | xargs rm -rf {} \;
-find . -type d -name ".cvs" | xargs rm -rf {} \;
-sed -i 's/\r//g' content/ftp_resp
-
-# first install lorcon
-cd lorcon
- CFLAGS="$SLKCFLAGS" \
- ./configure \
- --prefix=/usr \
- --libdir=/usr/lib${LIBDIRSUFFIX} \
- --mandir=/usr/man \
- --datadir=/usr/share/$PRGNAM \
- --enable-static=no \
- --build=$ARCH-slackware-linux
-
- make
- make install DESTDIR=$PKG
-cd ..
-
-sed -i 's/#include <unistd.h>/#include <unistd.h> #include <wep.h>/' keygen.c
-echo "sed change made"
-ls -lh keygen.c
-
-# Fix airpwn files so we can use Python versions other than 2.4
-PYTHON_VERSION1=$(python -c 'import sys; print sys.version[:3]')
-PYTHON_VERSION2=$(echo $PYTHON_VERSION1 | tr . _)
-
-for FILE in configure.ac conf.h config.h.in; do
- sed -i "s|python2.4|python${PYTHON_VERSION1}|g" $FILE
-done
-sed -i "s|Python2.4|Python${PYTHON_VERSION1}|g" configure.ac
-sed -i "s|PYTHON2_4|PYTHON${PYTHON_VERSION2}|g" config.h.in
-
-autoreconf -vif
-
-CFLAGS="$SLKCFLAGS" \
-LDFLAGS="-L${PKG}/usr/lib${LIBDIRSUFFIX}" \
-CPPFLAGS="-I${PKG}/usr/include" \
-./configure \
- --prefix=/usr \
- --libdir=/usr/lib${LIBDIRSUFFIX} \
- --mandir=/usr/man \
- --build=$ARCH-slackware-linux
-
-# fix what libs we link to
-sed -i 's/-lnet/-lnet -lssl -lexpat -lcrypto/' Makefile
-
-# build airpwn
-make
-make install DESTDIR=$PKG
-
-# Install some scripts to help get wireless devices into monitor mode.
-install -m 0755 mac80211_prep.sh $PKG/usr/sbin
-install -m 0755 madwifing_prep.sh $PKG/usr/sbin
-install -m 0755 madwifiold_prep.sh $PKG/usr/sbin
-
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-( cd $PKG/usr/man
- find . -type f -exec gzip -9 {} \;
- for i in $( find . -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
-)
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
- COPYING LICENSE lorcon/{BUGS,README,THANKS,TODO} content conf pyscripts \
- $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-chmod 0644 $PKG/usr/doc/$PRGNAM-$VERSION/*
-chmod 0755 $PKG/usr/doc/$PRGNAM-$VERSION/{content,conf,pyscripts}
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/network/airpwn/airpwn.info b/network/airpwn/airpwn.info
deleted file mode 100644
index 7c8bf62072..0000000000
--- a/network/airpwn/airpwn.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="airpwn"
-VERSION="1.4"
-HOMEPAGE="http://airpwn.sourceforge.net/Airpwn.html"
-DOWNLOAD="http://downloads.sourceforge.net/sourceforge/airpwn/airpwn-1.4.tgz"
-MD5SUM="c5538f5eadc2afa0bf3e873c4bfa2513"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="libnet"
-MAINTAINER="Klaatu"
-EMAIL="klaatu@member.fsf.org"
diff --git a/network/airpwn/slack-desc b/network/airpwn/slack-desc
deleted file mode 100644
index 5e52edb57b..0000000000
--- a/network/airpwn/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-airpwn: airpwn (framework for 802.11 packet injection)
-airpwn:
-airpwn: Airpwn is a framework for 802.11 (wireless) packet injection. Airpwn
-airpwn: listens to incoming wireless packets, and if the data matches a
-airpwn: pattern specified in the config files, custom content is injected
-airpwn: "spoofed" from the wireless access point. From the perspective of the
-airpwn: wireless client, airpwn becomes the server.
-airpwn:
-airpwn: Homepage: http://airpwn.sourceforge.net/Airpwn.html
-airpwn:
-airpwn: