summaryrefslogtreecommitdiffstats
path: root/network/arm/arm.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'network/arm/arm.SlackBuild')
-rw-r--r--network/arm/arm.SlackBuild73
1 files changed, 0 insertions, 73 deletions
diff --git a/network/arm/arm.SlackBuild b/network/arm/arm.SlackBuild
deleted file mode 100644
index a929bb5c60..0000000000
--- a/network/arm/arm.SlackBuild
+++ /dev/null
@@ -1,73 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for arm
-# Written by pyllyukko - pyllyukko AT maimed dot org
-
-PRGNAM=arm
-VERSION=${VERSION:-1.4.5.0}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-ARCH=noarch
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM
-
-# The package can be verified with Damian Johnson's PGP key (0x9ABBEEC6).
-# If we have GPG installed, we try to verify the signature.
-if [ -x "/usr/bin/gpg" -a -x "/usr/bin/gpgv" ]
-then
- set +e
- # This will check if we have the correct key in our keyring.
- # For the trustedkeys.gpg, see "man 1 gpgv".
- /usr/bin/gpg --keyring trustedkeys.gpg --no-default-keyring --list-keys 0x9ABBEEC6 &>/dev/null
- GPG_RET=${?}
- # 2 means we don't have his key, 0 means we do.
- set -e
- # If we have the key and the signature file, we verify the package with GPG
- if [ ${GPG_RET} -eq 0 -a \
- -f "${CWD}/${PRGNAM}-${VERSION}.tar.bz2.asc" ]
- then
- /usr/bin/gpgv "${CWD}/${PRGNAM}-${VERSION}.tar.bz2.asc"
- fi
-fi
-
-tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
-cd $PRGNAM
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
-
-# prereq.py checks python version and for required packages
-python src/prereq.py
-python setup.py install --root=$PKG --docPath doc/${PRGNAM}-${VERSION}
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-# Move the man pages. setup.py handles the compressing.
-mv -v ${PKG}/usr/share/man ${PKG}/usr
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
- ChangeLog LICENSE README \
- $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}