summaryrefslogtreecommitdiffstats
path: root/network/asciinema
diff options
context:
space:
mode:
Diffstat (limited to 'network/asciinema')
-rw-r--r--network/asciinema/asciinema.SlackBuild37
-rw-r--r--network/asciinema/asciinema.info10
-rw-r--r--network/asciinema/setup.py5
3 files changed, 32 insertions, 20 deletions
diff --git a/network/asciinema/asciinema.SlackBuild b/network/asciinema/asciinema.SlackBuild
index db3f23b1a4..d5ffca1ec1 100644
--- a/network/asciinema/asciinema.SlackBuild
+++ b/network/asciinema/asciinema.SlackBuild
@@ -1,8 +1,8 @@
-#!/bin/sh
+#!/bin/bash
# Slackware build script for asciinema
-# Copyright 2014-2019 Dimitris Zlatanidis Orestiada, Greece
+# Copyright 2014-2023 Dimitris Zlatanidis Orestiada, Greece
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -22,10 +22,13 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+cd $(dirname $0) ; CWD=$(pwd)
+
PRGNAM=asciinema
-VERSION=${VERSION:-2.0.2}
+VERSION=${VERSION:-2.4.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -35,7 +38,11 @@ if [ -z "$ARCH" ]; then
esac
fi
-CWD=$(pwd)
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
@@ -61,27 +68,27 @@ mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cp $CWD/setup.py $PRGNAM-$VERSION
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-# Fixed doc and manpage path
-sed -i -e "s/share\/doc/doc/" -e "s/share\/man/man/" setup.py
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
python3 setup.py install --root=$PKG
-# install man page
+mkdir -p $PKG/usr/man/man1
+cp man/asciinema.1 $PKG/usr/man/man1
+
find $PKG/usr/man -type f -exec gzip -9 {} \;
-for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+mv $PKG/usr/share/doc/$PRGNAM/* $PKG/usr/doc/$PRGNAM-$VERSION
+rm -rf $PKG/usr/share # nothing here but empty doc/ dir.
+
cp -a *.md PKG-INFO $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
@@ -90,4 +97,4 @@ cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/network/asciinema/asciinema.info b/network/asciinema/asciinema.info
index b110415859..874f4c5dd0 100644
--- a/network/asciinema/asciinema.info
+++ b/network/asciinema/asciinema.info
@@ -1,10 +1,10 @@
PRGNAM="asciinema"
-VERSION="2.0.2"
+VERSION="2.4.0"
HOMEPAGE="https://asciinema.org"
-DOWNLOAD="https://files.pythonhosted.org/packages/a7/71/771c859795e02c71c187546f34f7535487b97425bc1dad1e5f6ad2651357/asciinema-2.0.2.tar.gz"
-MD5SUM="f3bda18659e40cfd9b37a790f47eaed7"
+DOWNLOAD="https://files.pythonhosted.org/packages/f1/19/45b405438e90ad5b9618f3df62e9b3edaa2b115b530e60bd4b363465c704/asciinema-2.4.0.tar.gz"
+MD5SUM="bcf1b5f337a1e8a7b4839d13e153b5bf"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="python3"
+REQUIRES=""
MAINTAINER="Dimitris Zlatanidis"
-EMAIL="d.zlatanidis@gmail.com"
+EMAIL="dslackw@gmail.com"
diff --git a/network/asciinema/setup.py b/network/asciinema/setup.py
new file mode 100644
index 0000000000..0ae4555937
--- /dev/null
+++ b/network/asciinema/setup.py
@@ -0,0 +1,5 @@
+from setuptools import setup
+
+
+if __name__ == '__main__':
+ setup()