summaryrefslogtreecommitdiffstats
path: root/network/authbind/authbind.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'network/authbind/authbind.SlackBuild')
-rw-r--r--network/authbind/authbind.SlackBuild28
1 files changed, 19 insertions, 9 deletions
diff --git a/network/authbind/authbind.SlackBuild b/network/authbind/authbind.SlackBuild
index 3693884f19..419cce58cb 100644
--- a/network/authbind/authbind.SlackBuild
+++ b/network/authbind/authbind.SlackBuild
@@ -1,15 +1,24 @@
-#!/bin/sh
+#!/bin/bash
# Slackware build script for authbind
-# Written by B. Watson (yalhcru@gmail.com)
+# Written by B. Watson (urchlay@slackware.uk)
# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
+# 20230103 bkw: Note to self: There is an authbind_2.1.3.tar.gz
+# available on Debian's download server, but there are no code changes
+# between 2.1.2 and 2.1.3. The only differences are in the Debian
+# packaging stuff (debian/rules and debian/changelog), which we don't
+# use.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
PRGNAM=authbind
VERSION=${VERSION:-2.1.2}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -19,7 +28,11 @@ if [ -z "$ARCH" ]; then
esac
fi
-CWD=$(pwd)
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
@@ -47,11 +60,8 @@ rm -rf $PRGNAM
tar xvf $CWD/${PRGNAM}_$VERSION.tar.gz
cd $PRGNAM
chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
+ \! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+
make \
OPTIMISE="$SLKCFLAGS" \
@@ -77,4 +87,4 @@ mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE