summaryrefslogtreecommitdiffstats
path: root/network/dwb
diff options
context:
space:
mode:
Diffstat (limited to 'network/dwb')
-rw-r--r--network/dwb/README3
-rw-r--r--network/dwb/doinst.sh4
-rw-r--r--network/dwb/dwb.SlackBuild103
-rw-r--r--network/dwb/dwb.info10
-rw-r--r--network/dwb/slack-desc19
5 files changed, 0 insertions, 139 deletions
diff --git a/network/dwb/README b/network/dwb/README
deleted file mode 100644
index 06e43caeaa..0000000000
--- a/network/dwb/README
+++ /dev/null
@@ -1,3 +0,0 @@
-dwb is a lightweight web browser based on the webkit web browser
-engine and the gtk toolkit. dwb is highly customisable and can be
-easily configured through a web interface.
diff --git a/network/dwb/doinst.sh b/network/dwb/doinst.sh
deleted file mode 100644
index 392c12adb9..0000000000
--- a/network/dwb/doinst.sh
+++ /dev/null
@@ -1,4 +0,0 @@
-if [ -x /usr/bin/update-desktop-database ]; then
- /usr/bin/update-desktop-database -q usr/share/applications
-fi
-
diff --git a/network/dwb/dwb.SlackBuild b/network/dwb/dwb.SlackBuild
deleted file mode 100644
index 35b930c488..0000000000
--- a/network/dwb/dwb.SlackBuild
+++ /dev/null
@@ -1,103 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for dwb
-# Originally by Marcin Herda <mherda@slackword.net>
-
-# Formerly maintained by:
-# Ryan P.C. McQuen | Everett, WA | ryanpcmcquen@member.fsf.org
-
-# Now maintained by B. Watson (yalhcru@gmail.com)
-
-# This program is free software: you can redistribute it and/or modify
-# it under the terms of the GNU General Public License as published by
-# the Free Software Foundation; either version 2 of the License, or
-# (at your option) any later version, with the following exception:
-# the text of the GPL license may be omitted.
-
-# This program is distributed in the hope that it will be useful, but
-# without any warranty; without even the implied warranty of
-# merchantability or fitness for a particular purpose. Compiling,
-# interpreting, executing or merely reading the text of the program
-# may result in lapses of consciousness and/or very being, up to and
-# including the end of all existence and the Universe as we know it.
-# See the GNU General Public License for more details.
-
-# You may have received a copy of the GNU General Public License along
-# with this program (most likely, a file named COPYING). If not, see
-# <https://www.gnu.org/licenses/>.
-
-# 20170309 bkw:
-# - take over maintenance
-# - update for v20161213_4f6c404 (latest commit)
-# - i486 => i586
-# - minor tweaks
-# - TODO: look into ad-blocking (patch whatever's needed)
-
-PRGNAM=dwb
-VERSION=${VERSION:-20161213_4f6c404}
-SRCVER=${SRCVER:-4f6c404f2761}
-SRCNAM=${SRCNAM:-portix-dwb}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $SRCNAM-$SRCVER
-tar xvf $CWD/$SRCVER.tar.bz2 || tar xvf $CWD/$SRCNAM-$SRCVER.tar.bz2
-cd $SRCNAM-$SRCVER
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-# fix the location of man pages
-sed -i '/^MANDIR/s/DATAROOTDIR/PREFIX/' config.mk
-
-CFLAGS="$SLKCFLAGS" \
-make
-make install DESTDIR=$PKG
-strip $PKG/usr/bin/*
-gzip $PKG/usr/man/man?/*.?
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a README AUTHORS $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-cat $CWD/doinst.sh > $PKG/install/doinst.sh
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/network/dwb/dwb.info b/network/dwb/dwb.info
deleted file mode 100644
index f2ca1c84e3..0000000000
--- a/network/dwb/dwb.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="dwb"
-VERSION="20161213_4f6c404"
-HOMEPAGE="https://portix.bitbucket.io/dwb/"
-DOWNLOAD="https://bitbucket.org/portix/dwb/get/4f6c404f2761.tar.bz2"
-MD5SUM="08df9c127009284bc201e2301e41f3e1"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="webkitgtk"
-MAINTAINER="B. Watson"
-EMAIL="yalhcru@gmail.com"
diff --git a/network/dwb/slack-desc b/network/dwb/slack-desc
deleted file mode 100644
index 7fb4569ff9..0000000000
--- a/network/dwb/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-dwb: dwb (dwb web browser)
-dwb:
-dwb: dwb is a lightweight web browser based on the webkit web browser
-dwb: engine and the gtk toolkit. dwb is highly customisable and can be
-dwb: easily configured through a web interface.
-dwb:
-dwb: Homepage: http://portix.bitbucket.org/dwb/
-dwb:
-dwb:
-dwb:
-dwb: