summaryrefslogtreecommitdiffstats
path: root/network/exim/exim.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'network/exim/exim.SlackBuild')
-rw-r--r--network/exim/exim.SlackBuild23
1 files changed, 17 insertions, 6 deletions
diff --git a/network/exim/exim.SlackBuild b/network/exim/exim.SlackBuild
index 11e76bbb82..be60519268 100644
--- a/network/exim/exim.SlackBuild
+++ b/network/exim/exim.SlackBuild
@@ -8,14 +8,16 @@
# Thanks to Debian for the manpages.
PRGNAM=exim
-VERSION=${VERSION:-4.76}
+VERSION=${VERSION:-4.77}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
+# Automatically determine the architecture we're building on:
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i486 ;;
arm*) ARCH=arm ;;
+ # Unless $ARCH is already set, use uname -m for all other archs:
*) ARCH=$( uname -m ) ;;
esac
fi
@@ -59,20 +61,29 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
+# Copy the Makefile and a stock config for eximon
cat $CWD/exim.Makefile > Local/Makefile
cat exim_monitor/EDITME > Local/eximon.conf
-make \
- CFLAGS="$SLKCFLAGS -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE" \
- LIBDIRSUFFIX=$LIBDIRSUFFIX
-make install DESTDIR=$PKG
+# Use the Exim build system to set the architecture-specific CFLAGS.
+# This requires "make" to run twice, in case you wonder. If you want
+# to use your own CFLAGS in exim.Makefile, you should put a '#' in
+# front of the next 4 lines.
+echo "CFLAGS=$SLKCFLAGS" > Local/Makefile-Linux
+echo "CFLAGS+=-D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE" > Local/Makefile-Linux-i386
+FULLECHO="" LIBDIRSUFFIX=$LIBDIRSUFFIX DESTDIR=$PKG make -e || true
+FULLECHO="" LIBDIRSUFFIX=$LIBDIRSUFFIX DESTDIR=$PKG make -e makefile
+
+# build & install
+FULLECHO="" LIBDIRSUFFIX=$LIBDIRSUFFIX DESTDIR=$PKG make -e
+FULLECHO="" LIBDIRSUFFIX=$LIBDIRSUFFIX DESTDIR=$PKG make -e install
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
# Ditch the symlink and move the binary to its final destination.
rm -f $PKG/usr/sbin/exim
-mv $PKG/usr/sbin/exim-$VERSION-1 $PKG/usr/sbin/exim
+mv $PKG/usr/sbin/exim-$VERSION-? $PKG/usr/sbin/exim
# Additional symlinks provide compatibility with sendmail
mkdir -p $PKG/usr/lib # no LIBDIRSUFFIX here!