summaryrefslogtreecommitdiffstats
path: root/network/heimdal
diff options
context:
space:
mode:
Diffstat (limited to 'network/heimdal')
-rw-r--r--network/heimdal/README2
-rw-r--r--network/heimdal/config/heimdal.sh4
-rw-r--r--network/heimdal/config/rc.ipropd-master6
-rw-r--r--network/heimdal/config/rc.ipropd-slave6
-rw-r--r--network/heimdal/config/rc.kadmind6
-rw-r--r--network/heimdal/config/rc.kdc6
-rw-r--r--network/heimdal/config/rc.kpasswdd6
-rw-r--r--network/heimdal/doinst.sh7
-rw-r--r--network/heimdal/heimdal.SlackBuild66
-rw-r--r--network/heimdal/heimdal.info6
-rw-r--r--network/heimdal/slack-desc2
11 files changed, 71 insertions, 46 deletions
diff --git a/network/heimdal/README b/network/heimdal/README
index 41e6e229b2..3031fa264f 100644
--- a/network/heimdal/README
+++ b/network/heimdal/README
@@ -8,5 +8,3 @@ Heimdal is a free implementation of Kerberos 5. The goals are to:
* include the most important and useful application programs
(rsh, telnet, popper, etc.)
* include enough backwards compatibility with Kerberos V4
-
-This package conflicts with krb5.
diff --git a/network/heimdal/config/heimdal.sh b/network/heimdal/config/heimdal.sh
new file mode 100644
index 0000000000..fd3f0bdba4
--- /dev/null
+++ b/network/heimdal/config/heimdal.sh
@@ -0,0 +1,4 @@
+#!/bin/sh
+
+export PATH=/usr/heimdal/bin:/usr/heimdal/sbin:$PATH
+export MANPATH=/usr/heimdal/man:$MANPATH
diff --git a/network/heimdal/config/rc.ipropd-master b/network/heimdal/config/rc.ipropd-master
index 744943b4c5..054048c440 100644
--- a/network/heimdal/config/rc.ipropd-master
+++ b/network/heimdal/config/rc.ipropd-master
@@ -3,9 +3,9 @@
HOSTNAME=`hostname -f`
ipropd_master_start() {
- if [ -x /usr/libexec/ipropd-master ]; then
- echo "Starting the ipropd-master service: /usr/libexec/ipropd-master --detach"
- /usr/libexec/ipropd-master --detach --hostname=$HOSTNAME
+ if [ -x /usr/heimdal/libexec/ipropd-master ]; then
+ echo "Starting the ipropd-master service: /usr/heimdal/libexec/ipropd-master --detach"
+ /usr/heimdal/libexec/ipropd-master --detach --hostname=$HOSTNAME
fi
}
diff --git a/network/heimdal/config/rc.ipropd-slave b/network/heimdal/config/rc.ipropd-slave
index 6b1a8c7274..9364430e07 100644
--- a/network/heimdal/config/rc.ipropd-slave
+++ b/network/heimdal/config/rc.ipropd-slave
@@ -4,9 +4,9 @@ KEYTAB=/etc/iprop.keytab
HOSTNAME=`hostname -f`
ipropd_slave_start() {
- if [ -x /usr/libexec/ipropd-slave ]; then
- echo "Starting the ipropd-slave service: /usr/libexec/ipropd-slave --detach"
- /usr/libexec/ipropd-slave --detach --keytab=$KEYTAB --hostname=$HOSTNAME
+ if [ -x /usr/heimdal/libexec/ipropd-slave ]; then
+ echo "Starting the ipropd-slave service: /usr/heimdal/libexec/ipropd-slave --detach"
+ /usr/heimdal/libexec/ipropd-slave --detach --keytab=$KEYTAB --hostname=$HOSTNAME
fi
}
diff --git a/network/heimdal/config/rc.kadmind b/network/heimdal/config/rc.kadmind
index 23b5447078..4487b492bc 100644
--- a/network/heimdal/config/rc.kadmind
+++ b/network/heimdal/config/rc.kadmind
@@ -1,9 +1,9 @@
#!/bin/sh
kadmind_start() {
- if [ -x /usr/libexec/kadmind ]; then
- echo "Starting the kadmind service: /usr/libexec/kadmind"
- /usr/libexec/kadmind --detach
+ if [ -x /usr/heimdal/libexec/kadmind ]; then
+ echo "Starting the kadmind service: /usr/heimdal/libexec/kadmind"
+ /usr/heimdal/libexec/kadmind --detach
fi
}
diff --git a/network/heimdal/config/rc.kdc b/network/heimdal/config/rc.kdc
index 3233794801..09c9f37827 100644
--- a/network/heimdal/config/rc.kdc
+++ b/network/heimdal/config/rc.kdc
@@ -1,9 +1,9 @@
#!/bin/sh
kdc_start() {
- if [ -x /usr/libexec/kdc ]; then
- echo "Starting the kdc service: /usr/libexec/kdc --detach"
- /usr/libexec/kdc --detach
+ if [ -x /usr/heimdal/libexec/kdc ]; then
+ echo "Starting the kdc service: /usr/heimdal/libexec/kdc --detach"
+ /usr/heimdal/libexec/kdc --detach
fi
}
diff --git a/network/heimdal/config/rc.kpasswdd b/network/heimdal/config/rc.kpasswdd
index f712ee8e45..793d3d2094 100644
--- a/network/heimdal/config/rc.kpasswdd
+++ b/network/heimdal/config/rc.kpasswdd
@@ -1,9 +1,9 @@
#!/bin/sh
kpasswdd_start() {
- if [ -x /usr/libexec/kpasswdd ]; then
- echo "Starting the kpasswdd service: /usr/libexec/kpasswdd"
- /usr/libexec/kpasswdd --detach
+ if [ -x /usr/heimdal/libexec/kpasswdd ]; then
+ echo "Starting the kpasswdd service: /usr/heimdal/libexec/kpasswdd"
+ /usr/heimdal/libexec/kpasswdd --detach
fi
}
diff --git a/network/heimdal/doinst.sh b/network/heimdal/doinst.sh
index 3176f057e6..37eaf64c5d 100644
--- a/network/heimdal/doinst.sh
+++ b/network/heimdal/doinst.sh
@@ -23,10 +23,15 @@ preserve_perms() {
}
preserve_perms etc/rc.d/rc.kdc.new
-preserve_perms etc/rc.d/rc.kadmind.new
+preserve_perms etc/rc.d/rc.kadmind-heimdal.new
preserve_perms etc/rc.d/rc.kpasswdd.new
preserve_perms etc/rc.d/rc.ipropd-master.new
preserve_perms etc/rc.d/rc.ipropd-slave.new
config etc/krb5.conf.new
+config etc/profile.d/heimdal.sh.new
config var/heimdal/kdc.conf.new
config var/heimdal/kadmind.acl.new
+
+if [ ! "$(grep /usr/heimdal/lib@LIBDIRSUFFIX@ /etc/ld.so.conf)" ]; then
+ echo "/usr/heimdal/lib@LIBDIRSUFFIX@" >> /etc/ld.so.conf
+fi
diff --git a/network/heimdal/heimdal.SlackBuild b/network/heimdal/heimdal.SlackBuild
index bffccb9397..1b4d389115 100644
--- a/network/heimdal/heimdal.SlackBuild
+++ b/network/heimdal/heimdal.SlackBuild
@@ -1,9 +1,9 @@
-#!/bin/sh
+#!/bin/bash
# Slackware build script for KTH Heimdal Kerberos
-# Copyright 2010 Menno Duurma
-# Copyright 2011-2019 Thibaut Notteboom, Paris, FRANCE
+# Copyright 2010 Menno Duursma
+# Copyright 2011-2023 Thibaut Notteboom, Paris, FRANCE
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,10 +23,15 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# 20220322 bkw: Modified by SlackBuilds.org: fix 32-bit build.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
PRGNAM=heimdal
-VERSION=${VERSION:-7.7.0}
+VERSION=${VERSION:-7.8.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -36,7 +41,11 @@ if [ -z "$ARCH" ]; then
esac
fi
-CWD=$(pwd)
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
@@ -50,6 +59,9 @@ elif [ "$ARCH" = "i686" ]; then
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
LIBDIRSUFFIX="64"
+elif [ "$ARCH" = "aarch64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
else
SLKCFLAGS="-O2"
LIBDIRSUFFIX=""
@@ -66,26 +78,32 @@ cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
+
+# 20220322 bkw: disable 2 of the unit tests that won't work on 32-bit,
+# because they rely on pre-generated certificates whose expiration
+# dates are ~500 years in the future (meaning past 2038, meaning a
+# 32-bit time_t can't handle it). This has been a known issue upstream
+# since at least 2019: https://github.com/heimdal/heimdal/issues/533
+[ -z "$LIBDIRSUFFIX" ] && \
+ sed -i '/^[\t ]*test_c\(hain\|ms\)[\t ]/d' lib/hx509/Makefile.??
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
-LDFLAGS="-L/usr/lib$LIBDIRSUFFIX -lpthread" \
./configure \
- --prefix=/usr \
- --libdir=/usr/lib${LIBDIRSUFFIX} \
+ --prefix=/usr/heimdal \
+ --libdir=/usr/heimdal/lib${LIBDIRSUFFIX} \
--sysconfdir=/etc \
--localstatedir=/var \
--infodir=/usr/info \
- --mandir=/usr/man \
+ --mandir=/usr/heimdal/man \
--docdir=/usr/doc/$PRGNAM-$VERSION \
--with-openldap=/usr \
- --with-readline=/usr \
+ --with-libedit=/usr \
--with-sqlite3=/usr \
--with-libintl=/usr \
- --with-berkeley-db-include=/usr/include/db48 \
--with-x \
--with-ipv6 \
--without-hesiod \
@@ -97,33 +115,32 @@ LDFLAGS="-L/usr/lib$LIBDIRSUFFIX -lpthread" \
--build=$ARCH-slackware-linux
make
-make -j1 check
+#make -j1 check
make install-strip DESTDIR=$PKG
mkdir -p $PKG/etc/rc.d
cat $CWD/config/krb5.conf > $PKG/etc/krb5.conf.new
cat $CWD/config/rc.kdc > $PKG/etc/rc.d/rc.kdc.new
-cat $CWD/config/rc.kadmind > $PKG/etc/rc.d/rc.kadmind.new
+cat $CWD/config/rc.kadmind > $PKG/etc/rc.d/rc.kadmind-heimdal.new
cat $CWD/config/rc.kpasswdd > $PKG/etc/rc.d/rc.kpasswdd.new
cat $CWD/config/rc.ipropd-master > $PKG/etc/rc.d/rc.ipropd-master.new
cat $CWD/config/rc.ipropd-slave > $PKG/etc/rc.d/rc.ipropd-slave.new
+mkdir -p $PKG/etc/profile.d
+cat $CWD/config/heimdal.sh > $PKG/etc/profile.d/heimdal.sh.new
+
mkdir -p $PKG/var/heimdal
cat $CWD/config/kdc.conf > $PKG/var/heimdal/kdc.conf.new
cat $CWD/config/kadmind.acl > $PKG/var/heimdal/kadmind.acl.new
-mv $PKG/usr/bin/su $PKG/usr/bin/su-heimdal
-
-# Don't ship .la files:
-rm -f $PKG/{,usr/}lib${LIBDIRSUFFIX}/*.la
+rm -f $PKG/{,usr/}heimdal/lib/*.la
-rm -rf $PKG/usr/man/cat?
-find $PKG/usr/man -type f -exec gzip -9 -f {} \;
+rm -rf $PKG/usr/heimdal/man/cat?
+find $PKG/usr/heimdal/man -type f -exec gzip -9 -f {} \;
for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
rm -f $PKG/usr/info/dir
gzip -9 $PKG/usr/info/*
-( cd $PKG/usr/info ; ln -s heimdal.info.gz heimdal )
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a \
@@ -133,7 +150,8 @@ cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
-cat $CWD/doinst.sh > $PKG/install/doinst.sh
+sed -e "s|@LIBDIRSUFFIX@|$LIBDIRSUFFIX|" \
+ $CWD/doinst.sh > $PKG/install/doinst.sh
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/network/heimdal/heimdal.info b/network/heimdal/heimdal.info
index ccfe34d596..4c0c46b21e 100644
--- a/network/heimdal/heimdal.info
+++ b/network/heimdal/heimdal.info
@@ -1,8 +1,8 @@
PRGNAM="heimdal"
-VERSION="7.7.0"
+VERSION="7.8.0"
HOMEPAGE="http://www.h5l.org"
-DOWNLOAD="https://github.com/heimdal/heimdal/releases/download/heimdal-7.7.0/heimdal-7.7.0.tar.gz"
-MD5SUM="82da0bfbe89995c2ecb6cb9c354e06a3"
+DOWNLOAD="https://github.com/heimdal/heimdal/releases/download/heimdal-7.8.0/heimdal-7.8.0.tar.gz"
+MD5SUM="2389c0ad22f2cc2bbef7b27a090d27b5"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""
diff --git a/network/heimdal/slack-desc b/network/heimdal/slack-desc
index 417279b350..07b754ca40 100644
--- a/network/heimdal/slack-desc
+++ b/network/heimdal/slack-desc
@@ -16,4 +16,4 @@ heimdal: (key distribution center) ``kerberized'' versions of programs such
heimdal: as such as login and ftp/ftpd , telnet/telnetd and administration
heimdal: utilities such as ``klist'' and ``kadmin''. krb and GSSAPI libs.
heimdal:
-heimdal: This package conflicts with krb5.
+heimdal: