summaryrefslogtreecommitdiffstats
path: root/network/python-demjson
diff options
context:
space:
mode:
Diffstat (limited to 'network/python-demjson')
-rw-r--r--network/python-demjson/README2
-rw-r--r--network/python-demjson/python-demjson.SlackBuild87
-rw-r--r--network/python-demjson/python-demjson.info10
-rw-r--r--network/python-demjson/slack-desc19
4 files changed, 0 insertions, 118 deletions
diff --git a/network/python-demjson/README b/network/python-demjson/README
deleted file mode 100644
index cfac5b4bda..0000000000
--- a/network/python-demjson/README
+++ /dev/null
@@ -1,2 +0,0 @@
-Encoder, decoder, and lint/validator for JSON (JavaScript Object
-Notation) compliant with RFC 4627
diff --git a/network/python-demjson/python-demjson.SlackBuild b/network/python-demjson/python-demjson.SlackBuild
deleted file mode 100644
index afc81180f7..0000000000
--- a/network/python-demjson/python-demjson.SlackBuild
+++ /dev/null
@@ -1,87 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for python-demjson
-# Copyright 2010 David Woodfall <dave@dawoodfall.net>
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-SRCNAM=demjson
-PRGNAM=python-$SRCNAM
-VERSION=${VERSION:-1.4}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i486 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $SRCNAM-$VERSION
-tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
-cd $SRCNAM-$VERSION
-chown -R root:root .
-find . \
- \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
-
-python setup.py install --root=$PKG
-
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
- AUTHORS.txt CHANGES.txt INSTALL.txt LICENSE.txt NEWS.txt README.txt THANKS.txt docs *.txt \
- $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/network/python-demjson/python-demjson.info b/network/python-demjson/python-demjson.info
deleted file mode 100644
index 573dada797..0000000000
--- a/network/python-demjson/python-demjson.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="python-demjson"
-VERSION="1.4"
-HOMEPAGE="http://pypi.python.org/pypi/demjson"
-DOWNLOAD="http://pypi.python.org/packages/source/d/demjson/demjson-1.4.tar.gz"
-MD5SUM="6f6c88bfe2443390230109c709243fcd"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-MAINTAINER="David Woodfall"
-EMAIL="dave@dawoodfall.net"
-APPROVED="dsomero"
diff --git a/network/python-demjson/slack-desc b/network/python-demjson/slack-desc
deleted file mode 100644
index 8165a04f27..0000000000
--- a/network/python-demjson/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description. Line
-# up the first '|' above the ':' following the base package name, and the '|'
-# on the right side marks the last column you can put a character in. You must
-# make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':'.
-
- |-----handy-ruler------------------------------------------------------|
-python-demjson: python-demjson ( Encoder, decoder, and lint/validator for JSON )
-python-demjson:
-python-demjson: Encoder, decoder, and lint/validator for JSON (JavaScript Object
-python-demjson: Notation) compliant with RFC 4627
-python-demjson:
-python-demjson: Homepage: http://pypi.python.org/pypi/demjson
-python-demjson:
-python-demjson:
-python-demjson:
-python-demjson:
-python-demjson: