summaryrefslogtreecommitdiffstats
path: root/network/rtorrent/rtorrent.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'network/rtorrent/rtorrent.SlackBuild')
-rw-r--r--network/rtorrent/rtorrent.SlackBuild14
1 files changed, 8 insertions, 6 deletions
diff --git a/network/rtorrent/rtorrent.SlackBuild b/network/rtorrent/rtorrent.SlackBuild
index 6eded0f175..7b3fc0df2e 100644
--- a/network/rtorrent/rtorrent.SlackBuild
+++ b/network/rtorrent/rtorrent.SlackBuild
@@ -4,18 +4,17 @@
# Written by Brian Kysela <brian.kysela@gmail.com> 2009-11-04
# Updated to 0.8.6 by Brian Kysela 2010-02-16
# Updated to include rtorrent.rc 2010-04-20
+# Updated to 0.8.7 by Brian Kysela 2010-10-27
PRGNAM=rtorrent
-VERSION=0.8.6
-BUILD=${BUILD:-2}
+VERSION=0.8.7
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
-# Automatically determine the architecture we're building on:
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i486 ;;
arm*) ARCH=arm ;;
- # Unless $ARCH is already set, use uname -m for all other archs:
*) ARCH=$( uname -m ) ;;
esac
fi
@@ -63,14 +62,17 @@ CXXFLAGS="$SLKCFLAGS" \
make
make install DESTDIR=$PKG
-gzip -9 $PKG/usr/man/man?/*.?
+# Taken out as developer removed "out-of-date man page". If you want it back
+# in you will need to edit doc/Makefile.am in the source and uncomment
+# 'man_MANS = rtorrent.1' as well as the line below.
+#gzip -9 $PKG/usr/man/man?/*.?
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a \
- AUTHORS COPYING INSTALL NEWS README TODO doc/rtorrent.rc \
+ AUTHORS COPYING INSTALL README TODO doc/rtorrent.rc \
$PKG/usr/doc/$PRGNAM-$VERSION
find $PKG/usr/doc/$PRGNAM-$VERSION -type f -exec chmod 644 {} \;
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM-SlackBuild