summaryrefslogtreecommitdiffstats
path: root/network/twitter
diff options
context:
space:
mode:
Diffstat (limited to 'network/twitter')
-rw-r--r--network/twitter/twitter.SlackBuild22
-rw-r--r--network/twitter/twitter.info6
2 files changed, 19 insertions, 9 deletions
diff --git a/network/twitter/twitter.SlackBuild b/network/twitter/twitter.SlackBuild
index 96a206bcb3..828245900c 100644
--- a/network/twitter/twitter.SlackBuild
+++ b/network/twitter/twitter.SlackBuild
@@ -1,8 +1,8 @@
-#!/bin/sh
+#!/bin/bash
# Slackware build script for twitter
-# Copyright 2014-2019 Dimitris Zlatanidis Orestiada, Greece
+# Copyright 2014-2022 Dimitris Zlatanidis Orestiada, Greece
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -22,10 +22,13 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+cd $(dirname $0) ; CWD=$(pwd)
+
PRGNAM=twitter
-VERSION=${VERSION:-1.18.0}
+VERSION=${VERSION:-1.19.3}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -35,7 +38,14 @@ if [ -z "$ARCH" ]; then
esac
fi
-CWD=$(pwd)
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
@@ -69,7 +79,7 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
+python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
@@ -83,4 +93,4 @@ cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/network/twitter/twitter.info b/network/twitter/twitter.info
index 2f978c65e6..a0d126b34a 100644
--- a/network/twitter/twitter.info
+++ b/network/twitter/twitter.info
@@ -1,8 +1,8 @@
PRGNAM="twitter"
-VERSION="1.18.0"
+VERSION="1.19.3"
HOMEPAGE="https://mike.verdone.ca/twitter/"
-DOWNLOAD="https://files.pythonhosted.org/packages/8a/9d/cea0ec784ba05d56fbd8a56a674ca12d9b012487528ce91e0064b19224f7/twitter-1.18.0.tar.gz"
-MD5SUM="22aa581b0c463963ae577e62e1a72158"
+DOWNLOAD="https://files.pythonhosted.org/packages/39/ae/1df3708172d04371b1a3efd9d1d790ec4c5eef6da548a9ef85d86f216ab1/twitter-1.19.3.tar.gz"
+MD5SUM="cba038224bb5e20a15463d8794623e4f"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""