summaryrefslogtreecommitdiffstats
path: root/network/urlscan
diff options
context:
space:
mode:
Diffstat (limited to 'network/urlscan')
-rw-r--r--network/urlscan/README20
-rw-r--r--network/urlscan/urlscan.SlackBuild38
-rw-r--r--network/urlscan/urlscan.info8
3 files changed, 42 insertions, 24 deletions
diff --git a/network/urlscan/README b/network/urlscan/README
index b108ec74b6..c3273d2e2a 100644
--- a/network/urlscan/README
+++ b/network/urlscan/README
@@ -1,8 +1,7 @@
-
-Urlscan parses an email message or file and scans it for URLs and email addresses.
-It then displays the URLs and their context within the message,
-and allows you to choose one or more URLs to send to your Web browser.
-Alternatively, it send a list of all URLs to stdout.
+Urlscan parses an email message or file and scans it for URLs and
+email addresses. It then displays the URLs and their context within
+the message, and allows you to choose one or more URLs to send to your
+Web browser. Alternatively, it send a list of all URLs to stdout.
Relative to urlview, urlscan has the following additional features:
@@ -17,11 +16,14 @@ Relative to urlview, urlscan has the following additional features:
* Incremental case-insensitive search with /.
* Execute an arbitrary function (for example, copy URL to clipboard)
instead of opening URL in a browser.
-* Use l to cycle through whether URLs are opened using the Python webbrowser module (default),
- xdg-open (if installed) or opened by a function passed on the command line with --run.
+* Use l to cycle through whether URLs are opened using the Python
+ webbrowser module (default), xdg-open (if installed) or opened by
+ a function passed on the command line with --run.
* Configure colors and keybindings via ~/.config/urlscan/config.json.
Generate default config file for editing by running urlscan -g.
Cycle through available palettes with p.
-* Copy URL to clipboard with C or to primary selection with P. Requires xsel or xclip.
-* Run a command with the selected URL as the argument or pipe the selected URL to a command.
+* Copy URL to clipboard with C or to primary selection with P.
+ Requires xsel or xclip.
+* Run a command with the selected URL as the argument or pipe the
+ selected URL to a command.
* Show complete help menu with F1. Hide header on startup with --nohelp.
diff --git a/network/urlscan/urlscan.SlackBuild b/network/urlscan/urlscan.SlackBuild
index 53135d4c57..87f2633700 100644
--- a/network/urlscan/urlscan.SlackBuild
+++ b/network/urlscan/urlscan.SlackBuild
@@ -1,7 +1,7 @@
-#!/bin/sh
+#!/bin/bash
# Slackware build script for urlscan
-# Copyright 2019 abooksigun <abooksigun09@gmail.com>
+# Copyright 2020 abooksigun <abooksigun09@gmail.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -21,10 +21,13 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+cd $(dirname $0) ; CWD=$(pwd)
+
PRGNAM=urlscan
-VERSION=${VERSION:-0.9.4}
+VERSION=${VERSION:-0.9.5}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -34,7 +37,14 @@ if [ -z "$ARCH" ]; then
esac
fi
-CWD=$(pwd)
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
@@ -63,10 +73,10 @@ tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
python3 setup.py install --root=$PKG --optimize=1
@@ -76,8 +86,14 @@ find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | gr
cp -r $PKG/usr/share/man $PKG/usr
rm -r $PKG/usr/share
-find $PKG/usr/man -type f -exec gzip -9 {} \;
-for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+for man in $( find $PKG/usr/man -type f ); do
+ gzip -9 $man
+done
+
+for man in $( find $PKG/usr/man -type l ); do
+ ln -s $( readlink $man ).gz $man.gz
+ rm $man
+done
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -t $PKG/usr/doc/$PRGNAM-$VERSION README.rst COPYING requirements.txt
@@ -88,4 +104,4 @@ mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/network/urlscan/urlscan.info b/network/urlscan/urlscan.info
index dd9689a567..26329755bd 100644
--- a/network/urlscan/urlscan.info
+++ b/network/urlscan/urlscan.info
@@ -1,10 +1,10 @@
PRGNAM="urlscan"
-VERSION="0.9.4"
+VERSION="0.9.5"
HOMEPAGE="https://github.com/firecat53/urlscan"
-DOWNLOAD="https://github.com/firecat53/urlscan/archive/0.9.4/urlscan-0.9.4.tar.gz"
-MD5SUM="5c735bbb872248f0d981b4efcde257ac"
+DOWNLOAD="https://github.com/firecat53/urlscan/archive/0.9.5/urlscan-0.9.5.tar.gz"
+MD5SUM="6b9434208dbcfd12dd4dde74b4b41b21"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="python3-urwid"
+REQUIRES="python-urwid"
MAINTAINER="abooksigun"
EMAIL="abooksigun09@gmail.com"