summaryrefslogtreecommitdiffstats
path: root/network/vcspull
diff options
context:
space:
mode:
Diffstat (limited to 'network/vcspull')
-rw-r--r--network/vcspull/vcspull.SlackBuild25
-rw-r--r--network/vcspull/vcspull.info10
2 files changed, 23 insertions, 12 deletions
diff --git a/network/vcspull/vcspull.SlackBuild b/network/vcspull/vcspull.SlackBuild
index 14ac5140e9..b857eb09b0 100644
--- a/network/vcspull/vcspull.SlackBuild
+++ b/network/vcspull/vcspull.SlackBuild
@@ -1,8 +1,8 @@
-#!/bin/sh
+#!/bin/bash
# Slackware build script for vcspull
-# Copyright 2014-2016 Dimitris Zlatanidis Orestiada, Greece
+# Copyright 2014-2023 Dimitris Zlatanidis Orestiada, Greece
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -22,10 +22,13 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+cd $(dirname $0) ; CWD=$(pwd)
+
PRGNAM=vcspull
-VERSION=${VERSION:-0.9.0}
+VERSION=${VERSION:-1.25.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -35,7 +38,14 @@ if [ -z "$ARCH" ]; then
esac
fi
-CWD=$(pwd)
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
@@ -69,17 +79,18 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
+python3 -m build --wheel --no-isolation
+python3 -m installer --destdir "$PKG" dist/*.whl
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a CHANGES LICENSE PKG-INFO README.rst doc/* $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a LICENSE PKG-INFO README.md docs/*.md $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/network/vcspull/vcspull.info b/network/vcspull/vcspull.info
index b43f48fc92..21e3561389 100644
--- a/network/vcspull/vcspull.info
+++ b/network/vcspull/vcspull.info
@@ -1,10 +1,10 @@
PRGNAM="vcspull"
-VERSION="0.9.0"
+VERSION="1.25.0"
HOMEPAGE="https://github.com/tony/vcspull/"
-DOWNLOAD="http://ponce.cc/slackware/sources/repo/vcspull-0.9.0.tar.gz"
-MD5SUM="30a82abdff974446aa3b96a7734043af"
+DOWNLOAD="https://files.pythonhosted.org/packages/75/d7/f4e3c1c71a5a6df182b71a4dd657e4f4ea3fb0a906c7e464a2c0b82b2a25/vcspull-1.25.0.tar.gz"
+MD5SUM="90c2d41337157407f77314eb2b32dbd4"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="kaptan PyYAML argcomplete colorama"
+REQUIRES="python3-libvcs colorama"
MAINTAINER="Dimitris Zlatanidis"
-EMAIL="d.zlatanidis@gmail.com"
+EMAIL="dslackw@gmail.com"