summaryrefslogtreecommitdiffstats
path: root/office/kbibtex
diff options
context:
space:
mode:
Diffstat (limited to 'office/kbibtex')
-rw-r--r--office/kbibtex/README13
-rw-r--r--office/kbibtex/desktop_perms.patch13
-rw-r--r--office/kbibtex/kbibtex.SlackBuild39
-rw-r--r--office/kbibtex/kbibtex.info6
-rw-r--r--office/kbibtex/slack-desc14
5 files changed, 55 insertions, 30 deletions
diff --git a/office/kbibtex/README b/office/kbibtex/README
index 5cbb1f1cb9..ab74bceefc 100644
--- a/office/kbibtex/README
+++ b/office/kbibtex/README
@@ -1,8 +1,7 @@
-KBibTeX is a BibTeX editor for KDE to edit bibliographies used with
-LaTeX. KBibTeX is released under the GNU Public License (GPL) version 2
-or any later version.
+The program KBibTeX is a bibliography editor by KDE. Its main purpose is
+to provide a user-friendly interface to BibTeX files.
-KBibTeX for KDE 4 is currently under development. KBibTeX for KDE 4 is
-mature for most daily tasks, but still lacks some features. It is
-recommended that you make backups of all your files before editing
-them with KBibTeX for KDE 4.
+This software, unless noted differently for individual files, materials,
+or contributions, is licensed under the terms of the GNU General Public
+License as published by the Free Software Foundation; either version 2
+of the License, or (at your option) any later version.
diff --git a/office/kbibtex/desktop_perms.patch b/office/kbibtex/desktop_perms.patch
new file mode 100644
index 0000000000..47061964c2
--- /dev/null
+++ b/office/kbibtex/desktop_perms.patch
@@ -0,0 +1,13 @@
+diff --git a/src/program/CMakeLists.txt b/src/program/CMakeLists.txt
+index b9ed670f..8ff76302 100644
+--- a/src/program/CMakeLists.txt
++++ b/src/program/CMakeLists.txt
+@@ -135,7 +135,7 @@ install(
+ )
+
+ install(
+- PROGRAMS
++ FILES
+ org.kde.kbibtex.desktop
+ DESTINATION
+ ${KDE_INSTALL_APPDIR}
diff --git a/office/kbibtex/kbibtex.SlackBuild b/office/kbibtex/kbibtex.SlackBuild
index 712fd85897..5f3ea62116 100644
--- a/office/kbibtex/kbibtex.SlackBuild
+++ b/office/kbibtex/kbibtex.SlackBuild
@@ -1,9 +1,8 @@
-#!/bin/sh
-# vim: et ts=2 sw=2
+#!/bin/bash
# Slackware build script for kbibtex
-# Copyright (c) 2011 Gregory J.L. Tourte (artourter@gmail.com)
+# Copyright (c) 2011-2023 Gregory J. L. Tourte (artourter@gmail.com)
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,10 +22,15 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+cd $(dirname $0) ; CWD=$(pwd)
+
PRGNAM=kbibtex
-VERSION=${VERSION:-0.7}
+VERSION=${VERSION:-0.10.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+SRCVER=v$VERSION
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -36,7 +40,14 @@ if [ -z "$ARCH" ]; then
esac
fi
-CWD=$(pwd)
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
@@ -60,9 +71,9 @@ set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
+rm -rf $PRGNAM-$SRCVER
+tar xvf $CWD/$PRGNAM-$SRCVER.tar.bz2
+cd $PRGNAM-$SRCVER
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
@@ -70,15 +81,17 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+patch -p1 < $CWD/desktop_perms.patch
+
mkdir -p build
cd build
cmake \
- -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
-DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
-DCMAKE_INSTALL_PREFIX=/usr \
- -DLIB_SUFFIX=${LIBDIRSUFFIX} \
- -DMANDIR=/usr/man \
+ -DCMAKE_INSTALL_MANDIR=/usr/man \
+ -DKDE_INSTALL_DOCBUNDLEDIR=/usr/doc/HTML \
-DCMAKE_BUILD_TYPE=Release \
+ -DBUILD_TESTING=OFF \
-Wno-dev \
..
@@ -92,7 +105,7 @@ find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | gr
find $PKG/usr/man -type f -exec gzip -9 {} \;
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a README LICENSE TODO $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README.md LICENSE TODO.md ChangeLog $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
@@ -100,4 +113,4 @@ cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/office/kbibtex/kbibtex.info b/office/kbibtex/kbibtex.info
index ce1fa76722..2b6ee7ef86 100644
--- a/office/kbibtex/kbibtex.info
+++ b/office/kbibtex/kbibtex.info
@@ -1,8 +1,8 @@
PRGNAM="kbibtex"
-VERSION="0.7"
+VERSION="0.10.0"
HOMEPAGE="https://userbase.kde.org/KBibTeX"
-DOWNLOAD="https://github.com/KDE/kbibtex/archive/v0.7/kbibtex-0.7.tar.gz"
-MD5SUM="db8f045be7fdb7fdb3101b47dd9b1bd3"
+DOWNLOAD="https://invent.kde.org/office/kbibtex/-/archive/v0.10.0/kbibtex-v0.10.0.tar.bz2"
+MD5SUM="4b32d308183cdc88ba4e485c8e4e74b9"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""
diff --git a/office/kbibtex/slack-desc b/office/kbibtex/slack-desc
index 9899f6105c..b9de6e4550 100644
--- a/office/kbibtex/slack-desc
+++ b/office/kbibtex/slack-desc
@@ -8,12 +8,12 @@
|-----handy-ruler------------------------------------------------------|
kbibtex: kbibtex (A BibTeX editor for KDE)
kbibtex:
-kbibtex: KBibTeX is a BibTeX editor for KDE to edit bibliographies used with
-kbibtex: LaTeX. KBibTeX is released under the GNU Public License (GPL) version
-kbibtex: 2 or any later version.
+kbibtex: The program KBibTeX is a bibliography editor by KDE. Its main purpose
+kbibtex: is to provide a user-friendly interface to BibTeX files.
kbibtex:
-kbibtex: KBibTeX for KDE 4 is currently under development. KBibTeX for KDE 4
-kbibtex: is mature for most daily tasks, but still lacks some features. It is
-kbibtex: recommended that you make backups of all your files before editing
-kbibtex: them with KBibTeX for KDE 4.
+kbibtex: This software, unless noted differently for individual files,
+kbibtex: materials, or contributions, is licensed under the terms of the GNU
+kbibtex: General Public License as published by the Free Software Foundation;
+kbibtex: either version 2 of the License, or (at your option) any later
+kbibtex: version.
kbibtex: