summaryrefslogtreecommitdiffstats
path: root/office/zathura/zathura.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'office/zathura/zathura.SlackBuild')
-rw-r--r--office/zathura/zathura.SlackBuild18
1 files changed, 9 insertions, 9 deletions
diff --git a/office/zathura/zathura.SlackBuild b/office/zathura/zathura.SlackBuild
index e084440cb5..9241dcee1e 100644
--- a/office/zathura/zathura.SlackBuild
+++ b/office/zathura/zathura.SlackBuild
@@ -29,8 +29,12 @@
# - Include generated man pages
# - fix homepage URL
+# Updated 20120721 by B. Watson <yalhcru@gmail.com>:
+# - Updated for v0.2.0
+# - generated man pages now included by upstream, get rid of ours
+
PRGNAM=zathura
-VERSION=${VERSION:-0.1.1}
+VERSION=${VERSION:-0.2.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -82,17 +86,11 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
-# zathura uses rst2man from docutils to generate its man pages. Rather than
-# require docutils (1.5MB download) as a dep, just include the man pages (5KB)
-# with the SlackBuild archive.
-mkdir -p $PKG/usr/man/man1 $PKG/usr/man/man5
-cp $CWD/*.1.gz $PKG/usr/man/man1/
-cp $CWD/*.5.gz $PKG/usr/man/man5/
-
sed -i "s/-pedantic/$SLKCFLAGS/" config.mk
make LIBDIR=/usr/lib$LIBDIRSUFFIX
-make install LIBDIR=/usr/lib$LIBDIRSUFFIX DESTDIR=$PKG RSTTOMAN=""
+make install LIBDIR=/usr/lib$LIBDIRSUFFIX MANPREFIX=/usr/man DESTDIR=$PKG RSTTOMAN=""
+gzip $PKG/usr/man/man?/*.?
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a AUTHORS LICENSE README $PKG/usr/doc/$PRGNAM-$VERSION
@@ -115,6 +113,8 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
+# ZATHURA_VERSION_CHECK=0 shouldn't be required :(
+
sed -i "s/-fPIC/$SLKCFLAGS/" config.mk
make install \
ZATHURA_INC=-I.. \