summaryrefslogtreecommitdiffstats
path: root/python/Flask-Babel
diff options
context:
space:
mode:
Diffstat (limited to 'python/Flask-Babel')
-rw-r--r--python/Flask-Babel/Flask-Babel.SlackBuild85
-rw-r--r--python/Flask-Babel/Flask-Babel.info10
-rw-r--r--python/Flask-Babel/README4
-rw-r--r--python/Flask-Babel/slack-desc19
4 files changed, 0 insertions, 118 deletions
diff --git a/python/Flask-Babel/Flask-Babel.SlackBuild b/python/Flask-Babel/Flask-Babel.SlackBuild
deleted file mode 100644
index 47fd06eff1..0000000000
--- a/python/Flask-Babel/Flask-Babel.SlackBuild
+++ /dev/null
@@ -1,85 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for Flask-Babel
-
-# Copyright 2017 Nikos Giotis <nikos.giotis@gmail.com>
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM=Flask-Babel
-VERSION=${VERSION:-0.11.1}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python setup.py install --root=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a LICENSE $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/Flask-Babel/Flask-Babel.info b/python/Flask-Babel/Flask-Babel.info
deleted file mode 100644
index 4f7967ac31..0000000000
--- a/python/Flask-Babel/Flask-Babel.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="Flask-Babel"
-VERSION="0.11.1"
-HOMEPAGE="https://github.com/python-babel/flask-babel"
-DOWNLOAD="https://pypi.python.org/packages/47/96/6013d4091fb4238e27e918aec4929f082942fa8c9489ae3aad2f18de4b5b/Flask-Babel-0.11.1.tar.gz"
-MD5SUM="658e84a20ddc545a7612144fe2c758d3"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="Flask babel"
-MAINTAINER="Nikos Giotis"
-EMAIL="nikos.giotis@gmail.com"
diff --git a/python/Flask-Babel/README b/python/Flask-Babel/README
deleted file mode 100644
index 9978b4568f..0000000000
--- a/python/Flask-Babel/README
+++ /dev/null
@@ -1,4 +0,0 @@
-Flask-Babel is an extension to Flask that adds i18n and l10n support
-to any Flask application with the help of babel, pytz and speaklater.
-It has builtin support for date formatting with timezone support as
-well as a very simple and friendly interface to gettext translations. \ No newline at end of file
diff --git a/python/Flask-Babel/slack-desc b/python/Flask-Babel/slack-desc
deleted file mode 100644
index fd326f6d8e..0000000000
--- a/python/Flask-Babel/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-Flask-Babel: Flask-Babel (Adds i18n/l10n support to Flask applications)
-Flask-Babel:
-Flask-Babel: Flask-Babel is an extension to Flask that adds i18n and l10n support
-Flask-Babel: to any Flask application with the help of babel, pytz and speaklater.
-Flask-Babel: It has builtin support for date formatting with timezone support as
-Flask-Babel: well as a very simple and friendly interface to gettext translations.
-Flask-Babel:
-Flask-Babel: https://github.com/python-babel/flask-babel
-Flask-Babel:
-Flask-Babel:
-Flask-Babel: