summaryrefslogtreecommitdiffstats
path: root/python/plaso
diff options
context:
space:
mode:
Diffstat (limited to 'python/plaso')
-rw-r--r--python/plaso/README21
-rw-r--r--python/plaso/plaso.SlackBuild29
-rw-r--r--python/plaso/plaso.info8
3 files changed, 36 insertions, 22 deletions
diff --git a/python/plaso/README b/python/plaso/README
index 14750f58e3..88138a895b 100644
--- a/python/plaso/README
+++ b/python/plaso/README
@@ -1,13 +1,14 @@
plaso (Forensic Super-Timeline)
-Plaso is the Python based back-end engine used by tools such as log2timeline
-for automatic creation of a super timelines. The goal of log2timeline (and
-thus plaso) is to provide a single tool that can parse various log files and
-forensic artifacts from computers and related systems, such as network equipment
-to produce a single correlated timeline. This timeline can then be easily
-analysed by forensic investigators/analysts, speeding up investigations by
-correlating the vast amount of information found on an average computer system.
+Plaso is the Python based back-end engine used by tools such as
+log2timeline for automatic creation of a super timelines. The goal of
+log2timeline (and thus plaso) is to provide a single tool that can parse
+various log files and forensic artifacts from computers and related
+systems, such as network equipment to produce a single correlated
+timeline. This timeline can then be easily analysed by forensic
+investigators/analysts, speeding up investigations by correlating the
+vast amount of information found on an average computer system.
-Please pay close attention to the build order for plaso and its requirements
-(particularly dfvfs). Read the README files and do NOT rely on automated
-package tools.
+Please pay close attention to the build order for plaso and its
+requirements (particularly dfvfs). Read the README files and do NOT
+rely on automated package tools.
diff --git a/python/plaso/plaso.SlackBuild b/python/plaso/plaso.SlackBuild
index 88294e10d2..e00e10dbed 100644
--- a/python/plaso/plaso.SlackBuild
+++ b/python/plaso/plaso.SlackBuild
@@ -1,7 +1,7 @@
-#!/bin/sh
+#!/bin/bash
# Slackware build script for plaso
-# Copyright 2015-2019 Barry Grundy <bgrundy[at]linuxleo.com>
+# Copyright 2015-2023 Barry Grundy <bgrundy[at]linuxleo.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -21,12 +21,15 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
#
-# Updated Build version 20190131, March 2019
+# Updated for version 20230717, May 2022
+
+cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=plaso
-VERSION=${VERSION:-20190131}
+VERSION=${VERSION:-20230717}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -36,7 +39,14 @@ if [ -z "$ARCH" ]; then
esac
fi
-CWD=$(pwd)
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
@@ -70,19 +80,22 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
+python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a ACKNOWLEDGEMENTS AUTHORS LICENSE README $PKG/usr/doc/$PRGNAM-$VERSION/
+cp -a LICENSE README $PKG/usr/doc/$PRGNAM-$VERSION/
# Remove duplicated docs in /usr/share/doc
rm -rf $PKG/usr/share
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+# Copy data files into /usr/share/$PRGNAM
+mkdir -p $PKG/usr/share/$PRGNAM
+cp -a data/. $PKG/usr/share/$PRGNAM/
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/plaso/plaso.info b/python/plaso/plaso.info
index 6e1fd11bf0..e698108b4a 100644
--- a/python/plaso/plaso.info
+++ b/python/plaso/plaso.info
@@ -1,10 +1,10 @@
PRGNAM="plaso"
-VERSION="20190131"
+VERSION="20230717"
HOMEPAGE="https://github.com/log2timeline/plaso"
-DOWNLOAD="https://github.com/log2timeline/plaso/releases/download/20190131/plaso-20190131.tar.gz"
-MD5SUM="42402d1a43b7145d34f91bb3d64ef346"
+DOWNLOAD="https://linuxleo.com/Source/plaso-20230717.tar.gz"
+MD5SUM="57e8bf97ab04fe81194cf4d97913a8e8"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="dfvfs artifacts bencode biplist python-requests python-dateutil dfwinreg dotty elasticsearch5 hachoir-metadata idna python-lz4 pefile psutil pyparsing pyzmq pytz XlsxWriter libesedb libevt libevtx libfwsi liblnk libmsiecf libolecf libscca yara-python"
+REQUIRES="dfvfs artifacts acstore python3-bencode python3-dateutil python3-defusedxml dfwinreg python3-lz4 pefile python3-psutil python3-pyzmq pytz libcaes libesedb libevt libevtx libfwsi liblnk libmsiecf libolecf libscca redis-py python3-yara XlsxWriter"
MAINTAINER="Barry J. Grundy"
EMAIL="bgrundy<at>linuxleo.com"