summaryrefslogtreecommitdiffstats
path: root/python/pychm/pychm.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/pychm/pychm.SlackBuild')
-rw-r--r--python/pychm/pychm.SlackBuild34
1 files changed, 26 insertions, 8 deletions
diff --git a/python/pychm/pychm.SlackBuild b/python/pychm/pychm.SlackBuild
index cea6426868..96270c4971 100644
--- a/python/pychm/pychm.SlackBuild
+++ b/python/pychm/pychm.SlackBuild
@@ -1,4 +1,4 @@
-#!/bin/sh
+#!/bin/bash
# Slackware build script for PyCHM
@@ -25,20 +25,30 @@
# OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
# THE SOFTWARE.
+cd $(dirname $0) ; CWD=$(pwd)
+
PRGNAM=pychm
-VERSION=${VERSION:-0.8.4}
+VERSION=${VERSION:-0.8.6}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
fi
-CWD=$(pwd)
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
@@ -58,18 +68,26 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
-python setup.py build
-python setup.py install --root $PKG
+if [ -x /usr/bin/python2 ]
+then
+ python2 setup.py install --root $PKG
+fi
+
+if [ -x /usr/bin/python3 ]
+then
+ python3 setup.py install --root $PKG
+fi
+
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a COPYING ChangeLog NEWS PKG-INFO README $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a AUTHORS COPYING HACKING LICENSE NEWS README $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE