summaryrefslogtreecommitdiffstats
path: root/python/pycryptodomex
diff options
context:
space:
mode:
Diffstat (limited to 'python/pycryptodomex')
-rw-r--r--python/pycryptodomex/README14
-rw-r--r--python/pycryptodomex/pycryptodomex.SlackBuild39
-rw-r--r--python/pycryptodomex/pycryptodomex.info6
3 files changed, 26 insertions, 33 deletions
diff --git a/python/pycryptodomex/README b/python/pycryptodomex/README
index 7b818930c5..8aa5026945 100644
--- a/python/pycryptodomex/README
+++ b/python/pycryptodomex/README
@@ -1,8 +1,8 @@
-PyCryptodome is a self-contained Python package of low-level cryptographic
-primitives. It supports Python 2.6 or newer, all Python 3 versions and PyPy.
-PyCryptodome is a fork of PyCrypto.
+PyCryptodome is a self-contained Python package of low-level
+cryptographic primitives. It supports Python 2.6 or newer, all Python 3
+versions and PyPy. PyCryptodome is a fork of PyCrypto.
-PyCryptodome is not a wrapper to a separate C library like OpenSSL. To the
-largest possible extent, algorithms are implemented in pure Python. Only the
-pieces that are extremely critical to performance (e.g. block ciphers) are
-implemented as C extensions.
+PyCryptodome is not a wrapper to a separate C library like OpenSSL. To
+the largest possible extent, algorithms are implemented in pure Python.
+Only the pieces that are extremely critical to performance (e.g. block
+ciphers) are implemented as C extensions.
diff --git a/python/pycryptodomex/pycryptodomex.SlackBuild b/python/pycryptodomex/pycryptodomex.SlackBuild
index fa187e5429..16bc633cbc 100644
--- a/python/pycryptodomex/pycryptodomex.SlackBuild
+++ b/python/pycryptodomex/pycryptodomex.SlackBuild
@@ -1,4 +1,4 @@
-#!/bin/sh
+#!/bin/bash
# Slackware build script for pycryptodomex
@@ -22,10 +22,13 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+cd $(dirname $0) ; CWD=$(pwd)
+
PRGNAM=pycryptodomex
-VERSION=${VERSION:-3.9.9}
+VERSION=${VERSION:-3.20.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -35,25 +38,18 @@ if [ -z "$ARCH" ]; then
esac
fi
-CWD=$(pwd)
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
set -e
rm -rf $PKG
@@ -69,11 +65,8 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
-
-if $(python3 -c 'import sys' 2>/dev/null); then
- python3 setup.py install --root=$PKG
-fi
+python2 setup.py install --root=$PKG
+python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
@@ -88,4 +81,4 @@ mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/pycryptodomex/pycryptodomex.info b/python/pycryptodomex/pycryptodomex.info
index 14bec407e6..bd0c97b3eb 100644
--- a/python/pycryptodomex/pycryptodomex.info
+++ b/python/pycryptodomex/pycryptodomex.info
@@ -1,8 +1,8 @@
PRGNAM="pycryptodomex"
-VERSION="3.9.9"
+VERSION="3.20.0"
HOMEPAGE="https://github.com/Legrandin/pycryptodome"
-DOWNLOAD="https://github.com/Legrandin/pycryptodome/archive/v3.9.9x/pycryptodome-3.9.9x.tar.gz"
-MD5SUM="2c93ea38caa2138fc974cf38e454bea2"
+DOWNLOAD="https://github.com/Legrandin/pycryptodome/archive/v3.20.0x/pycryptodome-3.20.0x.tar.gz"
+MD5SUM="934fe89c1fd2070391cf60de8c8147f9"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""