summaryrefslogtreecommitdiffstats
path: root/python/pynzb
diff options
context:
space:
mode:
Diffstat (limited to 'python/pynzb')
-rw-r--r--python/pynzb/README10
-rw-r--r--python/pynzb/pynzb.SlackBuild54
-rw-r--r--python/pynzb/pynzb.info10
-rw-r--r--python/pynzb/slack-desc19
4 files changed, 0 insertions, 93 deletions
diff --git a/python/pynzb/README b/python/pynzb/README
deleted file mode 100644
index 48dd4f2de9..0000000000
--- a/python/pynzb/README
+++ /dev/null
@@ -1,10 +0,0 @@
-NZB is an XML-based file format for retrieving posts from NNTP (Usenet)
-servers. Since NZB is XML-based, it's relatively easy to build one-off
-parsers to parse NZB files. This project is an attempt to consolidate
-those many one-off NZB parsers into one simple interface.
-
-This package includes three implementations: one based on expat, another
-based on ElementTree, and a final implementation based on lxml. The order
-in which they were listed is in order of compatibility. The expat version
-should work on all versions of Python > 2.0, the lxml one will work on
-all versions > 2.5, and lxml will only work if you have lxml installed.
diff --git a/python/pynzb/pynzb.SlackBuild b/python/pynzb/pynzb.SlackBuild
deleted file mode 100644
index dc9862588a..0000000000
--- a/python/pynzb/pynzb.SlackBuild
+++ /dev/null
@@ -1,54 +0,0 @@
-#!/bin/sh
-# Generated by Alien's SlackBuild Toolkit: http://slackware.com/~alien/AST
-# Copyright 2009-2010 Eric Hameleers, Eindhoven, Netherlands
-# Slackware build script for pynzb
-# Written by Lionel Young <redtricycle@gmail.com>
-# Based on http://slackbuilds.org/template.SlackBuild
-
-PRGNAM=pynzb
-VERSION=${VERSION:-0.1.0}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) export ARCH=i486 ;;
- arm*) export ARCH=arm ;;
- *) export ARCH=$( uname -m ) ;;
- esac
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
-
-python setup.py build || exit 1
-python setup.py install --root=$PKG || exit 1
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
- PKG-INFO \
- $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/pynzb/pynzb.info b/python/pynzb/pynzb.info
deleted file mode 100644
index d1a6513380..0000000000
--- a/python/pynzb/pynzb.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="pynzb"
-VERSION="0.1.0"
-HOMEPAGE="https://github.com/ericflo/pynzb"
-DOWNLOAD="https://pypi.python.org/packages/source/p/pynzb/pynzb-0.1.0.tar.gz"
-MD5SUM="63c74a36348ac28aa99732dcb8be8c59"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Lionel Young"
-EMAIL="redtricycle@gmail.com"
diff --git a/python/pynzb/slack-desc b/python/pynzb/slack-desc
deleted file mode 100644
index 746cd0407b..0000000000
--- a/python/pynzb/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-pynzb: pynzb (NZB file format parser)
-pynzb:
-pynzb: NZB is an XML-based file format for retrieving posts from NNTP
-pynzb: (Usenet) servers. Since NZB is XML-based, it's relatively
-pynzb: easy to build one-off parsers to parse NZB files. This project is
-pynzb: an attempt to consolidate those many one-off NZB parsers into one
-pynzb: simple interface.
-pynzb:
-pynzb: Home: https://github.com/ericflo/pynzb
-pynzb:
-pynzb: