summaryrefslogtreecommitdiffstats
path: root/python/python-ly
diff options
context:
space:
mode:
Diffstat (limited to 'python/python-ly')
-rw-r--r--python/python-ly/README8
-rw-r--r--python/python-ly/python-ly.SlackBuild20
-rw-r--r--python/python-ly/python-ly.info6
3 files changed, 22 insertions, 12 deletions
diff --git a/python/python-ly/README b/python/python-ly/README
index da506d6af8..d75c6c8fbf 100644
--- a/python/python-ly/README
+++ b/python/python-ly/README
@@ -1,4 +1,4 @@
-This package provides a Python library ly containing various Python modules to
-parse, manipulate or create documents in LilyPond format. A command line
-program ly is also provided that can be used to do various manipulations with
-LilyPond files.
+This package provides a Python library ly containing various Python
+modules to parse, manipulate or create documents in LilyPond format. A
+command line program ly is also provided that can be used to do
+various manipulations with LilyPond files.
diff --git a/python/python-ly/python-ly.SlackBuild b/python/python-ly/python-ly.SlackBuild
index db723cd24f..9b2033d86e 100644
--- a/python/python-ly/python-ly.SlackBuild
+++ b/python/python-ly/python-ly.SlackBuild
@@ -1,12 +1,15 @@
-#!/bin/sh
+#!/bin/bash
# Slackware build script for <python-ly>
#
# Michales (clavisound) Michaloudes korgie@gmail.com <2017>
+cd $(dirname $0) ; CWD=$(pwd)
+
PRGNAM=python-ly
-VERSION=${VERSION:-0.9.4}
+VERSION=${VERSION:-0.9.7}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -16,7 +19,14 @@ if [ -z "$ARCH" ]; then
esac
fi
-CWD=$(pwd)
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
@@ -50,7 +60,7 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root $PKG
+python3 setup.py install --root $PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
@@ -66,4 +76,4 @@ mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/python-ly/python-ly.info b/python/python-ly/python-ly.info
index 0a37c9ad66..9e00f6558a 100644
--- a/python/python-ly/python-ly.info
+++ b/python/python-ly/python-ly.info
@@ -1,8 +1,8 @@
PRGNAM="python-ly"
-VERSION="0.9.4"
+VERSION="0.9.7"
HOMEPAGE="https://pypi.python.org/pypi/python-ly/"
-DOWNLOAD="https://pypi.python.org/packages/57/4f/889579244947368f28eda66b782331b1e75f83fd72e63f9ece93cd7a18f9/python-ly-0.9.4.tar.gz"
-MD5SUM="14c8f6bb5c887564af187d1fd5fbbc91"
+DOWNLOAD="https://files.pythonhosted.org/packages/9b/ed/e277509bb9f9376efe391f2f5a27da9840366d12a62bef30f44e5a24e0d9/python-ly-0.9.7.tar.gz"
+MD5SUM="88058a68cf54377d86c648094ed45743"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""