summaryrefslogtreecommitdiffstats
path: root/python/python2-suds
diff options
context:
space:
mode:
Diffstat (limited to 'python/python2-suds')
-rw-r--r--python/python2-suds/README1
-rw-r--r--python/python2-suds/python2-suds.SlackBuild66
-rw-r--r--python/python2-suds/python2-suds.info10
-rw-r--r--python/python2-suds/slack-desc19
4 files changed, 96 insertions, 0 deletions
diff --git a/python/python2-suds/README b/python/python2-suds/README
new file mode 100644
index 0000000000..7ae900bb0b
--- /dev/null
+++ b/python/python2-suds/README
@@ -0,0 +1 @@
+Suds is a lightweight SOAP python client for consuming Web Services.
diff --git a/python/python2-suds/python2-suds.SlackBuild b/python/python2-suds/python2-suds.SlackBuild
new file mode 100644
index 0000000000..3ccecb648c
--- /dev/null
+++ b/python/python2-suds/python2-suds.SlackBuild
@@ -0,0 +1,66 @@
+#!/bin/bash
+
+# Slackware build script for python-suds
+# Written by Joey Trungale <joey@trungale.net>
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=python2-suds
+SRCNAM=python-suds
+VERSION=${VERSION:-0.3.9}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+DOCS="LICENSE README"
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+python2 setup.py install --root=$PKG
+
+find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/python2-suds/python2-suds.info b/python/python2-suds/python2-suds.info
new file mode 100644
index 0000000000..8655686b75
--- /dev/null
+++ b/python/python2-suds/python2-suds.info
@@ -0,0 +1,10 @@
+PRGNAM="python2-suds"
+VERSION="0.3.9"
+HOMEPAGE="https://fedorahosted.org/suds/"
+DOWNLOAD="http://ponce.cc/slackware/sources/repo/python-suds-0.3.9.tar.gz"
+MD5SUM="420ac4b6ba788e43631b74719a470bf7"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Joey Trungale"
+EMAIL="joey@trungale.net"
diff --git a/python/python2-suds/slack-desc b/python/python2-suds/slack-desc
new file mode 100644
index 0000000000..30bd23503c
--- /dev/null
+++ b/python/python2-suds/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python2-suds: python2-suds (Python SOAP client)
+python2-suds:
+python2-suds: Suds is a lightweight SOAP python client for consuming Web Services.
+python2-suds:
+python2-suds: https://fedorahosted.com/suds
+python2-suds:
+python2-suds:
+python2-suds:
+python2-suds:
+python2-suds:
+python2-suds: