summaryrefslogtreecommitdiffstats
path: root/python/python3-dulwich
diff options
context:
space:
mode:
Diffstat (limited to 'python/python3-dulwich')
-rw-r--r--python/python3-dulwich/README4
-rw-r--r--python/python3-dulwich/python3-dulwich.SlackBuild82
-rw-r--r--python/python3-dulwich/python3-dulwich.info10
-rw-r--r--python/python3-dulwich/slack-desc19
4 files changed, 115 insertions, 0 deletions
diff --git a/python/python3-dulwich/README b/python/python3-dulwich/README
new file mode 100644
index 0000000000..7ec8b93eeb
--- /dev/null
+++ b/python/python3-dulwich/README
@@ -0,0 +1,4 @@
+Dulwich is a Python implementation of the Git file formats and
+protocols. It aims to give an interface to git repos (both local and
+remote) that doesn't call out to git directly but instead uses pure
+Python.
diff --git a/python/python3-dulwich/python3-dulwich.SlackBuild b/python/python3-dulwich/python3-dulwich.SlackBuild
new file mode 100644
index 0000000000..45a80b20ec
--- /dev/null
+++ b/python/python3-dulwich/python3-dulwich.SlackBuild
@@ -0,0 +1,82 @@
+#!/bin/bash
+
+# Slackware build script for python3-dulwich
+
+# Yth | Pont-en-Royans, France | yth@ythogtha.org
+# Copyright 2012-2017 Audrius Kažukauskas <audrius@neutrino.lt>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=python3-dulwich
+SRCNAM=${PRGNAM#python3-*}
+VERSION=${VERSION:-0.22.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+PYVER=$(python3 -c 'import sys; print("%d.%d" % sys.version_info[:2])')
+export PYTHONPATH=/opt/python$PYVER/site-packages/
+python3 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a AUTHORS *.rst COPYING NEWS $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/python3-dulwich/python3-dulwich.info b/python/python3-dulwich/python3-dulwich.info
new file mode 100644
index 0000000000..9ecc757a3a
--- /dev/null
+++ b/python/python3-dulwich/python3-dulwich.info
@@ -0,0 +1,10 @@
+PRGNAM="python3-dulwich"
+VERSION="0.22.1"
+HOMEPAGE="https://www.dulwich.io/"
+DOWNLOAD="https://pypi.python.org/packages/source/d/dulwich/dulwich-0.22.1.tar.gz"
+MD5SUM="08e441d9f3c978a89ce682bfcc101dda"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="python3-setuptools-rust-opt"
+MAINTAINER="Yth - Arnaud"
+EMAIL="yth@ythogtha.org"
diff --git a/python/python3-dulwich/slack-desc b/python/python3-dulwich/slack-desc
new file mode 100644
index 0000000000..aa4eb68ec1
--- /dev/null
+++ b/python/python3-dulwich/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python3-dulwich: python3-dulwich (Python implementation of Git formats and protocols)
+python3-dulwich:
+python3-dulwich: Dulwich is a Python implementation of the Git file formats and
+python3-dulwich: protocols. It aims to give an interface to git repos (both local and
+python3-dulwich: remote) that doesn't call out to git directly but instead uses pure
+python3-dulwich: Python. The project is named after the village in which Mr. and
+python3-dulwich: Mrs. Git live in the Monty Python sketch.
+python3-dulwich:
+python3-dulwich: Homepage: https://www.dulwich.io/
+python3-dulwich:
+python3-dulwich: