summaryrefslogtreecommitdiffstats
path: root/python/python3-falcon
diff options
context:
space:
mode:
Diffstat (limited to 'python/python3-falcon')
-rw-r--r--python/python3-falcon/README13
-rw-r--r--python/python3-falcon/python3-falcon.SlackBuild74
-rw-r--r--python/python3-falcon/python3-falcon.info10
-rw-r--r--python/python3-falcon/slack-desc19
4 files changed, 116 insertions, 0 deletions
diff --git a/python/python3-falcon/README b/python/python3-falcon/README
new file mode 100644
index 0000000000..0b14a6ae0a
--- /dev/null
+++ b/python/python3-falcon/README
@@ -0,0 +1,13 @@
+The Falcon Web Framework
+
+Falcon is a minimalist ASGI/WSGI framework for building
+mission-critical REST APIs and microservices, with a focus on
+reliability, correctness, and performance at scale.
+
+When it comes to building HTTP APIs, other frameworks weigh you down
+with tons of dependencies and unnecessary abstractions.
+Falcon cuts to the chase with a clean design that embraces HTTP and
+the REST architectural style.
+
+Falcon apps work with any WSGI or ASGI server, and run like a champ
+under CPython 3.5+ and PyPy 3.5+ (3.6+ required for ASGI).
diff --git a/python/python3-falcon/python3-falcon.SlackBuild b/python/python3-falcon/python3-falcon.SlackBuild
new file mode 100644
index 0000000000..58c091f848
--- /dev/null
+++ b/python/python3-falcon/python3-falcon.SlackBuild
@@ -0,0 +1,74 @@
+#!/bin/bash
+
+# Slackware build script for python3-falcon
+
+# Copyright 2023 Yth | Pont-en-Royans, France | yth@ythogtha.org
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=python3-falcon
+SRCNAM=${PRGNAM#python3-*}
+VERSION=${VERSION:-3.1.3}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.?z*
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) -exec chmod 755 {} \; -o \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python3 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a [A-Z][A-Z]* $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/python3-falcon/python3-falcon.info b/python/python3-falcon/python3-falcon.info
new file mode 100644
index 0000000000..fae8cacfda
--- /dev/null
+++ b/python/python3-falcon/python3-falcon.info
@@ -0,0 +1,10 @@
+PRGNAM="python3-falcon"
+VERSION="3.1.3"
+HOMEPAGE="https://falconframework.org/"
+DOWNLOAD="https://pypi.python.org/packages/source/f/falcon/falcon-3.1.3.tar.gz"
+MD5SUM="22a5c32f3d9dd96d498febe8e16ddffe"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Yth - Arnaud"
+EMAIL="yth@ythogtha.org"
diff --git a/python/python3-falcon/slack-desc b/python/python3-falcon/slack-desc
new file mode 100644
index 0000000000..7aa12b1859
--- /dev/null
+++ b/python/python3-falcon/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python3-falcon: python3-falcon (ASGI+WSGI framework for building data plane APIs)
+python3-falcon:
+python3-falcon: The Falcon Web Framework is a minimalist ASGI/WSGI framework for
+python3-falcon: building mission-critical REST APIs and microservices, with a focus
+python3-falcon: on reliability, correctness, and performance at scale.
+python3-falcon:
+python3-falcon: Falcon apps work with any WSGI or ASGI server, and run like a champ
+python3-falcon: under CPython 3.5+ and PyPy 3.5+ (3.6+ required for ASGI).
+python3-falcon:
+python3-falcon:
+python3-falcon: