summaryrefslogtreecommitdiffstats
path: root/python/python3-mat2
diff options
context:
space:
mode:
Diffstat (limited to 'python/python3-mat2')
-rw-r--r--python/python3-mat2/README25
-rw-r--r--python/python3-mat2/python3-mat2.SlackBuild76
-rw-r--r--python/python3-mat2/python3-mat2.info10
-rw-r--r--python/python3-mat2/slack-desc19
4 files changed, 130 insertions, 0 deletions
diff --git a/python/python3-mat2/README b/python/python3-mat2/README
new file mode 100644
index 0000000000..ddc53c7093
--- /dev/null
+++ b/python/python3-mat2/README
@@ -0,0 +1,25 @@
+Metadata and privacy
+
+Metadata consist of information that characterizes data. Metadata are
+used to provide documentation for data products. In essence, metadata
+answer who, what, when, where, why, and how about every facet of the
+data that are being documented. Metadata within a file can tell a lot
+about you. Cameras record data about when a picture was taken and what
+camera was used. Office documents like PDF or Office automatically
+adds author and company information to documents and spreadsheets.
+Maybe you don't want to disclose those information.
+
+This is precisely the job of mat2: getting rid, as much as possible,
+of metadata.
+
+mat2 provides:
+
+a library called libmat2;
+a command line tool called mat2,
+a service menu for Dolphin, KDE's default file manager
+
+If you prefer a regular graphical user interface, you might be
+interested in Metadata Cleaner
+(https://metadatacleaner.romainvigier.fr/ , not on SBo), which is
+using mat2 under the hood.
+
diff --git a/python/python3-mat2/python3-mat2.SlackBuild b/python/python3-mat2/python3-mat2.SlackBuild
new file mode 100644
index 0000000000..80568bae70
--- /dev/null
+++ b/python/python3-mat2/python3-mat2.SlackBuild
@@ -0,0 +1,76 @@
+#!/bin/bash
+
+# Slackware build script for mat2
+
+# Copyright 2023 Lockywolf
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=python3-mat2
+TGZNAM=mat2
+VERSION=${VERSION:-0.13.3}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+ARCH=noarch
+
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $TGZNAM-$VERSION
+tar xvf $CWD/$TGZNAM-$VERSION.tar.gz
+cd $TGZNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python3 setup.py install --root=$PKG
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+CHANGELOG.md README.md \
+CONTRIBUTING.md LICENSE \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/python3-mat2/python3-mat2.info b/python/python3-mat2/python3-mat2.info
new file mode 100644
index 0000000000..50a17070a0
--- /dev/null
+++ b/python/python3-mat2/python3-mat2.info
@@ -0,0 +1,10 @@
+PRGNAM="python3-mat2"
+VERSION="0.13.3"
+HOMEPAGE="https://0xacab.org/jvoisin/mat2"
+DOWNLOAD="https://0xacab.org/jvoisin/mat2/-/archive/0.13.3/mat2-0.13.3.tar.gz"
+MD5SUM="1c0d0890ab620553472e7d58161ec891"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="mutagen"
+MAINTAINER="Lockywolf"
+EMAIL="for_sbo.mat2_2023-05-17@lockywolf.net"
diff --git a/python/python3-mat2/slack-desc b/python/python3-mat2/slack-desc
new file mode 100644
index 0000000000..ebb4a2f750
--- /dev/null
+++ b/python/python3-mat2/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+python3-mat2: python3-mat2 (A metadata removal tool)
+python3-mat2:
+python3-mat2: python3-mat2 is a metadata removal tool, supporting a wide range of
+python3-mat2: commonly used file formats, written in python3: at its core, it's a
+python3-mat2: library, used by an eponymous command-line interface, as well as
+python3-mat2: several file manager extensions.
+python3-mat2:
+python3-mat2:
+python3-mat2:
+python3-mat2:
+python3-mat2: