summaryrefslogtreecommitdiffstats
path: root/python/python3-parso
diff options
context:
space:
mode:
Diffstat (limited to 'python/python3-parso')
-rw-r--r--python/python3-parso/README10
-rw-r--r--python/python3-parso/python3-parso.SlackBuild102
-rw-r--r--python/python3-parso/python3-parso.info10
-rw-r--r--python/python3-parso/slack-desc19
4 files changed, 141 insertions, 0 deletions
diff --git a/python/python3-parso/README b/python/python3-parso/README
new file mode 100644
index 0000000000..290b0c92ff
--- /dev/null
+++ b/python/python3-parso/README
@@ -0,0 +1,10 @@
+Parso is a Python parser that supports error recovery and
+round-trip parsing for different Python versions (in multiple Python
+versions). Parso is also able to list multiple syntax errors in your
+python file.
+
+Parso has been battle-tested by jedi. It was pulled out of jedi to be
+useful for other projects as well.
+
+Parso consists of a small API to parse Python and analyse the syntax
+tree.
diff --git a/python/python3-parso/python3-parso.SlackBuild b/python/python3-parso/python3-parso.SlackBuild
new file mode 100644
index 0000000000..13b02453c1
--- /dev/null
+++ b/python/python3-parso/python3-parso.SlackBuild
@@ -0,0 +1,102 @@
+#!/bin/bash
+
+# Slackware build script for python3-parso
+
+# Copyright 2021 Yth | Pont-en-Royans, France | yth@ythogtha.org
+# Copyright 2017-2021 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=python3-parso
+SRCNAM=${PRGNAM#python3-*}
+VERSION=${VERSION:-0.8.4}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+elif [ "$ARCH" = "aarch64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python3 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ AUTHORS.txt CHANGELOG.rst CONTRIBUTING.md LICENSE.txt README.rst \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/python3-parso/python3-parso.info b/python/python3-parso/python3-parso.info
new file mode 100644
index 0000000000..02cf985a1f
--- /dev/null
+++ b/python/python3-parso/python3-parso.info
@@ -0,0 +1,10 @@
+PRGNAM="python3-parso"
+VERSION="0.8.4"
+HOMEPAGE="https://github.com/davidhalter/parso"
+DOWNLOAD="https://github.com/davidhalter/parso/archive/v0.8.4/parso-0.8.4.tar.gz"
+MD5SUM="c9c186cb65cc7bed8e2751ea94185e78"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Yth - Arnaud"
+EMAIL="yth@ythogtha.org"
diff --git a/python/python3-parso/slack-desc b/python/python3-parso/slack-desc
new file mode 100644
index 0000000000..2b97ca9177
--- /dev/null
+++ b/python/python3-parso/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python3-parso: python3-parso (Python parser)
+python3-parso:
+python3-parso: Parso is a Python parser that supports error recovery and round-trip
+python3-parso: parsing for different Python versions (in multiple Python versions).
+python3-parso: Parso is also able to list multiple syntax errors in your python file.
+python3-parso:
+python3-parso:
+python3-parso:
+python3-parso:
+python3-parso:
+python3-parso: