summaryrefslogtreecommitdiffstats
path: root/python/python3-pyproject-api/python3-pyproject-api.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/python3-pyproject-api/python3-pyproject-api.SlackBuild')
-rw-r--r--python/python3-pyproject-api/python3-pyproject-api.SlackBuild26
1 files changed, 10 insertions, 16 deletions
diff --git a/python/python3-pyproject-api/python3-pyproject-api.SlackBuild b/python/python3-pyproject-api/python3-pyproject-api.SlackBuild
index 5f3a30df6b..fef1bf5318 100644
--- a/python/python3-pyproject-api/python3-pyproject-api.SlackBuild
+++ b/python/python3-pyproject-api/python3-pyproject-api.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for python3-pyproject-api
-# Copyright 2023 Jeremy Hansen jebrhansen+SBo@gmail.com
+# Copyright 2023-2024 Jeremy Hansen jebrhansen+SBo@gmail.com
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -24,7 +24,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-pyproject-api
-VERSION=${VERSION:-1.6.1}
+VERSION=${VERSION:-1.8.0}
SRCNAM=${SRCNAM:-pyproject-api}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -47,20 +47,6 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
set -e
rm -rf $PKG
@@ -76,8 +62,16 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+PYVER=$(python3 -c 'import sys; print("%d.%d" % sys.version_info[:2])')
+export PYTHONPATH=/opt/python$PYVER/site-packages
export SETUPTOOLS_SCM_PRETEND_VERSION=$VERSION
+# Revert unnecessary dependency version requirements
+sed -i 's|2\.0\.1|1\.2\.2|' pyproject.toml # tomli
+
+# Hide warning for packaging>=24 since it resides in /opt/
+sed -i 's|.*packaging.*||' pyproject.toml
+
python3 -m build --wheel --no-isolation
python3 -m installer --destdir=$PKG dist/*.whl