summaryrefslogtreecommitdiffstats
path: root/python/s3cmd
diff options
context:
space:
mode:
Diffstat (limited to 'python/s3cmd')
-rw-r--r--python/s3cmd/README16
-rw-r--r--python/s3cmd/s3cmd.SlackBuild18
-rw-r--r--python/s3cmd/s3cmd.info2
3 files changed, 24 insertions, 12 deletions
diff --git a/python/s3cmd/README b/python/s3cmd/README
index 5d8aa8791a..8d6b7f7c29 100644
--- a/python/s3cmd/README
+++ b/python/s3cmd/README
@@ -1,9 +1,11 @@
-S3cmd is a command line tool for uploading, retrieving and managing data in
-Amazon S3. It is best suited for power users who don't fear command line. It is
-also ideal for scripts, automated backups triggered from cron, etc.
+S3cmd is a command line tool for uploading, retrieving and managing data
+in Amazon S3. It is best suited for power users who don't fear command
+line. It is also ideal for scripts, automated backups triggered from
+cron, etc.
-Optional: python-magic
+Optional: python2-magic
-Before s3cmd can be used it must first be set up. Run 's3cmd --configure' and
-enter in you access key and your secret key and follow the instructions. This
-will create ~/.s3cfg file with your s3 credentials.
+Before s3cmd can be used it must first be set up. Run 's3cmd
+--configure' and enter in you access key and your secret key and follow
+the instructions. This will create ~/.s3cfg file with your s3
+credentials.
diff --git a/python/s3cmd/s3cmd.SlackBuild b/python/s3cmd/s3cmd.SlackBuild
index f54fb81ed4..bde04f19f5 100644
--- a/python/s3cmd/s3cmd.SlackBuild
+++ b/python/s3cmd/s3cmd.SlackBuild
@@ -1,4 +1,4 @@
-#!/bin/sh
+#!/bin/bash
# Slackware build script for s3cmd
@@ -22,10 +22,13 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+cd $(dirname $0) ; CWD=$(pwd)
+
PRGNAM=s3cmd
VERSION=${VERSION:-2.0.2}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -35,7 +38,14 @@ if [ -z "$ARCH" ]; then
esac
fi
-CWD=$(pwd)
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
@@ -59,7 +69,7 @@ sed -i 's|\(doc_path\)+"/s3cmd"|\1|' setup.py
S3CMD_INSTPATH_DOC="/usr/doc/$PRGNAM-$VERSION" \
S3CMD_INSTPATH_MAN="/usr/man" \
-python setup.py install --root=$PKG
+python2 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
@@ -72,4 +82,4 @@ mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/s3cmd/s3cmd.info b/python/s3cmd/s3cmd.info
index bedf4a1af3..45ce4939e8 100644
--- a/python/s3cmd/s3cmd.info
+++ b/python/s3cmd/s3cmd.info
@@ -5,6 +5,6 @@ DOWNLOAD="https://downloads.sourceforge.net/s3tools/s3cmd-2.0.2.tar.gz"
MD5SUM="7e4043186f46a6832ba3fb4d9cb59bb8"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="python-dateutil"
+REQUIRES="python2-dateutil"
MAINTAINER="Larry Hajali"
EMAIL="larryhaja[at]gmail[dot]com"