summaryrefslogtreecommitdiffstats
path: root/system/autoarchive
diff options
context:
space:
mode:
Diffstat (limited to 'system/autoarchive')
-rw-r--r--system/autoarchive/autoarchive.SlackBuild31
-rw-r--r--system/autoarchive/autoarchive.info8
2 files changed, 25 insertions, 14 deletions
diff --git a/system/autoarchive/autoarchive.SlackBuild b/system/autoarchive/autoarchive.SlackBuild
index 7eabcf48a1..3edec57b0c 100644
--- a/system/autoarchive/autoarchive.SlackBuild
+++ b/system/autoarchive/autoarchive.SlackBuild
@@ -1,8 +1,8 @@
-#!/bin/sh
+#!/bin/bash
# Slackware build script for autoarchive
-# Copyright 2014-2016 Dimitris Zlatanidis Orestiada, Greece
+# Copyright 2014-2022 Dimitris Zlatanidis Orestiada, Greece
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -22,10 +22,16 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# 20220402 bkw: Modified by SlackBuilds.org, BUILD=2:
+# - fix broken man page symlink.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
PRGNAM=autoarchive
-VERSION=${VERSION:-1.3.0}
-BUILD=${BUILD:-1}
+VERSION=${VERSION:-2.0.2}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -35,7 +41,11 @@ if [ -z "$ARCH" ]; then
esac
fi
-CWD=$(pwd)
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
@@ -60,14 +70,14 @@ rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
# fix docs path
sed -i 's/share\/doc/doc/' setup.py
@@ -81,7 +91,8 @@ find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | gr
mv $PKG/etc/aa/aa.conf $PKG/etc/aa/aa.conf.new
-find $PKG/usr/man -type f -name "*.?" -exec gzip -9f {} \;
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a README COPYING NEWS PKG-INFO $PKG/usr/doc/$PRGNAM-$VERSION
@@ -92,4 +103,4 @@ cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/system/autoarchive/autoarchive.info b/system/autoarchive/autoarchive.info
index 1dbca30c22..c1ea9bbc7f 100644
--- a/system/autoarchive/autoarchive.info
+++ b/system/autoarchive/autoarchive.info
@@ -1,10 +1,10 @@
PRGNAM="autoarchive"
-VERSION="1.3.0"
+VERSION="2.0.2"
HOMEPAGE="http://autoarchive.sourceforge.net/"
-DOWNLOAD="https://pypi.python.org/packages/71/4a/329d970bee2dc278ecd4523708c4cfd332e91cd2e14617a2057ed9974901/autoarchive-1.3.0.tar.bz2"
-MD5SUM="9d8a371e3dff5a7bfb40d21b4fa85257"
+DOWNLOAD="https://files.pythonhosted.org/packages/a4/cf/99c7f0b26a8bdce00b1e9362d06a4737a426fa1e142435cf284a1f7c4bd2/autoarchive-2.0.2.tar.gz"
+MD5SUM="ee05a3a0ee90c859cbaaa24084ea6155"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="python3"
+REQUIRES=""
MAINTAINER="Dimitris Zlatanidis"
EMAIL="d.zlatanidis@gmail.com"