summaryrefslogtreecommitdiffstats
path: root/system/b2/Makefile.unix.mak.patch
diff options
context:
space:
mode:
Diffstat (limited to 'system/b2/Makefile.unix.mak.patch')
-rw-r--r--system/b2/Makefile.unix.mak.patch11
1 files changed, 11 insertions, 0 deletions
diff --git a/system/b2/Makefile.unix.mak.patch b/system/b2/Makefile.unix.mak.patch
new file mode 100644
index 0000000000..8ef3bf00f2
--- /dev/null
+++ b/system/b2/Makefile.unix.mak.patch
@@ -0,0 +1,11 @@
+--- Makefile.unix.mak. 2023-06-10 11:56:03.000000000 +0100
++++ Makefile.unix.mak 2023-06-21 21:10:15.499776974 +0100
+@@ -52,7 +52,7 @@
+ @echo ---------------------------------------------------------------------------
+ rm -Rf "$(_FOLDER)"
+ mkdir -p "$(_FOLDER)"
+- (cd "$(_FOLDER)" && cmake -G "$(CMAKE_TYPE)" $(CMAKE_DEFINES) -DCMAKE_BUILD_TYPE=$(BUILD) $(if $(SANITIZER),-DSANITIZE_$(SANITIZER)=On) ../..) || $(if $(SANITIZER),rm -Rf "$(_FOLDER)",false)
++ (cd "$(_FOLDER)" && cmake -G "$(CMAKE_TYPE)" $(CMAKE_DEFINES) -DCMAKE_BUILD_TYPE=$(BUILD) $(if $(SANITIZER),-DSANITIZE_$(SANITIZER)=Off) ../..) || $(if $(SANITIZER),rm -Rf "$(_FOLDER)",false)
+
+ .PHONY:buildall
+ buildall: