summaryrefslogtreecommitdiffstats
path: root/system/fsv
diff options
context:
space:
mode:
Diffstat (limited to 'system/fsv')
-rw-r--r--system/fsv/README13
-rw-r--r--system/fsv/fsv.SlackBuild26
-rw-r--r--system/fsv/fsv.info2
3 files changed, 24 insertions, 17 deletions
diff --git a/system/fsv/README b/system/fsv/README
index 7aefe83920..4d15a50ff2 100644
--- a/system/fsv/README
+++ b/system/fsv/README
@@ -1,8 +1,9 @@
fsv (3D file system viewer, Jurassic Park style)
-fsv (pronounced eff-ess-vee) is a file system visualizer in cyberspace. It
-lays out files and directories in three dimensions, geometrically
-representing the file system hierarchy to allow visual overview and
-analysis. fsv can visualize a modest home directory, a workstation's
-hard drive, or any arbitrarily large collection of files, limited only
-by the host computer's memory and graphics hardware.
+fsv (pronounced eff-ess-vee) is a file system visualizer in
+cyberspace. It lays out files and directories in three dimensions,
+geometrically representing the file system hierarchy to allow visual
+overview and analysis. fsv can visualize a modest home directory,
+a workstation's hard drive, or any arbitrarily large collection
+of files, limited only by the host computer's memory and graphics
+hardware.
diff --git a/system/fsv/fsv.SlackBuild b/system/fsv/fsv.SlackBuild
index ec5a93c0a2..9384da8e2f 100644
--- a/system/fsv/fsv.SlackBuild
+++ b/system/fsv/fsv.SlackBuild
@@ -1,17 +1,20 @@
-#!/bin/sh
+#!/bin/bash
# Slackware build script for fsv
-# Written by B. Watson (yalhcru@gmail.com)
+# Written by B. Watson (urchlay@slackware.uk)
# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
# 20170302 bkw: use long-format githhub URL
+cd $(dirname $0) ; CWD=$(pwd)
+
PRGNAM=fsv
VERSION=${VERSION:-0.9_1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -21,7 +24,11 @@ if [ -z "$ARCH" ]; then
esac
fi
-CWD=$(pwd)
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
@@ -51,11 +58,8 @@ rm -rf $PRGNAM-$PRGNAM-$SRCVER
tar xvf $CWD/$PRGNAM-$PRGNAM-$SRCVER.tar.gz
cd $PRGNAM-$PRGNAM-$SRCVER
chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
+ \! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+
# dirty hack: avoid segfaults on exit. This works on Linux because the
# kernel cleans up any allocated memory at process exit, but it will
@@ -71,7 +75,9 @@ sed -i \
-e 's/netscape -no-.* > /firefox %s > /' \
src/dialog.c
-autoreconf -if
+# thanks AUR!
+sed -i 's/@DATADIRNAME@/share/' po/Makefile.in.in
+./autogen.sh
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
@@ -109,4 +115,4 @@ cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/system/fsv/fsv.info b/system/fsv/fsv.info
index 41fa215a04..4db44e51e9 100644
--- a/system/fsv/fsv.info
+++ b/system/fsv/fsv.info
@@ -7,4 +7,4 @@ DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="gtkglarea"
MAINTAINER="B. Watson"
-EMAIL="yalhcru@gmail.com"
+EMAIL="urchlay@slackware.uk"