summaryrefslogtreecommitdiffstats
path: root/system/mksh/TaC-mksh.txt
diff options
context:
space:
mode:
Diffstat (limited to 'system/mksh/TaC-mksh.txt')
-rw-r--r--system/mksh/TaC-mksh.txt258
1 files changed, 258 insertions, 0 deletions
diff --git a/system/mksh/TaC-mksh.txt b/system/mksh/TaC-mksh.txt
new file mode 100644
index 0000000000..5e59d2a528
--- /dev/null
+++ b/system/mksh/TaC-mksh.txt
@@ -0,0 +1,258 @@
+Terms and Conditions - The MirBSD Korn Shell
+============================================
+
+The MirBSD Korn Shell (mksh) consists of a number of "source" files,
+which are provided by upstream in a number of places. This file will
+list the files belonging to mksh or being part of it and the licence
+terms and conditions that apply to them, in one single central place
+for packagers' convenience. This list aims to be authoritative. (Yet
+as it was compiled by a human, there may be bugs, please report them
+if any are found. We don't think so though.)
+
+All paths are relative to The MirOS Project's CVS repository.
+
+
+The following files form The MirBSD Korn Shell R39c:
+- build system, testsuite
+ * mksh/Build.sh
+ * mksh/check.pl
+ * mksh/check.t
+- documentation, configuration
+ * mksh/dot.mkshrc
+ * mksh/mksh.1
+- source code
+ * mksh/edit.c
+ * mksh/emacsfn.h
+ * mksh/eval.c
+ * mksh/exec.c
+ * mksh/expr.c
+ * mksh/funcs.c
+ * mksh/histrap.c
+ * mksh/jobs.c
+ * mksh/lalloc.c
+ * mksh/lex.c
+ * mksh/main.c
+ * mksh/misc.c
+ * mksh/sh.h
+ * mksh/sh_flags.h
+ * mksh/shf.c
+ * mksh/syn.c
+ * mksh/tree.c
+ * mksh/var.c
+ * mksh/var_spec.h
+- upstream provided packaging
+ * contrib/hosted/tg/deb/mksh/debian/** (Debian)
+ * mksh/Makefile (MirBSD only, not part of mksh)
+ * ports/shells/mksh/DEINSTALL
+ * ports/shells/mksh/DESCR (official)
+ * ports/shells/mksh/INSTALL
+ * ports/shells/mksh/Makefile
+ * ports/shells/mksh/PLIST
+ * ports/shells/mksh/distinfo (official)
+ * src/distrib/special/mksh/Makefile (for the MirBSD installer)
+- website (informal)
+ * www/data/tag_mksh.cfg (internal)
+ * www/files/TaC-mksh.txt (this file)
+ * www/pics/mksh.svg (logo source code)
+ * www/pics/mksh128x100.png (logo compiled version)
+ * www/src/mksh.hts (primary webpage)
+ * www/src/mksh_bld.hts (supplemental webpage)
+ * www/src/mksh_old.hts (supplemental webpage)
+
+All of these files are covered by The MirOS Licence (Appendix A) ex-
+cept the upstream provided packaging, some of which were copied from
+other places (specifically some of the Debian packaging) and most of
+which do not require a copyright licence.
+
+The mksh author acknowledges the contribution from the Public Domain
+Korn Shell and everyone who contributed to its various incarnations,
+including patches, which have found their way into mksh (not all are
+even known, but they gave up copyright anyway). The patches and sug-
+gestions from other developers, users and other shells' authors were
+also welcome.
+
+
+The following files belong to mksh and are distributed inside of its
+distfile, but are not part of it. They are provided for convenience,
+because they are required on many operating environments for mksh or
+some of its features to function:
+- source code
+ * mksh/setmode.c (needed for the optional mknod builtin)
+ * mksh/strlcpy.c (always needed)
+
+These files are covered by seperate licences in addition (Appendices
+B and C). Some operating environments already provide their functio-
+nality, such as the BSDs and OSX libc, or the Debian/freedesktop.org
+libbsd package. The files are not compiled into the resulting binary
+if their respective functionality is already provided.
+
+
+The following files belong to mksh in a less close way, as they pro-
+vide additional functionality less closely coupled or not always de-
+sired. These are not included in the mksh distfile:
+- source code
+ * contrib/code/Snippets/arc4random.c (somewhat portable arc4random
+ implementation on top of /dev/urandom - for $RANDOM reads)
+ * contrib/hosted/tg/arc4rootdom.c (an even less portable implemen-
+ tation of a4r_pushb for *WRT/Android/... - for $RANDOM writes)
+ * contrib/hosted/tg/deb/klibc/arc4random.c (part of my klibc patch
+ providing arc4random API on top of jrand48 for small size)
+ * src/usr.bin/printf/printf.c (slightly modified UCB printf utili-
+ ty code - for the optional, undesired printf(1) builtin)
+ *DO NOT* INCLUDE printf AS A SHELL BUILT-IN UNLESS YOU ABSOLUTE-
+ LY MUST (otherwise, the preferrable /usr/bin/printf is called)
+
+The arc4rootdom.c file is covered by the MirOS Licence (Appendix A).
+The klibc/arc4random.c file is also covered by The MirOS Licence but
+dual-licenced with klibc's as we hope it gets included. The printf.c
+file is covered by the UCB's three-clause BSD licence (Appendix B).
+
+The arc4random.c file is a conglomerate of The MirOS Licence as well
+as another but many people have touched this code so there are other
+versions of it around with differing terms. See Appendix D for ours.
+
+
+The MirOS Licence also applies as a collective-work copyright on The
+MirBSD Korn Shell.
+
+Note that these appendices may represent the terms and conditions of
+more than one file, hence the actual wording of the files was folded
+into one representation, with different copyright holders and years,
+separated if merging was undesirable.
+
+
+Appendix A - The MirOS Licence (OSI approved)
+==============================
+
+The MirBSD Korn Shell (mksh) is
+Copyright © 2002, 2003, 2004, 2005, 2006, 2007, 2008, 2009, 2010
+ Thorsten "mirabilos" Glaser <tg@mirbsd.org>
+All rights reserved.
+
+The mksh logo is
+Copyright © 2008, 2009
+ Lukas U. <smultron@midnightbsd.org>
+Copyright © 2008, 2009
+ Thorsten "mirabilos" Glaser <tg@mirbsd.org>
+
+The arc4random for *WRT, Android, klibc functions are
+Copyright © 2009
+ Thorsten "mirabilos" Glaser <tg@mirbsd.org>
+
+
+Provided that these terms and disclaimer and all copyright notices
+are retained or reproduced in an accompanying document, permission
+is granted to deal in this work without restriction, including un‐
+limited rights to use, publicly perform, distribute, sell, modify,
+merge, give away, or sublicence.
+
+This work is provided “AS IS” and WITHOUT WARRANTY of any kind, to
+the utmost extent permitted by applicable law, neither express nor
+implied; without malicious intent or gross negligence. In no event
+may a licensor, author or contributor be held liable for indirect,
+direct, other damage, loss, or other issues arising in any way out
+of dealing in the work, even if advised of the possibility of such
+damage or existence of a defect, except proven that it results out
+of said person’s immediate fault when using the work as intended.
+
+
+Appendix B - The UCB (3-clause BSD) licence (OSI approved)
+===========================================
+
+printf.c is
+Copyright (c) 1989
+ The Regents of the University of California.
+All rights reserved.
+
+setmode.c is
+Copyright (c) 1989, 1993, 1994
+ The Regents of the University of California.
+All rights reserved.
+
+This code is derived from software contributed to Berkeley by
+Dave Borman at Cray Research, Inc.
+
+
+Redistribution and use in source and binary forms, with or without
+modification, are permitted provided that the following conditions
+are met:
+1. Redistributions of source code must retain the above copyright
+ notice, this list of conditions and the following disclaimer.
+2. Redistributions in binary form must reproduce the above copyright
+ notice, this list of conditions and the following disclaimer in the
+ documentation and/or other materials provided with the distribution.
+3. Neither the name of the University nor the names of its contributors
+ may be used to endorse or promote products derived from this software
+ without specific prior written permission.
+
+THIS SOFTWARE IS PROVIDED BY THE REGENTS AND CONTRIBUTORS ``AS IS'' AND
+ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
+IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
+ARE DISCLAIMED. IN NO EVENT SHALL THE REGENTS OR CONTRIBUTORS BE LIABLE
+FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
+DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS
+OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
+HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT
+LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY
+OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF
+SUCH DAMAGE.
+
+
+Appendix C - ISC Licence (OSI approved)
+========================
+
+strlcpy.c is
+Copyright (c) 2006, 2008, 2009
+ Thorsten Glaser <tg@mirbsd.org>
+Copyright (c) 1998
+ Todd C. Miller <Todd.Miller@courtesan.com>
+
+
+Permission to use, copy, modify, and distribute this software for any
+purpose with or without fee is hereby granted, provided that the above
+copyright notice and this permission notice appear in all copies.
+
+THE SOFTWARE IS PROVIDED "AS IS" AND THE AUTHOR DISCLAIMS ALL WARRANTIES
+WITH REGARD TO THIS SOFTWARE INCLUDING ALL IMPLIED WARRANTIES OF
+MERCHANTABILITY AND FITNESS. IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR
+ANY SPECIAL, DIRECT, INDIRECT, OR CONSEQUENTIAL DAMAGES OR ANY DAMAGES
+WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER IN AN
+ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF
+OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
+
+
+Appendix D - Licence of mircvs://contrib/code/Snippets/arc4random.c
+===================================================================
+
+/*-
+ * Arc4 random number generator for OpenBSD.
+ * Copyright 1996 David Mazieres <dm@lcs.mit.edu>.
+ *
+ * Modification and redistribution in source and binary forms is
+ * permitted provided that due credit is given to the author and the
+ * OpenBSD project by leaving this copyright notice intact.
+ */
+
+/*-
+ * This code is derived from section 17.1 of Applied Cryptography,
+ * second edition, [...]
+ *
+ * RC4 is a registered trademark of RSA Laboratories.
+ */
+
+/*-
+ * Modified by Robert Connolly from OpenBSD lib/libc/crypt/arc4random.c v1.11.
+ * This is arc4random(3) using urandom.
+ */
+
+arc4random_uniform() is derived from code written by
+ Damien Miller <djm@openbsd.org>
+published under the ISC licence (see Appendix C).
+
+arc4random.c additionally is Copyright © 2008, 2009
+ Thorsten Glaser <tg@mirbsd.org>
+and covered by the MirOS Licence (see Appendix A).
+
+
+_________________________________________________________________
+$MirOS: www/files/TaC-mksh.txt,v 1.3 2011/03/21 16:22:58 tg Exp $