summaryrefslogtreecommitdiffstats
path: root/system/salt
diff options
context:
space:
mode:
Diffstat (limited to 'system/salt')
-rw-r--r--system/salt/README50
-rw-r--r--system/salt/doinst.sh27
-rw-r--r--system/salt/rc.salt-master.new49
-rw-r--r--system/salt/rc.salt-minion.new49
-rw-r--r--system/salt/rc.salt-syndic.new49
-rw-r--r--system/salt/salt.SlackBuild105
-rw-r--r--system/salt/salt.info10
-rw-r--r--system/salt/slack-desc19
8 files changed, 0 insertions, 358 deletions
diff --git a/system/salt/README b/system/salt/README
deleted file mode 100644
index de96dc0bf1..0000000000
--- a/system/salt/README
+++ /dev/null
@@ -1,50 +0,0 @@
-SaltStack or Salt is a Python-based open source configuration
-management and remote execution engine.
-
-This SlackBuild packages both the master and the minion.
-
-Note: at this time, the pkg and service modules are not available
-(unimplemented) in minions running Slackware.
-
-Optional dependencies include:
- python-ldap
- GitPython
- Mako
- libvirt
- pyOpenSSL
- CherryPy
- pymongo
- python-keyring
- MySQL-python
- redis-py
- python-gnupg
-
-You must configure your master and your minions correctly before using
-salt. For configuration details, please see:
-
- https://docs.saltstack.com/en/latest/ref/configuration/index.html
-
-To start the salt daemons automatically on your systems, you can add the
-following lines to /etc/rc.d/rc.local, and then on each system enable
-only the daemons you actually want, by making the rc scripts executable.
-
- if [ -x /etc/rc.d/rc.salt-master ]; then
- /etc/rc.d/rc.salt-master start
- fi
- if [ -x /etc/rc.d/rc.salt-minion ]; then
- /etc/rc.d/rc.salt-minion start
- fi
- if [ -x /etc/rc.d/rc.salt-syndic ]; then
- /etc/rc.d/rc.salt-syndic start
- fi
-
-On a master, you should enable the salt-master daemon:
-
- chmod +x /etc/rc.d/rc.salt-master
-
-On a minion, you should enable the salt-minion daemon:
-
- chmod +x /etc/rc.d/rc.salt-minion
-
-You probably won't want to enable the salt-syndic daemon unless you have
-configured a complex topology.
diff --git a/system/salt/doinst.sh b/system/salt/doinst.sh
deleted file mode 100644
index 7af961a5ca..0000000000
--- a/system/salt/doinst.sh
+++ /dev/null
@@ -1,27 +0,0 @@
-config() {
- NEW="$1"
- OLD="$(dirname $NEW)/$(basename $NEW .new)"
- # If there's no config file by that name, mv it over:
- if [ ! -r $OLD ]; then
- mv $NEW $OLD
- elif [ "$(cat $OLD | md5sum)" = "$(cat $NEW | md5sum)" ]; then
- # toss the redundant copy
- rm $NEW
- fi
- # Otherwise, we leave the .new copy for the admin to consider...
-}
-
-preserve_perms() {
- NEW="$1"
- OLD="$(dirname $NEW)/$(basename $NEW .new)"
- if [ -e $OLD ]; then
- cp -a $OLD ${NEW}.incoming
- cat $NEW > ${NEW}.incoming
- mv ${NEW}.incoming $NEW
- fi
- config $NEW
-}
-
-preserve_perms etc/rc.d/rc.salt-master.new
-preserve_perms etc/rc.d/rc.salt-minion.new
-preserve_perms etc/rc.d/rc.salt-syndic.new
diff --git a/system/salt/rc.salt-master.new b/system/salt/rc.salt-master.new
deleted file mode 100644
index d4c851f5a5..0000000000
--- a/system/salt/rc.salt-master.new
+++ /dev/null
@@ -1,49 +0,0 @@
-#!/bin/sh
-# Start/stop/restart salt master
-
-PIDFILE=/var/run/salt-master.pid
-LOGFILE=/var/log/salt/master
-# LOGLEVEL: One of: all, garbage, trace, debug, info, warning, error, quiet
-LOGLEVEL=warning
-
-# Start salt-master:
-salt_master_start() {
- if [ -x /usr/bin/salt-master ]; then
- echo "Starting salt-master daemon: /usr/bin/salt-master"
- /usr/bin/salt-master -d \
- --pid-file=$PIDFILE \
- --log-file=$LOGFILE \
- --log-file-level=$LOGLEVEL
- fi
-}
-
-# Stop salt-master:
-salt_master_stop() {
- if [ -s $PIDFILE ] ; then
- kill $(cat $PIDFILE)
- else
- killall salt-master
- fi
- rm -f $PIDFILE
-}
-
-# Restart salt-master:
-salt_master_restart() {
- salt_master_stop
- sleep 1
- salt_master_start
-}
-
-case "$1" in
-'start')
- salt_master_start
- ;;
-'stop')
- salt_master_stop
- ;;
-'restart')
- salt_master_restart
- ;;
-*)
- echo "usage $0 start|stop|restart"
-esac
diff --git a/system/salt/rc.salt-minion.new b/system/salt/rc.salt-minion.new
deleted file mode 100644
index f699a12f25..0000000000
--- a/system/salt/rc.salt-minion.new
+++ /dev/null
@@ -1,49 +0,0 @@
-#!/bin/sh
-# Start/stop/restart salt minion
-
-PIDFILE=/var/run/salt-minion.pid
-LOGFILE=/var/log/salt/minion
-# LOGLEVEL: One of: all, garbage, trace, debug, info, warning, error, quiet
-LOGLEVEL=warning
-
-# Start salt-minion:
-salt_minion_start() {
- if [ -x /usr/bin/salt-minion ]; then
- echo "Starting salt-minion daemon: /usr/bin/salt-minion"
- /usr/bin/salt-minion -d \
- --pid-file=$PIDFILE \
- --log-file=$LOGFILE \
- --log-file-level=$LOGLEVEL
- fi
-}
-
-# Stop salt-minion:
-salt_minion_stop() {
- if [ -s $PIDFILE ] ; then
- kill $(cat $PIDFILE)
- else
- killall salt-minion
- fi
- rm -f $PIDFILE
-}
-
-# Restart salt-minion:
-salt_minion_restart() {
- salt_minion_stop
- sleep 1
- salt_minion_start
-}
-
-case "$1" in
-'start')
- salt_minion_start
- ;;
-'stop')
- salt_minion_stop
- ;;
-'restart')
- salt_minion_restart
- ;;
-*)
- echo "usage $0 start|stop|restart"
-esac
diff --git a/system/salt/rc.salt-syndic.new b/system/salt/rc.salt-syndic.new
deleted file mode 100644
index c8986e21a2..0000000000
--- a/system/salt/rc.salt-syndic.new
+++ /dev/null
@@ -1,49 +0,0 @@
-#!/bin/sh
-# Start/stop/restart salt syndic
-
-PIDFILE=/var/run/salt-syndic.pid
-LOGFILE=/var/log/salt/syndic
-# LOGLEVEL: One of: all, garbage, trace, debug, info, warning, error, quiet
-LOGLEVEL=warning
-
-# Start salt-syndic:
-salt_syndic_start() {
- if [ -x /usr/bin/salt-syndic ]; then
- echo "Starting salt-syndic daemon: /usr/bin/salt-syndic"
- /usr/bin/salt-syndic -d \
- --pid-file=$PIDFILE \
- --log-file=$LOGFILE \
- --log-file-level=$LOGLEVEL
- fi
-}
-
-# Stop salt-syndic:
-salt_syndic_stop() {
- if [ -s $PIDFILE ] ; then
- kill $(cat $PIDFILE)
- else
- killall salt-syndic
- fi
- rm -f $PIDFILE
-}
-
-# Restart salt-syndic:
-salt_syndic_restart() {
- salt_syndic_stop
- sleep 1
- salt_syndic_start
-}
-
-case "$1" in
-'start')
- salt_syndic_start
- ;;
-'stop')
- salt_syndic_stop
- ;;
-'restart')
- salt_syndic_restart
- ;;
-*)
- echo "usage $0 start|stop|restart"
-esac
diff --git a/system/salt/salt.SlackBuild b/system/salt/salt.SlackBuild
deleted file mode 100644
index d4f286b88b..0000000000
--- a/system/salt/salt.SlackBuild
+++ /dev/null
@@ -1,105 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for salt aka saltstack
-
-# Copyright 2016 David Spencer, Baildon, West Yorkshire, U.K.
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM=salt
-VERSION=${VERSION:-2018.3.3}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python setup.py install --root=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/etc/$PRGNAM
-cp -a conf/* $PKG/etc/$PRGNAM
-
-mkdir -p $PKG/etc/rc.d
-cp $CWD/rc.* $PKG/etc/rc.d
-
-mv $PKG/usr/share/man $PKG/usr/man
-rmdir --ignore-fail-on-non-empty $PKG/usr/share
-cp -a doc/man/salt.1 $PKG/usr/man/man1/
-
-find $PKG/usr/man -type f -exec gzip -9 {} \;
-for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a AUTHORS HACKING.rst LICENSE README.rst $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-cat $CWD/doinst.sh > $PKG/install/doinst.sh
-
-cd $PKG
-
-for i in $( find etc/$PRGNAM -type f ) ; do
- mv $i $i.new
- echo "config $i.new" >> $PKG/install/doinst.sh
-done
-
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/system/salt/salt.info b/system/salt/salt.info
deleted file mode 100644
index 16ed078146..0000000000
--- a/system/salt/salt.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="salt"
-VERSION="2018.3.3"
-HOMEPAGE="https://saltstack.com/community/"
-DOWNLOAD="https://files.pythonhosted.org/packages/source/s/salt/salt-2018.3.3.tar.gz"
-MD5SUM="13ba421e4bea1f33617b30b1116a9d32"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="msgpack-python PyYAML Jinja2 MarkupSafe python-requests singledispatch tornado futures zeromq pyzmq pycrypto"
-MAINTAINER="David Spencer"
-EMAIL="baildon.research@googlemail.com"
diff --git a/system/salt/slack-desc b/system/salt/slack-desc
deleted file mode 100644
index 0698d964a9..0000000000
--- a/system/salt/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-salt: salt (configuration management engine)
-salt:
-salt: SaltStack or Salt is a Python-based open source configuration
-salt: management and remote execution engine.
-salt:
-salt: Note: at this time, the pkg and service modules are not available
-salt: (unimplemented) in minions running Slackware.
-salt:
-salt: Homepage: https://saltstack.com/community/
-salt:
-salt: